Cant get new blindwrite to work?

could anyone tell me why I dont seem to be able to get the new blindwrite suite to run correctly?
I used the program many months ago and with all the excitement
regarding 1:1 copies of newer securom news I thought I would give it a go!
But no luck it installs ok patin couffin drivers but when I try to image up a cd ex. new lord of rings securom 4.8 or any for that matter it starts off ok then after a few minutes it locks up and freezes and the reading drops off to nothing and the drive light just stops. doesnt matter if I use my liteon or asus drive most frustrating any ideas out there ??? Im baffled tried reinstall no go???

please post a full report of your hardware.

eventually got it to read a full disc BUT only when I removed the pattin driver ??? adaptec worked ok ? any ideas?
my cd writers are a liteon 48125w and a asus 3212a using windows me.
By the way IT WORKS !!!
copying a securom4.8 disc YIPPEE congratulations blindwrite vso team you are amazing I couldnt believe it when the disc actually ran well done team what a result!!! thank you .

Sorry what are you saying? The SecuROM disc is backed up correctly only if u remove the patin couffin driver and use the Windows ASPI layer?

So you made a 1:1 of the PC game “Lord of the Rings”?