Can't get it to flash in DOS: HELP!

vbimport

#1

Hi,
I’m a Mac user trying to flash my 2510a on a PC in DOS and it ain’t working. It’s an old Gateway running Windows95. I thought I was following Herries FAQ instructions to the letter, but I keep on getting “Bad command or filename”. I’ve tried guessing at what might be wrong with the syntax :confused:
I downloaded the FW and used WINRAR to put it in a “firmware” folder on C:
I re-started in DOS and got:
C:\WINDOWS>
I typed nec2x10a.exe -sec -mas -flash 107v2b5d.bin
and got the error message
I’ve tried playing with the name of the drive (is that x supposed to be in there?), and with adding more directory path info to the FW filename: C:\firmware\1107v2b5d.bin
all to no avail.
The jumper on the burner is where it was when it arrived, in the “master” position. I’m not sure about primary / secondary IDE thing.
I really have no idea what I’m doing here, so any help at all would be greatly appreciated.
Thanks!
Albo


#2

from DOS prompt
type the following

CD C:
CD C:\firmware
nec2x00a.exe -sec -mas -flash 107v2b5d.bin

PS the filename of the flasher, its normally as i’ve typed it nec2x00a.exe


#3

Thanks again Dee,
Reading your post made me realize one important thing: I don’t have the nec2x00a.exe firmware flasher on the computer! Herrie doesn’t mention it in his FAQ.
I’ll download it now. Should I put it in the same “firmware” folder that I made on C:?
Looking at your instructions I don’t understand how I get the line-breaks;
CD C:\
CD C:\firmware
nec2x00a.exe -sec -mas -flash 107v2b5d.bin

won’t pressing enter just give me an error message? Like I said; I know nothing about this stuff. This is probably the fifth time in my life that I’ve turned on a PC, and I sure don’t know no DOS!
And while I’m asking questions: when (if) I get it to flash, once it’s finished how do restart the computer? Control/Alt/Delete? or a command-line thing?
Thanks for your help!
ALbo


#4

yep, put flasher in same folder

re commands
hit return/enter after each command/line is typed

control/alt/del will restart
or just hit reset button :wink:


#5

Thanks Dee,
It worked like a charm with your detailed instructions. Now the only problem is that that the drive is doing all kinds of weird things in my Mac: I can’t erase RW discs, and the drive itself keeps on disappearing when I eject disks, so I have to reboot, and even then the computer still won’t recognize the drive sometimes.
I stuck the drive in a PC again (a Dell running XP home) and everything works fine, so it’s not the drive; I assume the Mac is having trouble with the new firmware.
I want to flash the original firmware back into the drive, now that I’m such a pro with DOS :wink: and put it back in my Mac to have a baseline to work from, and then I guess I’ll have to experiment with other firmware.
I found a binary of the 2.15 firmware from the Dangerous Brothers: am I right to assume that I just use the same process I used for the first flashing but with the file names changed?
And lastly: I’d like to write up a revised version of Herries FAQ to include the info that made it possible for me to do it, and I want people to take a look at it before I send it to Herrie: I’ll try to get it together and start a new thread with it in the next few days. This forum is so great and I’d really like to give something back to make things easier for others to do the flashing thing.
Albo


#6

Yes just use the same method, only use this firmware 2.16 its better than the 2.15 firmware :wink:
http://herrie.rpc1.org/downloads/2x00/2510/2510216d.rar