Can't get DMA to work with LTD-165H

Hi there,

I recently bought a ltd-165h dvdrom drive. I tried to enable dma on this thing, but it keeps pio-mode.
The config is:
ide1 : hrddrive Master, cdr(ltr40125s) Slave
ide2 : harddrive master, dvd slave

I use xp as os.

any suggestions?

Check the system BIOS to make sure that detection of UDMA for the Lite-on is automatically enabled. There are many reports of WinXP dropping UDMA support for CD/DVD type devices.

Usually, this can be fixed by uninstalling the secondary IDE channel that your DVD-ROM is on. After rebooting, WinXP will reinstall the IDE channel and redetect the Lite-on drive.

Hopefully, this time it will recognize and connect it as a UDMA 33 device.

You may wish to try putting both HD’s onthe primary channel and CD/DVD on secondary. Some boards will perform better this way.

Hi there I had the same problem on a LTD163 the solution is easy

“quote”

hello cockney kid…my ltd163 sometimes goes into PIO mode if I put a disc in thats either dirty or for some reason not playable immediately by the dvd drive…it tries to access these disc’s for a few minutes then I know its gone into PIO mode because my mouse pionter becomes ‘jerky’…the way to correct this is to go into ‘device manager’ (right click on my computer then go to properties-hardware.- device manager…then look for ata-atapi controllers in the list, click the plus sign and choose the channel your dive is on “primary or secondary”…then right click on channel and choose uninstall…ignore any warnings win xp gives and simply reboot …it will re-detect your drive on bootup and ask you to reboot one further time after that…it should then have changed to udma2…(ata33)…any problems get in touch…davros

or go here to the original post: http://club.cdfreaks.com/showthread.php?s=&threadid=48083&highlight=PIO+mode

this will work

best regards Lee :bigsmile:

Thanks for your replies !

Uninstalling the ide ports did the trick.
Now the device manager reports for the DVD udma 2 and for my cdr ( Lite-on LTR-40125S) udma 1.

But is this correct? shouldn’t it be 3 and 2 ?

I ask this, because when i boot my computer i see that dvd udma=3 and cdr udma=2
Also my harddrives should be both udma 4, but is the win device manager they are reported as udma 3. And if i must believe Sisoft Sandra 2002, my harddrives are both capable of udma 6.

What’s the deal here?

Hi all,

UDMA 6! I have the western digital 120gb WD1200JB with 8mb cache and this registers UDMA 5. It’s supposed to be one of the fastest ide HDD around.

U don’t say what spec your system is?

have you looked on the manufacturers site for spec details and any problems with certain O/S if the hardrive is a year or two old there might be updated drivers, check the motherboard site as well. If it has via chipsets download the latest 4-in-1 drivers they may make a big difference:

http://www.viaarena.com/?PageID=2

hope this helps

best regards Lee

Go here: http://www.pcguide.com/ref/hdd/if/ide/modesUDMA-c.html to find a very concise explanation of UDMA modes etc

best regards Lee :bigsmile:

Thanks 4 ur input Capt Opitcal.

‘Problem’ solved: My mobo doesn’t support udma100, only 33 and 66 are supported.

About the udma6 thingy: this is info from Sisoft Sandra 2002. I don’t know where it got udma 6 from, according to the links you provided it doesn’t exist…

Grtz, Etraman

No problem Etraman, I think sissoft sandra may be getting the defining standards and the modes mixed up.

UDMA Mode 5 relates to atapi 6 as a defining standard and i think thats what it relates to.
They mean mode 5 but bring up mode 6=atapi 6 :confused: Sheeez!

Mode 0
240
16.7
ATA/ATAPI-4

Mode 1
160
25.0
ATA/ATAPI-4

Mode 2
120
33.3
ATA/ATAPI-4

Mode 3
90
44.4
ATA/ATAPI-5

Mode 4
60
66.7
ATA/ATAPI-5

Mode 5
40
100.0
ATA/ATAPI-6?

they do it to keep us confused lol! glad to hear it’s all sorted though, I love these forums :bigsmile:

UDMA 1. :confused: The LTR-40125S normally connects in UDMA 2 (33 MB/s). UDMA 1 (25MB/s) is a nonstandard setting, although the drive should perform just as well if it is connecting in UDMA 1 mode.

UDMA 6 (133 MB/s) is a valid specification and was introduced by Maxtor in September of 2001. If you have newer Maxtor drives, they probably have ATA/133 capability with a UDMA 6 controller.