Cant get BOTH drives to DMA Enable

I recently added a new DVDrom drive and for some reason, whichever one is hooked up to the second connector stays in PIO and its WAY too slow to use. I dont know what else to do. Someone help!

Go into BIOS and make sure all IDE positiions are set to “auto”.

Hi :slight_smile:
Take a look here.

Some MOBOs are very limited on their IDE channels. I had two boxes that UMDA4 would only work on the master. Also some drives do not play well with others! If you have two drives that want to be a master then you are hosed! Also check your jumpers on the back of your drive one more time!

And some motherboards have bugs in them that screw up UDMA ability in confusing ways. Consider my silly MSI K7T Turbo2 :

  • connecting any optical drives to secondary IDE channel will result in them being PIO only
  • NOTHING will enable UDMA for them on that channel, I tried virtually everything from BIOS settings to hacking the registry to playing around with IDE drivers, IDE cables, jumpering etc)
  • Switching the drives to primary made both drives work at UDMA2 as they should have
  • Oddly enough, switching the hard disk to the secondary resulted in it still working at UDMA5.

I gave up trying to understand computers a long time ago.

Flash your BIOS at your MOBO site! Can’t hurt! Like two asperins and call me in the morning! LOL

thx to the forum here i solved the issue by deleting my IDE channel
after a reebot both drives were in UDMA 2 mode
thx board!