Can't flash drive

I can’t flash my artec vom 12e48x with my modified firmware(used ala’s MCSE to include INFOME R20-000 support) then ANY firmware. I tried mtkflash 1.83 and mtkflash 1.69(provided with firmware) in both DOS and windows.
firmware name: 100d500c.bin
What’s to do next?

commands I tried : c:/firm/mtkflash 1 w /b /m 100d500c.bin
switched drive to sec slave: c:/firm/mtkflash 1 w /b /m 100d500c.bin

Try this in pure dos.

Secondary master: mtkflash 3 w /b /m 100d500c.bin

Secondary slave: mtkflash 4 w /b /m 100d500c.bin

That’s what i did. I already stated that in my first post. Used a DOS boot disk.
At first the drive was set as secondary slave and I used the ‘4’ then switched it to primary master( my hdds are SATA ) and used the ‘1’

You have a 1, which means primary ide channel and master.

I can’t see that you tried with a 3 or 4 anywhere in your 1’st post.

Mtkflash explained. http://dhc014.rpc1.org/howto.htm

no kidding :rolleyes:

U SEE ‘1’ IN MY FIRST POST BECAUSE I copy/pasted in a rush AND COULDN’T EDIT AFTER POST. :a

the command I used are correct. First the drive was sec slave then I phisically(like i could do this in other way) moved it to primary ide, set jumper to master hence the ‘1’ I used in the command

If your hard drive is NTFS it might not work!!!
Why do flash under your “C” hard drive??? Keep your file into a floppy and flash it straight from your floppy !!!

it’s Fat32 all the way.I don’t like NTFS

IT might be that mtkflash cannot read from a SATA hdd but i don’t think so because it runs.
The errors I get are ~’ cannot open input file ’ or ’ can’t access cd-rom’