Can't find firmware for LiteOn DH18A1P multi burner

Hi,

I recently bought a new PC and i’ve been burning a few verbatim dvd+r 16x blanks, but my burner won’t burn at anything above 2.4x.

i’ve tried Nero and Ashampoo and get the same problems both times.

In the device manager, the drive shows up as “ATAPI DVD A DH18A1P ATA Device”, but from reading this forum, I understand it is actually a LiteOn drive.

The drive itself is a multi format burner that can also burn DL and DVD RAM discs, along with all the usual stuff.

Oh, and i’m using Vista home basic as well (legal copy…).

I’ve checked the DMA settings on the drive and they’re fine, but I do actually think the problem is firmware.

I used a firmware checker and from what I can remember about the result, it said the firmware version was something like “ZX15” - and I was reading somewhere else that someone had the same drive as me with firmware of “ZX16”, so I’m thinking I maybe need to flash the drive with the latest firmware.

Problem is, I can’t find it !

I’ve looked on the LiteOn sites, and the unofficial firmware pages, and searched for “DH18A1P” and nothing that looks like a firmware update appears, so I’m a bit stuck.

If anyone can point me in the right direction i’d be hugely grateful … thanks.

just to follow that up, i used the nero info tool to get more information and got this regarding the drive …

Drive : ATAPI DVD A DH18A1P
Type : DVD±R/RW DL Recorder
Firmware Version : ZX15
Buffer Size : 2 MB
Date : 2006-10-25
Serial Number : n/a
Vendor Specific : 2006/10/25 17:26
Drive Letter : E:
Location : 2:0
Mechanism : Tray
Read Speed : 16.0 , 12.0 , 8.0 , 6.0 , 4.0 , 2.0 , 1.0 X
Write Speed : 16.0 , 12.0 , 8.0 , 6.0 , 4.0 , 2.4 X

the closest i can find on the codeguys firmware page is firmware for a LiteOn LH-18A1P.

I’m willing to give it a try, but I don’t really want to kill my drive just yet :slight_smile:

Hi & welcome, - the problem you describe will not be solved by a firmware update. The slow speed is typically related to DMA and your drive should show 'Ultra DMA Mode 4" under “Current Transfer Mode” in Device Manager (follow this guide ).

Other than that, you probably have an OEM-drive with OEM firmware in your PC and the only place to get new firmware is with the PC manufacturer. Keep in mind that using any other firmware will void your warranty.

Good luck!

the DMA is fine - it’s already set to Ultra DMA Mode 4. it’s one of the first things I checked.

The only other thing I can think of is a conflict with Daemon tools ??

I’ve got that installed as well.

I’ll get hold of the manufacturer though, i think that might be the only solution.

Thanks for your help :bow:

I did notice someone else with a similar drive and problem here: http://club.cdfreaks.com/showthread.php?t=219102 . Does your PC’s mainboard use an nVidia chipset as well?

I don’t think so - the graphics card is a VIA Chrome9, for the record.

But i’ve checked through the device manager and nothing suggests there are any NVidia drivers anywhere.

I know one thing I used to do with my old PC is to delete the IDE channels and reboot, so it would re-install them but as this is a brand new PC that’s only about 5 weeks old, i’m slightly reluctant to do that …

Anyway, I think it’s an ATA driver for the burner anyway …

There’s an IDE controller in the IDE ATA/ATAPI controllers, but the rest are ATA.

If that made sense :slight_smile:

Then you have a VIA chipset, but it looks like you’re using the standard Vista IDE driver (which presumably is fine). You can safely “Uninstall” that IDE channel (which must be the one showing Ultra DMA Mode 4, right?) and reboot.

Next time you burn a disc with Nero, save a log and post it here.

Did that and it’s re-installed fine … phew … heh … i knew it would, but i know my luck is such that it would probably have melted the motherboard.

anyway, just going to go away and try and burn another dvd with ashampoo at 16x, so i’ll save the error log and post it here.

cheers for all your help so far … :bow: :bow:

just tried burning another compilation disc in ashampoo at 16x and it’s failed again, and it’s given me “a ‘medium error’ occured while recording a CD/DVD/Blu Ray disc”

i realise that probably doesn’t help so i’ll have to re-install nero and get an actual error log file … :a

Are you using an 80 wire ide cable?

He couldn’t be in UDMA4 if he wasn’t.

well i’m officially jiggered :slight_smile:

i’ve just finished burning a compilation in nero at 16x and it burnt 100% ok.

it was 19 short video clips, with a simple menu and i’ve just played it on my DVD recorder and it plays fine. (and no, it wasn’t a porn compilation :D)

I’ll have to do some more testing though - i’ll back up a few movies and see how that goes before I throw a party, but it seems as if uninstalling the ATA Channel 0 and rebooting has apparently solved the problem.

I say that because it’s the one thing I hadn’t tried beforehand, so I’m just assuming that’s done the trick.

Anyway, i’ll uninstall ashampoo, do some backups and see how I go …

Well that was strange.

I backed up my copy of “casino royale” (which i legally own, legal fans :)) this morning using dvd fab decrypter and nero recode, and set it to burn at 16x.

i had to go out, so i checked the ‘shutdown when done’ button and when I got back later on, it had indeed shut down so i assumed it had completed. i put it in my DVD recorder and it failed to recognise the disk - it gave an ‘unknown disc’ error, so it obviously wrote something.

anyway, i ran a lens cleaner on the burner, and restarted the whole procedure with recode and set it to burn at 8x. it gave me an error almost as soon as it started writing the lead-in (no error log though …), so I selected ‘burn this project again’ and set it at 8x again - and it burnt the copy 100% fine !!

it plays in my dvd recorder absolutely spot on, no skipping or freezing or anything.

so i don’t know …

i’m running out of blanks, so i’ll have to maybe try one more film and see what happens.

Well i eventually bought a new box of blanks and I’m pretty much back to square one.

I’ve even opened up the box to get the drive serial number, which is “108701408574” - and the full ID code for the drive is actually “DH18A1P022C” and I’ve searched everywhere.

it would help if the technical support department at the place I bought the PC weren’t idiots because when I told them i needed the update firmware, they told me to go to the manufacturers website.

I emailed them back and said “i thought you were the manufacturers” :smiley:

anyway, finding this firmware is becoming a bit of an obsession now … i WILL find it or die in the bloody attempt

well it’s official … i have the drive with no name :slight_smile:

i’ve just finished physically removing the whole thing from my box and poring over it in an attempt to find anything resembling a manufacturer and … nothing

Read up on the EEPROM Utility and the Flash Utility and you should be able to make it a Lite-On LH-18A1P with the firmware available at codeguys.rpc1.org (after backing up your original EEPROM and firmware first).

(Note: voids warranty & at your own risk.)

nice one … will do.

thanks :slight_smile:

ok, i don’t like the look of how this went …

this is what i did …

I downloaded the EEPROM utility and made a backup into a seperate folder - no problems.

I downloaded the ltnFW flash tool to make a backup of the firmware - I used the “compare” option to verify the backup - no problems.

I then went back to the EEPROM utility and selected “Upgrade drive”.

It had flagged the option “18A1P + DW1800” with “<- current model” and was offering me the “18A1H + DW1810” with the check box filled in, so I selected “OK” and the operation completed with no errors.

I downloaded the LiteOn LH-18A1P firmware from the codeguys site, but when I ran the “EXE” file, it was still detecting the old “DH” drive.

So I downloaded the xflash utility to extract the firmware bin file from the exe file, and used the flash utility to re-flash it to the 18A1P-GL0G firmware.

the operation completed without any errors, so I rebooted just to be certain.

In the control panel, the drive now shows up as “LITE-ON DVDRW LH-18A1P ATA Device” and when I rebooted, the drivers were automatically installed - all with no error.

I even used the Nero Information tool, and it scanned the drive fine - control panel says the drive is working properly.

Now, here comes the problem.

At the moment, the drive light is just continually blinking on and off and if I insert a disc, it doesn’t recognise anything.

i thought i might use my lens cleaner just in case, but when i inserted that, nothing happened either.

So i’m hoping that I haven’t killed it … i’ve got backups (thank the lord !) of the EEPROM and Firmware, so I can restore it (hopefully…) but is there a fix ?

Have i done something stupid ?

Please put me out of my misery ! Thanks !