Can't enable autoplay on dvd drive

Hi, I have a Maxtor PLEXTOR DVDR Drive and I can’t seem to get it to prompt me everytime I put a disc in. I want it to ask me what program I want to pick but it just wont do it, It’s on “Prompt me each time to choose an action” but it still doesn’t. Even after restart it doesn’t prompt me, have any ideas? I’ve already went to My computer, properties of drive and checked and it’s on “Prompt me each time to choose an action” and it doesn’t work… :frowning:

Copy/paste the following text into a file with a “.reg” extension and then double-click on it and reboot afterwards.

Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"=dword:00000001
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

;Enables Auto Insert Notification + AutoRun/AutoPlay.

CU, Martin.

This works for me when I have that problem.

Autoplay Repair Wizard

You need to recreate the problem while the wizard is running. You also need to reboot afterwards.

Martin, it still doesn’t prompt me even though I installed XP again…

Could it be my dvd-drive? If so, how can I fix it?

Try this method.

  1. Go to Start button and select “Run”
  2. Type [B]gpedit.msc[/B] and press return
  3. Browse the tree searching for the following path: [B]computer configuration\administrative templates\system urn off autoplay[/B]
  4. Double click on [B]turn off autoplay[/B] and select [B]DISABLED[/B]
  5. Do the same thing in the following path: [B]user configuration\administrative templates\system urn off autoplay[/B]

Be sure to set this option both in [B]computer configuration[/B] and in [B]user configuration[/B], or there could be a conflict.

Thank Geno888, the prompt only appeared once though, but look like the bright side, those 2 files were conflicting with my dvd’s loading speed. Now it reads dvds at the speed it always did.


Edit: Nevermind, I got the prompting to work fine, thanks Geno888, but one question, would I need to do this everytime I reformat with Windows or will it save in the DVD Drive?

And since I got help on my dvd’s loading speed without even asking, maybe you can help me enable my dvd-drive to read CD-R again?

I also wouldn’t mind live help.

AIM:Freezingwind

Hmm, those group policy “Turn off AutoPlay” options isn’t supposed to be enabled on a clean install of Windows XP. Btw, my second reg key are the same one that’s set by enabling AutoPlay with MS’s Tweak UI PowerToy and the first reg key simply enables Auto Insert Notification if it was disabled, which would mean that AutoPlay also wouldn’t work as it relies on that feature. Also, if not rebooting after applying the reg fix, then the change isn’t applied yet, and still won’t work.

Nonetheless, i’m glad you got it working right in the end with the help of geno888 :slight_smile:

CU, Martin.

You’re welcome :slight_smile:

As already said Martin, those group policy “Turn off AutoPlay” options isn’t supposed to be enabled on a clean install of Windows XP :slight_smile:

About CD discs, sorry, but I don’t understand: what is the problem exactly?

It just doesn’t read them anymore…

When I first got the computer it was able to read both CDs and DVDs, now it only reads DVDs, I don’t know what to do to make it read CDs again.

Any ideas?

It could be a damaged drive. To exclude completely a software problem, you can do a simple test trying to boot your computer from a CD.

To do this test you can use for example a live CD like slax or knoppix (both free linux distros that can run from a CD disc without installing anuthing on your computer)

I found out what was causing Autoplay to be disabled no matter what, it was Alcohol 120%, when I put the virtual drive it enabled turn off autoplay. So, is there a way I can use it still, or would you recommend a different virtual drive program?


2 mins later…

Now Autoplay is completely disabled once again, even with the “Turn off Autoplay” disabled. Any clue now?

The dvd drive also takes longer to read a disc now…

Try to uninstall at all Alcohol to see if this solve. Maybe there is some compatibility problem with your mainboard. Try to send a report to Alcohol developers: maybe they can solve it in a future version :slight_smile:

I uninstalled it last night, and it’s still disabled.

hmm… probably a fresh installation of windows is the better way to restore anything :frowning: