Can't disable DMA/Issues with DVD-ROM

vbimport

#1

Okeedokee, here comes another newbie. I gots me a TSSTcorp TS-H552B (I think; may have switched a digit or two) that’s being something of a prat. I foolishly enabled DMA through Nero 6 because a wee little dialogue box said I oughta, and now the drive refuses to spin up/access/exist. Prima donna.

I believe the DMA was disabled initially, though I’m not sure if this was the base setting upon install or if I disabled it at some point without knowing or if Nero even knew what it was talking about. Now that I have in theory enabled it, the problems began, which is why I’m thinking that’s the prob.

Trying to do any of the following cause a momentary or permanent system freeze:

-Inserting a DVD, movie or game, the drive trying to autoplay or spin up
-Trying to access the drive (empty) through anything, be it WinExplorer, burning software, or game with disc inserted
-Device Manager coughs a brick when I try to access the drive properties to get at the DMA settings–it freezes and halts any other processess–any at all, from opening a document to running something–from fully initializing

I can go as far as to left click the sucker in WinExplorer and bam, frozen. What I am guessing I need to do is disable the #$^@ DMA, but how to do that w/o Device Man or right-clicking or otherwise directly talking to the drive, I dunno. I have tried removing the drive thru D-Man, and no freeze, and upon restart/redetect Windows again found the drive, no prob–but the same issues persist. Of course, I have no idea if the DMA is really an issue here, but my admittedly simple powers of deduction made me think so: Painkiller DVD worked nice n’ pretty before; DMA enabled thru Nero -> Painkiller = no work no more. :confused:

Thanks for enduring my rambling, newbishness, and here’s hoping for some ideas from the guys with the techie brains. :bow:


#2

Read this about DMA. You WANT DMA enabled.
http://forum.digital-digest.com/showthread.php?t=61905


#3

Uninstall the burner in device manager :wink:
Uninstall the ide in device manager & reboot.

Right click “My computer” ->Properties->Advanced-> Device Manager.

And as stated above, DMA on is good.

DMA off makes your burner slower than a 90yr old woman with a broken hip.


#4

Very helpful thread, thanks for the reference; but on both Primary and Secondary channels, UDMA is already active. Primary is using Mode 5 and Secondary is Mode 2…since it’s not PIO-ing on me, I assume I don’t need to reinstall…?

Thanks again, the quick reply is appreciated. I figured DMA was a good thing, but ever since I enabled it on the DVD drive itself, I’ve had these issues. Any other ideas?


#5

Uninstall & reinstall nero :wink:


#6

Maybe try a new cable and/or make sure that the device jumper is correctly set to match it’s position on the cable, ie jumper in master position then end connection, jumper in slave position then middle connection.


#7

Danke to all. I’m gonna try nuking the drive and the IDE…assume you meant Secondary only, debro? I’m positive the cables are connected and the jumps are kosher 'cause I was just in the box not too long ago adding a SATA HDD and a new PSU, so played with all the connections then/checked jumpers on the opticals as well. If it’s still retarded, I’ll see about a new cable, just in case. Couldn’t hurt, anyhow. Thanks again!


#8

The secondary is only a slave to the main IDE controller. You will need to uninstall the main ide controller, which will remove the primary & secondary controllers.
This will force windows will redetect the IDE controller, re-install drivers & then redetect all IDE devices.

Hopefully it’ll clear out any buggy settings/files that may have crept into the system while you weren’t looking :wink:


#9

Hey, I did that, everything is reset, and all is well and sunny and beautiful and comes with marshmallows. Even better, all this DMA stuff I’ve learned about and jamo’s link brightened my day even more: my lappie was acting very freaking weird, and I couldn’t for the life of me figure out what had her all hacking…so I checked, and the PIO demon had her in its claws. Double thanks, because this solved two major thorns. Thanks, gents. I send e-mallows to all.


#10

Spoke too soon…it appears again that DMA is enabled, and I’m still getting freezes and the drive won’t spin up or access discs. Huh. Well, the laptop is fixed. :slight_smile: I’ll poke at the cables and check the jumps again, and heck, maybe buy a new cable.


#11

Do you have any DVD player programs, startsmart, or audio programs that attempt to access your CD/DVD drive when a disc is inserted?

Often programs can conflict, and although ti doesn’t sound like it, the drive is working fine, but the software is slowing everything down (read -> Hanging).


#12

How slow is a 90 yr old woman with broken hip


#13

Crawling pace.