Can't delete a file my sister downloaded!

vbimport

#1

Hi guys,
and thanks for such a great site,
i just got back from holiday to find my sister has download an avi file on my computer, and now i can’t delete, rename or even move it!
sounds dodgy eh?
i’ve run my symantec anti-virus on it and nothin, but i need to get rid of it, it’s 1.3gig,
it plays well all the way thro, but somethings def wrong eh,
any suggestions how i can get rid of it would be very handy

thank you :clap:


#2

try booting in safe mode (press f8 at startup) and see if you can delete from there


#3

http://www.tolvanen.com/eraser/

Not sure why you can’t delete it - follow the link above - that should get rid of it though.

Oh and what is your OS? If it is 2000 or XP are you logged in as an administrator?


#4

Is the file locked by another process? what’s the error?


#5

use unlocker get it from here


#6

first of all thanks for all your help so far,

1, i’ve tried getting into safe mode, but just pressing f8 isn’t doing it?
i have got into the system set up (i think thats what it was called) at the start but couldn’t find anything saying safe mode?

2/ the only download for the eraser are for older os’s, sorry i should of said i’m running xp, should i still try it?
oh and yes i’m admistrator

3/ error says something like “! cannot delete file, being used by another user, or programme, try shutting down other programmes that may be using this file then try again”, i’ve tried deleting it from the start before i open anything else?

4/ i’m going to try unlocker now , i’ll let you knwo how i get on

thanks again guys


#7

Job done,

the link Phil posted has sorted it for me,

it actually stated that the file wasn’t locked ?

but could delete it for me, which it did,

thanks for everyone who helped

:clap:


#8

Your more than welcome - only sorry my idea didn’t work - sob sob!!


#9

:clap: nice phil cool i was :bow: over that messages


#10

Next time, remember that you must press F8 while the computer is booting


#11

I’ll explain what went wrong here.

What happened is that the AVI file was broken. Yes, broken.

Windows, in its infinite wisdom, tries to render every file that you click on for that stupid little preview window on the left. But its renderer pretty much sucks. Therefore, if there’s ANYTHING wrong with the AVI file, or even if it just uses a really complex codec or is very long, the file will register as “in use” even though it isn’t.

Just clicking on it to select it and then delete it … puts it “in use”.

The quickest way to delete a file like this is to reboot and then use the command prompt to delete it. Or, to use an eraser program, or to unhook the handle to the file with something like Process Explorer.

There are also patches floating around (registry files) that will disable the automatic preview for AVI files. People that use Kazaa and whatnot to download videos run into this problem ALL THE TIME.


#12

I cannot attest to the fact that the file was broken, but the explanation on Windows AVI preview is right on point.

Always best to attempt deletion from a command prompt in these instances.


#13

I used the file unlocker and it worked OK too


#14

It doesn’t need to be broken. It could just be very large, or use a codec that uses up a lot of resources.

However, if it was “downloaded by his sister”, it was most likely just borked.


#15

also xp has a problem that when muliple users are set up, files cannot be deleted.


#16

Hey guys, im new to the site. and i have the exact same problem as the first poster.

except mine plays for a bit and when you play it - it opens an advertisement link on the internet browser automatically. and about 40secs into the 2min clip screen just goes black on RealPlayer and it requests the ‘DEBUG’ etc.

ive scanned it many times with AVG and its come up clean.
when i try to delete or remove it, it says its still in use - when its not.

any way around this?
much appreciated

acidjunky


#17

[QUOTE=phil_;1118676]use unlocker get it from [B]here[/B][/QUOTE]

LEGEND! i owe you mate! thanks a bunch, i was scared shitless. haha thought my PC was stuffed

<3
acidjunky


#18

look for it in the task manager in running processes-stop it- then delete it.


#21

What is it you are trying to delete?


#22

Not sure if you noticed weedougie, but I guess Unlocker worked…FWIW it does work most of the time…It has for me!..:iagree: