Can't burn faster than 12X on one of my systems. What the?

OK, ok, I’m not a newbie, but first we all have to get “back to school” someday and the general “optical drives” forum doesn’t have much activity.

There it is: on one of my systems I can’t get to burn faster than 12X, i run into buffer underruns as soon as the drive tries to write faster than 12X.

This is with any drive, Benq 1640, Nec 4550, Nec 3540. So not a drive issue.

MSI 848P-Neo V, Celeron 2.26. The first one who says it could be a CPU issue gets a one way ticket to the moon (I can burn @16X on an old 900Mhz system). :bigsmile:

I ruled out:

  1. DMA of course. This is fine.
  2. Fragmentation. Source disc not fragmented.
  3. Source disc. Tried another HD. No change.
  4. HD DMA. UDMA 5, so not an issue.
  5. Cable. Changed cable, no change.
  6. Antivirus. Deactivated it, no change.
  7. Background apps. Nothing special.
  8. Burning software. Same problem with Both Nero and Decrypter (using spti).

I’m out of ideas, even if I suspect it can be a power supply issue. Is it possible? Does anyone have other ideas? Thanks!

is your harddrive compressed?

Thanks for the input. No, my drive is not compressed.

Years ago I had a problem with a program that ran in the background. Most of the time it took up no cpu processing but every now and then it would run in the background and take up 80 to 90 percent processing power(I could not get rid of it so I had to wipe & reinstall). I run win2k and can see all the processes at the same time and how much cpu they used. If you can do the same (not all os’s can do this) you can run a test burn after you do ctrl-alt-del and click processes(?) to see if there is a spike during the burn. If that is the case, it may be just enough to not allow the buffer to have data (at 12x) when the drive requests it.

It probably is not your aspi layer since your are using nero (assuming it is new since you have Benq1640) but it may be worth checking out.

This is ruled out I think as I have Decrypter set to to burn through spti, not aspi.

About the background app idea, I’m currently trying out different things. A have a suspect actually, not an app but a driver (Wacom graphic tablet).

Good luck. That was all the ideas I had.

Thanks ra@scientist :slight_smile:

How much ram do you have?
Do you have more than 1 HDD? try changing the temp file to a separate, clean/defragmented drive
Check the hkeylocalmachine/software/microsoft/windows/currentversion/run is not full of add running programs/BS stuff that shouldn’t be running as well as the runonce folder.

Lasty, you can open the processes tab(from ctrl-alt-del) and remove unnecessary garbage.

Hi Francksoy

Maybe a dumb hypothesis, but are you sure that this mainboard have ATA-133 IDE channels? Maybe if your mainboard have “only” ATA-100 this could explain why you cannot reach 16x. Can you check on your mainboard user’s manual?

Thanks for the input. Interesting thoughts, but this mobo is not THAT old :wink: - it’s got ATA133 and SATA. Also I have another PC (actually I have 4 here… :bigsmile: ) with only ATA100 and the nec 3540A that’s inside does reach 16X…

To rocksalt: Memory (+/- 578MB free) , fragmentation and background apps have been ruled out already. Thanks for the input anyway :slight_smile:

I didn’t have the time yet to test without the graphic pen/tablet driver. Meanwhile, all ideas are welcome.

Burst rate > 23MB/s?
Try different IDE channels?
Did you try to test one drive at a time?

Another probably useless question: do you have 80 wire IDE cable?

Burst rate with the Benq 22MB/s :frowning: with a Nec 24MB/s - low numbers and this is not surprising.

Different IDE channel: didn’t try that yet. I thought secondary IDE issues with burners was a VIA thing, and this mobo has an Intel chipset. :confused: I’ll give it a go, who knows. Thanks for the idea.

One drive at a time: already tried. :frowning:

I’ve got nothing left to burn today and I’m tired (it’s kinda late here) - I’m out, meet you guys again tomorrow :slight_smile:

What is a 80-wire IDE cable? :confused: :confused:

Just kidding :bigsmile: - yes it’s a 80-wire cable, also already tried another cable (80 wires too :wink: ).

As a sidenote, I don’t think Nec and Benq drives DO need 80-wires cables, do they? Don’t only recent Pioneer drives need it?

This time I’m really out to bed - thanks to all :bow:

I have the Nec 3540, and could not reach speeds above 10-12 untill I put in a new 80 cable. P4,2ghz, 784 mbytes of ram. Just out of curiosity, exactly how long is the burn time for a full disc, at maximum speed? (with the 3540)

Solved the issue, though I’m not sure it was the best way.

It was definitly not an IDE issue on the burner side (secondary IDE channel) as Nero Create Data disc went fine @16X.

After having swapped IDE channels (no change) and played with the BIOS options (no change), I deactivated Window’s write-back cache for the HD and bingo, no more buffer underruns.

Now if this trick is in some FAQ here, I definitly look like a fool. :bigsmile:

Thanks again :slight_smile:

Nice to know that you solved the problem. :iagree: :iagree:

Where is the menu to set write-back cache?

Go on Device manager and see the example in the image.


I know about this “write caching” in the drive policies, but I thought “write-back cache” is a different thing. :doh:
Thanks for your effort, geno888.