Can't burn a DVD +R on LG GSA-H10L

Just installed an LG GSA-H10L DVD/CD Rewriter in my PC. Any time I attempt to perform a write operation on a blank DVD+R media, I get

Please insert a blank rewritable CD into the HL-DT-ST DVDRW 9 (D:) drive.

And the disk is ejected.

This is the message I get with Sonic RecordNow Deluxe. Similar messages through Nero. I’ve tried this with FujiFilm and Imitation DVD+R media with the same result.

Firmware is all up to date.

I was able to write an audio CD to this drive via iTunes with no problem.

Any ideas?

Thanks in advance.

are you sure it’s a DVD compilation you are trying to burn, not a CD compilation ?

Definitely a DVD compilation. In this case its an ISO file.

weird.
if it’s an image file (.iso) why don’t you try burning it with ImgBurn ?

what firmware version is your H10L ?

What media do you use? A noname or a brand disc? It happens on any +R media?

Dodecahedron

I tried ImgBurn on your suggestion and it worked like a champ! Not sure why though. I’ve been using RecordNow to burn ISOs on other drives for some time. Anyway, thanks very much for your help…

well, i don’t know why RecordNow didn’t work. but glad you got things worked out for you.