Cannot play WMA file in VLC?

vbimport

#1

Following upgrade to Windows10 WMA files on XHDD, return following message in VLC:
“Could not demux ASF stream:
DRM protected streams are not supported.
VLC can’t recognize the input’s format:
The format of ‘file:///C:/Users/Llewellyn/Music/Al%20Bano%20%26%20Romina%20Power/Collection%20%5BMusicrama%5D/Al%20Bano%20%26%20Romina%20Power%20Collection%20%5BMusicrama%5D%2001%20Dialogo.wma’ cannot be detected. Have a look at the log for details.”

Can this be repaired? Microsoft techies say files are corrupted, but they played fine on Windows8 & 8.1.


#2

I have a similar problem impacting on audio files. In VLC I get this error message:

“Could not demux ASF stream:
DRM protected streams are not supported.
VLC can’t recognize the input’s format:
The format of ‘file:///C:/Users/Llewellyn/Music/Al%20Bano%20%26%20Romina%20Power/Collection%20%5BMusicrama%5D/Al%20Bano%20%26%20Romina%20Power%20Collection%20%5BMusicrama%5D%2001%20Dialogo.wma’ cannot be detected. Have a look at the log for details.”

Obviously this is one file, but I have more than 200GB of files that return same error. Microsoft support techies can’t help. Can anyone else?


#4

Hi, Llewellyn. :slight_smile:

First, I must ask that you refrain from posting the same question in two or more places, as well as refrain from posting in old threads that are rather unrelated. I’ve moved your posts here.

Can you still play the files in Windows Media Player?

The error exists specifically in VLC, in a native part of the program meant to begin decoding the file. So it’s possible the switch to Win10 has changed the way applications open a stream, so you can try poking around in VLC’s settings (in the audio section) to see if changing any options helps, but it seems this is strictly on VLC to fix if the files can still be played by WMP.


#5

hmm… maybe its only a codec problem, try to install an new/other codec-package for win10. if you already have an codec pack installed remove this before you install a new one.


#6

[QUOTE=mr-edit;2764898]hmm… maybe its only a codec problem, try to install an new/other codec-package for win10. if you already have an codec pack installed remove this before you install a new one.[/QUOTE]

VLC is self contained and doesn’t rely on outside codecs.