Cannot play MP4 file

When I try to play an MP4 file (using WMP11) it plays for about 8 seconds, then freezes, then WMP crashes with the message: Windows Media Player has encountered a problem and needs to close. More info explains that the module is nevideo.ex v3.2.0.30.

Nero ShowTime does the same as WMP. DivX player plays does the same as WMP, crashing after 8 secs, but there is also no audio. RealPlayer plays the file without crashing, audio is OK, but there is no video at all.

When I check the file with Gspot 2.52 it advises the file is 3GPP Media (.3gp) [MP4 compat.] Mime type: video/mp4. When I test it I get a Render: Partial Failure message.

Gspot lists 156 codecs installed (see attached) with no problems reported.

Please advise! Thanks

You could use a converter and set it to MP3 or WMA instead.

dbPowerAmp is a good one, and they have up to date codecs.

http://www.dbpoweramp.com/dmc.htm

It’s a movie, so why would WMA or MP3 be relevant (sorry if this is a stupid question). Also, I don’t really want to install (or purchase) any additional software if I can avoid it.

Sorry - I misunderstood.

MP4 is also an audio format.

I guess the same principle applies, you would just need different software. Assuming that converting it would do the trick. Maybe gordian knot?

You might want to try two other free players:

AVD DVD Player: http://fileforum.betanews.com/detail/AVS_DVD_Player/1135953445/1

VLC Player: http://fileforum.betanews.com/detail/VLC_VideoLAN_for_Windows/1034861925/1

Thanks for the reply. As I said above I’d rather not install any additional software though, especially without a guarantee that this will work. I’d rather identify the cause of the problem and fix it.

Is this with every mp4 video file? If so, it sounds like a codec problem. Download ffdshow (http://www.free-codecs.com/download/FFDShow.htm), which should cover all the bases. If it’s just the one file you’re having trouble playing, it may simply be corrupt.

Thanks. I’ve installed the FFDShow filter (and the Haali media splitter) based upon advice in other threads but it hasn’t helped. Other threads have, however, also advised adding ;MP4 to the Extension List in the DirectShow Decoder, but I don’t know how to do this.

I have no other MP4 video files so cannot test.

Fair enough. Good luck. :slight_smile:

Another computer perhaps where you can test the MP4 file on? Perhaps it’s just your Operating System that is malfucntioning.

Thanks, but I think my O/S is fine. My media players are crashing, citing NeVideo.ax as the failing module, so I really DO think it is a software issue.

Sometimes doing a Ghost image to backup the system and trying a fresh install is worth doing, if for no other reason than for testing.

do you have quicktime installed?, i’m sure that will play mp4

Since you will not take other advices seriously why haven’t you solved the problem already then? How about reinstalling that stupid module?

Yes, I have tried QuickTime - it fails with error 50

Try VLC. Has its own built in codecs. If it doesn’t play there, odds are pretty good you’ve got a bad video file. And why on earth do you have so many Codecs installed?

Can you upload this file somewhere (to a free file sharing service or to an FTP) where we can download it and take a look? Without the file all discussion is pointless.

The Link for VLC is up above at BetaNews.

Sorry, I didn’t mean VLC. I was asking ch742718 to upload the file he was having problems with.

It’s more than 700mb, so I don’t want to upload it. I disagree that ‘without the file discussion is pointless’, surely it’s possible to identify potential codec issues without the ‘data’ file (e.g. invalid registry key entries <http://www.headbands.com/gspot/notes/dup_nero/> such as those caused by NeVideo - the module that fails when the movie is played, which nobody has mentioned once!)

I have today installed the VLC Media Player, and the file plays fine (both audio & video), confirming that the MP4 file itself is not corrupt. This leaves the issue of other media pl;ayers crashing on NeVideo.ax. Any help here, as I would like to burn the file to a DVD with NeroVision, and need to resolve this issue.