Cannot flash my Toshiba SD-R5372V

Hello all,

I have a Toshiba SD-R5372V DVDRW drive and I want to flash it in order to be able to record my TDK 4x DVDRW disks at 4x rather than 2,4x.

The problem is that I cannot flash it. It has Fw ver TU11.
I tried the official firmware update utility, but it keeps saying: Update is not available, no matter what I do.

I tried to use a Samsung BIN file with installer, same problem.

Should I check jumper settings?

Thanx in advance
Nikos

Nikos,

>The problem is that I cannot flash it. It has Fw ver TU11.

As far as I know, the model you got (SD-R5372V) superseeds the
older SD-R5372. There is no firmware update available because
youv’e got Toshiba’s latest firmware already. Don’t confuse the
two models (one with a “V” at the end, the other without).

For the older SD-R5372 there are several updates available,
but you don’t need them. If you could flash the drive, it would
make performance probably worse than better.

Timo

Timo, you are right. That’s what the Samsung tech support laso told me. I suppose I have to wait for some time long.

Nikos

WHERE CAN I BUY Toshiba SD-R5372V

IN USA ???