Cannot flash firmware 1.07 for Plextor Premium?

Here there, recently I want to flash the my Premium :bow: with the latest firmware 1.07, but I keep getting no drivers found windows with the flasher. Evenmore, my internal Plextor Premium drives appears in alcohol as Plextor CD-R Premiue. Does it have anything to do with my flash problem?

Help ? Anyone ?

BTW, the drive works fine at the moment

Don’t know what to tell you, mine flashed fine…

I even turned my DMA off, tried safe mode no help
Anyone know what has happened?

Damn, I was about to suggest safe mode but if even that doesn’t work I’m out of ideas. Is there maybe another computer around where you could install the drive? Apart from that, if the drive is working fine with F£W 1.06, why bother with an update?

Yea, tried nForce 430. nForce4 SLI. Currently using Asus P5W DH 975X
same problem all around

the drive is kinda wired recently. needs several boot to get it out of non-working Blinking state

Remove Alcohol

Tried, no help. I even reinstall windows.

What is your M/B? NF series? Don’t intall the NV SW driver

What is your Plextor Premium firmware version now?

ppl really need to read my post first.
I have tried NF4 NF430 AND Intel 975X
none of them works