Cannot flash CH10LS20 to RPC2 autoreset, can anyone help?

vbimport

#1

Hello everyone,
according to the release notes, MSCE should support the LG CH10LS20 bluray/DVD combo drive with riplock and RPC-2 auto-reset. However, I have failed twice now to get this to work and would like know know if anybody can tell me what I’m doing wrong. I’d like to be absolutely sure what to do next time I try this, because there are only 3 region changes left and I’ll use up two more if the next attempt fails (as I have to change the region back to what it is now to support the majorrity of my DVDs).

What I’ve done (with Windows XP Professional SP3):

I downloaded the firmware versions available from rpc1.org (both 1.00-00 and 1.00-03), plus MCSE 1.2.0.9. I loaded each of the firmware.exe files into MCSE what let me check the box for RPC-2 autoreset. Then I saved the firmware.exe files using a different file name and executed them. After successful firmware update and reboot of the system, I tried changing the region using the region tab in the device manager. I could change the region and the counter went down, as was expected. But when I rebooted the computer, neither went the counter up again nor did the region reset to before. So, the RPC-2 autoreset doesn’t seem to work. I tried it with both firmware versions, first with 1.00-03, then with 1.00-00, with the same non-success.

I also tried out the LG flasher tool from here, extracted the main and core firmware files, patched the main firmware and flashed the drive, but this always resulted in an unuseable drive with firmware revision “COR4” until I reflashed using one of the firmware.exe files.

As the MSCE lists CH10LS20 as patchable to RPC-2 autoreset, can anybody tell be what I must do differently in order to get this working? Any help is appreciated.

Greetings and thanks in advance, Hes.


#2

Hello again,
just to close the topic myself - the RPC2 autoreset reflash worked after all. I just hadn’t gathered from the instructions I read that the drive resets only after power-down, not after a simple soft or hard reset/reboot, and hadn’t switched the computer off and back on after the final attempts (I did so earlier on with my numerous reflash attempts). Thanks for the MSCE tool, it works great.

Greetings, Hes.