Cannot enable DMA for 3540a!

Hi Guys!

Recently got this nice new NEC burner and soon discovered that it only burns things really slowly. The saga so far:

  • installed drive in new PC, seemed to work ok
  • burnt a DVD in NERO and it took ages
  • discovered DMA wasn’t enabled, so enabled it in Device Management
  • despite the above, DMA did not enable on this drive, no matter what I did. My second drive, an NEC DVD-ROM was working fine with DMA.
  • not sure why DMA wasn’t working so downloaded the latest nforce4 drivers from nvidia for my fatal1ty mobo.
  • Appeared to solve the problem, DMA now showing as enabled!!
  • Now the drive won’t read any discs
  • Tried to fix this by using the correct jumper settings. I chose cable select
  • The drive now reads what’s on the disc (after a while) ie the contents, but it won’t read what’s ON the disc ie won’t play the song/open the file.
  • I’ve updated the firmware to the latest 1.03 and had a look on google but there doesn’t seem to be a general problem.
  • then I unistalled the latest IDE drivers and the drive was redetected.
  • the drive now reads/writes discs again BUT DMA is once again NOT enabled!! ie we’re back where we started.

The drive is IDE Master on Channel 1 and it’s a Win XP system. I’ve swapped IDE cables, jumpers, tried it with the other drive installed and without.

My last hope is that it’s the actual nvidia IDE drivers that are duff and that drivers from somewhere else may solve the problem.

any suggestions gratefully received!! :bow:
cheers

Are they 80 wire/conductor/pin or 40? I seem to remember loads of problems reported with 40. HTH

Yo-

Suggest that you uninstall the nvidia ide drivers and let XP install the M$ drivers-

Also make sure that the bios is set correctly for all drives-

Mike

hmm, not sure. i guess they’re just ‘standard’ IDE cables, whatever that may be. I have the DVD-ROM on channel 2 as a master and that has DMA enabled and working!

have already unistalled nvidia drivers, MS ones are installed now :slight_smile:

will double check the BIOS though, I’m pretty sure it’s all enabled though!

@ mythuk,

Suggest viewing the below Forum Posting and note Forum Member ireland’s (posting #4) comments concerning setting DMA.

http://club.cdfreaks.com/showthread.php?t=150240

Best Regards,
bkjg

thanks, yeah I had seen that but I’m very wary of changing the reg and want to avoid it if possible. I just wondered if peeps had any other suggestions before I went for that as a last resort!

I had read that post by ireland and it was very informative.

If you fear going into the registry, just use System Restore and make a restore point right before messing with the registry. Another safety precaution you can take is to export any key you will modify and save it to a clean folder.
If you do 5 reg changes to 5 keys, just export each key one by one. If something goes wrong, just click on the .reg files and they will replace the ones you messed with resoring the original.

I myself always use Acronis Drive Image and make a image of my drive before I do some serious alterations of the registry, If something goes wrong 1 week or 1 month from now that didn’t manifest itself immediately, I am covered with restoring the image. I have System Resore disabled, a drive image is far more reliable IMHO.

And what is the burner IDE position then? Is it slave on the same channel? If so, switch both drives (and set the jumpers accordingly of course) see if it helps.

pretty funny… my 3540 is a secondary slave to a 48161 and it is a a 40 pin cable, and i burn @ 8, 12, 16x without any issues…

the reg trick or pull the controller in the bios and reboot.

Same here. But I know from experience that some mobos have picky/problematic IDE controllers that mess with burners DMA when they’re connected as slaves while the master is a removable media drive. :wink:

burner is on Channel 1 on its own, set to master at the jumper, DMA not working!

ROM is on channel 2 on its own, set to master at the jumper, DMA working!

gonna have a play with the ide cables now. If that doesn’t work I think I’ll try the regedit idea!

:doh: :doh: well then something is defective somewhere. Either the drive, or the cable, or the IDE controller (have you tried to swap the drives?). The cable would be my best bet.
Never had to resort to any reg tweak as yet to have DMA enabled, but who knows :confused:

Please clarify, when you say channel 1 are you referring to the Primary Ide cable, and when you refer to channel 2 is this the secondary ide cable.

If this is the case, where is your hard drive(s) located on the channels?

sorry, yeah that’s what I mean.

2 HDDs are SATA.

well I think I’ve given up on this drive for now, I removed it and installed my old Sony DRU-500A and that’s working fine, DMA enabled and all.

I may RMA the NEC and see if a replacement works, if not I’ll just get a diff drive, I mean they’re so cheap these days they’re almost disposable!

EDIT - oh and the reg tweak didn’t work, I did eventually try it!

I hope the RMA solves your problem, and thanks for advising the forum that the Reg Tweak did not work for you.

thanks for all your tips guys.

Once I get the drive replacement I’ll post here to let you know if it solved things!

I have the same problem with my 3540a. Burner’s on my secondary master, dvd-rom is secondary slave (and works fine in DMA). I’ve tried every single trick mentioned on the web. Uninstalling the IDE drivers, the registry hacks, etc. Nothing has helped. The only thing that eventually worked was Intel’s Application Accelerator. Got fast rips and burns and the drive was working like a champ. Unfortunatley, it turned my computer to crap and started giving me way too many other problems.

So now I’m stuck in PIO mode. Grrrr! I think I’ve just about given up, but if anyone else has any suggestions, my ears are open!

Try a hardware forum? I mean this is not a 3540A issue, but a mobo/IDE controllers/IDE drivers issue, most probably. :wink: What’s your mobo?

I have the same problem with my NEC ND-3540A when conected to the Silicon Image 0680 ATA/133 Controller. When conected to the onboard IDE, UltraDMA Mode 2 works fine. The other drives work fine at UltraDMA Mode 2 when conected to the Silicon Image 0680 card. The NEC doesn´t!

All my cables are 80 wire. When I conect the NEC to the Silicon Image, the card detects the 80 wire cable as it was a 40 wire one! I think the card only enables Ultra DMA modes when 80 wire cables are detected. Since it detects a 40 wire cable it enables multiword DMA mode 2 instead. Wich is not enough for 16X DVD speeds.

Maybe your IDE controller works the same way.

So If this is the case, your RMA will not solve your problem.

I think the problem is the NEC firmware. I think it is related to the fact that the drive also lights the IDE light when it is working.

So please let me know the result of your RMA. If you have the same problem with the RMAed drive, maybe it will be time to talk to NEC tech support.

Regards.