Cannot Defragment my C: Drive

For some reason every time I try to defragment my c:drive I get a popup saying…

“Disk Defragmenter has detected that Chkdsk is scheduled to run on volume: Presario C , Please run chkdsk \f”

I ran chkdsk from My Computer>(right click) C Drive>Tools>Check Now

It says it can only run volume check at startup to. I restart the computer and the n when I try to Defragment I still get the same popup.

Please Help!!

you could download for free DIRMS at http://www.dirms.com/

You don’t say what windows you have xp??. If your hard drive has less than 15% free it may not let you defrag. You can download a free defrager at www.filehippo.com You can download ccleaner to delete temp. files and defag program scrool down to Cleaning and tweaking for those. You may have errors on your drive and may have to run scandisk on a restart.

Well you might as well rule out any infections first.

Two apps to try:

To me it seems like Windows the variable that controls chkdsk is corrupt or missing in the registry, as this usually clears after the chkdsk operation completes during boot.

[ol]
[li]Go into the registry editor (Start -> Run, type in ‘Regedit’ and click ‘OK’)[/li][li]Go into: HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> Session Manager[/li][li]Edit the ‘BootExecute’ value and change it to: autocheck autochk *[/li][li]If this ‘BootExecute’ value contains more than one line, delete them apart from this first line.[/li][li]If “BootExecute” is not present, create a new Multi-string value called ‘BootExecute’ and repeat step 3.[/li][/ol]

Reboot the PC and try running Defrag again :wink:

I run Windows XP Thanks for the help I will try it and let you know how it goes.
:slight_smile:

[QUOTE=Seán;2282591]To me it seems like Windows the variable that controls chkdsk is corrupt or missing in the registry, as this usually clears after the chkdsk operation completes during boot.

[ol]
[li]Go into the registry editor (Start -> Run, type in ‘Regedit’ and click ‘OK’)
[/li][li]Go into: HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control -> Session Manager
[/li][li]Edit the ‘BootExecute’ value and change it to: autocheck autochk *
[/li][li]If this ‘BootExecute’ value contains more than one line, delete them apart from this first line.
[/li][li]If “BootExecute” is not present, create a new Multi-string value called ‘BootExecute’ and repeat step 3.
[/li][/ol]

Reboot the PC and try running Defrag again ;)[/QUOTE]

Thanks Sean! I went through your steps and this is the value my Boot Executive is on ( autocheck autochk /r ??\C:
autocheck autochk *) Do I change it C:
autocheck autochk * or leave it how it is?

Going by what you mentioned, there is some extra garbage in your BootExecute value. Remove this and change it to only contain “autocheck autochk *”

I.e. here is what it looks like on my PC (running Windows XP):


I changed my Boot Executive and also DL’d Malwarebytes and found 16 infections that my Cyber Defender could not detect. I also DL’d Defraggler from freehippo.com but it seems to stop Analyzing at exactly 81% evertime. Do we know any further suggestions? Thanks again :wink:

It seems like there is still a file system problem on your C drive, possibly a bad sector.

When you have some time to spare, could you try the following:

[ol]
[li]Click Start -> Run, type in ‘cmd’ and click ‘OK’.[/li][li]In the command prompt that appears, type in: chkdsk c: /f[/li][li]When requested to check on next boot, press ‘Y’.[/li][li]Shut down the PC, then boot it up again for the check to take place.[/li][/ol]

During boot, the chkdsk operation should hopefully take place properly this time.

Another thing worth doing is checking the ‘SMART’ data of the hard disk to check for bad sectors. To do this, get HDTune (the v2.55 free version is fine) and install it, then in the utility, go into the ‘Health’ tab. Select your hard disk from the drop-down menu (usually selected by default). If the reallocated count is above 0, then your hard disk has encountered weak or bad sectors. In this case, go into the “Error Scan” tab and scan the drive (don’t use quick scan) to make sure there are no damaged blocks. If the “Error Scan” tab shows all green and the reallocated sector count is a low value (e.g. <10), I would consider this as a warning and should be checked periodically (e.g. weekly) to make sure it does not increase. I would also recommend increasing how often you backup your data. If the value is above 10 or you get red marks on the error scan, I would recommend getting the hard disk replaced.

I’m not sure if you meant the Reallocated Sector or Event Count. Here what it looks like.

They both show above 0??

He meant “Reallocated Event Count”. In the case of your drive, it has encountered bad sectors and has taken from the drive’s hidden reserve capacity to replace the failed parts.

Your drive appears to be an older drive or at least been in service for some time. Your drive has seen better days and it would be prudent to start looking for a replacement.

Sorry, I meant meant the ‘data’ column for the “Reallocated Sector Count”, however, either this or the “Reallocated Event Count” with a count (especially above 10) generally means bad news. The “Reallocated Sector Count” means the number of bad/weak sectors that have been mapped to spare reserved sectors and the “Reallocated Event Count” means the number of times one or more sectors had to be reallocated. From my experience, most good hard disks, even over 5 years old, have ‘0’ for both.

Going by what HD Tune is showing, your hard disk has had 131 sectors remapped and has had to reallocate sectors on 43 occasions, which means that you should definitely back up what ever you don’t have backed up already as soon as possible and consider getting this hard disk replaced. From my experience, hard disks often totally fail long before this figure reaches 100, more often by the time the reallocated sector count reaches between 40 to 60.

The ‘worst’ column for the “Raw Read Error Rate” shows that your hard disk exceeded the tolerance of how often the drive is encountering low level read errors. The lower this value, the worse the problem. Ideally, the ‘worst’ column for this should be 100 or 200 (depending on the hard disk manufacturer and model) or close to this. At this stage, I’m sure you’ve noticed your PC running unusually slow or even stuttering intermittently. This is most likely the hard disk struggling to read sectors, which is holding it up.

The following is from my PC’s hard disk, which gives an idea of what a healthy hard disk looks like:


Just ordered a hard drive:
SEAGATE ST31000340AS SATA BARRACUDA HARD DRIVE 1000 GB for $97

I have never had to run a backup. Would you recommend buying CD’s and copy all my files and programs through zip? Or is there an easier way. Thanks Sean!

If you have a DVD writer, use DVD+R’s or DVD-R’s as they hold over 6 times the capacity of a CD and this will cut time backing up your content. The main stuff to back up is everything in “My Documents” and your destkop and any other folders you place content into. Note that installed software cannot be easily transferred, unless you do a partition copy.

If you would like to keep your existing OS installation, setup, software, etc. your best option would be to copy the partition to the new hard disk, e.g. using the parted magic boot CD (download link and guide). If you choose this method, [U]do not boot from your existing hard disk with the new hard disk connected[/U], otherwise this will cause problems later when transferring the partition, even using other disk/partition copy software. Instead, make sure the BIOS is configured to boot from CD before installing the new hard disk, insert the Parted Magic CD, boot it and follow the guide. Afterwards, disconnect the original hard disk, boot a Windows XP setup CD, go into the recovery console (when it asks what you would like to do) and type in ‘fixmbr’ to put a master boot record on the new hard disk. Finally reboot and the new hard disk should boot. Hopefully someone else here can give you a simpler process, as I mainly use this process due to Parted Magic being free.

If you have some time to spare, a better option is to install Windows, the drivers and software from scratch on the new hard disk. With this method, disconnect your existing hard disk, connect up the new one and install Windows, drivers, software, etc. Then connect up your old hard disk again, go into the system BIOS and make sure the new hard disk is configured as the first for boot priority. When you’re in the OS, your old hard disk will show up as a different drive letter and you can go into this to copy everything you need to your new hard disk. :wink: