Cannot connect TRF

vbimport

#1

When I am calling NeroBurn to burn a NERO_ISO_AUDIO_MEDIA (DVD) I get the error "Cannot connect TRF".

Does anybody know why this error appears???


#2

A year later, I see there’s no replies. Well, it seems no one in the fucking net knows what TRF means.
I got a new BenQ DW1640 and had no trouble burning with the included Nero Express 6. Got a hold of Nero 7, and did one burn. The second, I got the “cannot connect TRF” error. Had to uninstall, delete everything from the registry… reinstall. Fixed. For ONE burn. Tried another… same error.
What the fuck is TRF? Is it my drive that’s defective, or what?
Couldn’t get the drive to work at all, till I changed the 40-wire cable for a 80-wire then it works. But can’t use Nero 7 because of this error.


#3

Please mind your language on this forum.

The solution is to increase the size of your windows swap file. See:
http://ht.hardwareanalysis.com/content/topic/21503

Mike


#4

First of all forgive my english.

I had the same problen about 10 minutes ago and i found a solution
Don’t let Windows manage your SWAP, do it by yourself…
For example if you have 256MB, the swap should be about 512MB of space…always the double of your RAM

Do not execute other programs…and free all the memory you can…it works for me.

I hope this help you in some way.

See ya


#5

i had the same problem with da nero 7 premium.
i installed it and trying to tweak it a little i removed a “nero filter check” and other thingies that were added by nero. didn’t get to write a disk before the tweaks. when i tried to burn a dvd i got the error “cannot connect to trf” and nero throws the error and some buttons are deactivated. i cannot close it by usual means. so i kill it using another application. so thinking that it was my bad for disabling some start up entries. i used the repair thing. same output. after that i removed it completly and reinstalled it again. got the same error. after that i uninstalled nero and removed everything that had nero or ahed in their names, searching system files and the registry. reinstalled it again and got the same f… result. tried also the swap trick that was mentioned and got the same result. anybody any ideea?


#6

What have you increased your swap file from and to? Try increasing it further.

Mike


#7

“Cannot connect TRF” means some of Nero’s transfer layer components, which are responsible for burning, failed to load. The reason for may be even not enough available memory.


#8

yeah. i did increase the memory. i stoped anything that wasn’t “a must” and got the same result. i must mention that i have 512mb ram dual channel, duron 1600@2ghz, asus nforce2 motherboard.
@czykit: i believe that i stoped a component from nero7 but why the repair function and uninstall/reinstall procedure doesn’t work. it would be ridiculous that a burning program to need more than 512mb of ram.


#9

Therefore in fact some DLLs could be missing. Is it possible for you to use Dependency Walker or similar tool and check if it’s true?


#10

I got the same error when buying a new nec nd3540A. I had installed nero 7 premium with a minimum set of features since i didn’t think i needed any of them. Tried to do a repair and added everything except inCD and the imagedrive, this solved the problem.

Specs:
Intel P4 3.0GHz 2GB of ram 1.5GB pagefile. While burning a data dvd nero uses about 300MB of memory.


#11

I got the same problem. My DVD burner is also BenQ DW1640, no problem with Nero 6, but Nero 7 throws ‘cannot connect to TRF’ when I burn data DVD. No problem burning DVD-Video though.
I have tried all methods, not working. I have 1G ram, sawp file is 2G, win xp sp2.


#12

I got the Same issue here & funiley enough with the same BenQ Drive “BenQ DW1640”

strange seems to be a issues with this drive if you ask me …


#13

I have recently had the same problem. Just put my pioneer 108 in my new rig, dfi nf4 motherboard. Thought it was something to do with that. Tried updating drivers etc, but didn’t solve the problem.
You know what did?
I uninstalled nero 7 and installed nero 6 ultra. Problem Solved.


#14

However this thread does have NOTHING TO DO WITH SDK so will a mod move please?


#15

Primarily the problem was discovered using NeroAPI, so it is NeroSDK related too. Anyway I’ll make a copy in Nero@InCD forum.


#16

I found by going back to a previous version of Nero (6.6.0.3) solved my problem.

John


#17

The sollution is: in combination with DVD Shrink 3.2, login file 1A22-030K-0350-1550-5697-0951, Nero (6.6.0.18), it solved my problem.

http://httpdl1.usw.nero.com/Nero-6.6.0.18.exe

Greetings


#18

Interesting… I found that using anything over UDF 2.01 (which worked fine) (ie. 2.5 or 2.6) immediately generates the Cannot Connect TRF. Tried to write to DVD+RW. I tried increasing my VM to 768 min, but that didn’t do anything. The machine has 256 RAM. This was Nero 6.0.1.4. My previous version, 6.0.0.15 I believe, didn’t have any option for anything over UDF 2.01. Either way, I understand UDF 1.02 is really the most you need for a data DVD. So I guess there are various reasons for the error.


#19

Same for me : I tried the trick of VM without success but going back to nero 6.6.0.18 correct the issue I had with DVDShrink on a BENQ DW1650.
I suggest to wait for a new version of Nero that correct the problem.

Olibouli


#20

just happened to me on my sony dru-810a using nero 6.614 latest vsn…
now gonna try burning to a lite-on