Cannot Burn DVD-MOVIES, Very Very Annoying, NEED HELP

My LG GSA-4082B has been having problems for a while, and I’m not really sure if its the drive that is faulty. When I burn DVD-MOVIES, at random times (can come at beginning, middle or end) it stops with an error that says: Unable to Create the Disc Structure, Burn Process Failed. I’m not sure if its the drive that is faulty because it can still copy DVD’s and burn CD-R’s- it just cannot burn DVD-MOVIES. I don’t think this is a software problem because it does the same thing when I try to burn with my Ulead software. I phoned LG about it, and they recommend that I send it in for a exchange, but they say that if it’s actually not faulty, I will have to pay for the exchanged one. I asked Nero Technical Support, all they say is to use a 80 wire cable, which I am already using.

I get a bunch of these in the nerovision log:
[10:48:58] GCCore The following operation did not finish in the past 15 seconds: Grab still image (AVStillSource)
[10:49:09] GCCore The following operation did not finish in the past 15 seconds: Graph control (Stream segment)
[10:49:09] GCCore The following operation did not finish in the past 15 seconds: Graph control (Stream segment)
[10:49:13] GCCore The following operation did not finish in the past 15 seconds: Grab still image (AVStillSource)
[10:49:24] GCCore The following operation did not finish in the past 15 seconds: Graph control (Stream segment)
[10:49:24] GCCore The following operation did not finish in the past 15 seconds: Graph control (Stream segment)
[10:49:28] GCCore The following operation did not finish in the past 15 seconds: Grab still image (AVStillSource)
[10:49:39] GCCore The following operation did not finish in the past 15 seconds: Graph control (Stream segment)
[10:49:39] GCCore The following operation did not finish in the past 15 seconds: Graph control (Stream segment)
[10:49:43] GCCore The following operation did not finish in the past 15 seconds: Grab still image (AVStillSource)
[10:49:54] GCCore The following operation did not finish in the past 15 seconds: Graph control (Stream segment)
[10:49:54] GCCore The following operation did not finish in the past 15 seconds: Graph control (Stream segment)
[10:49:58] GCCore The following operation did not finish in the past 15 seconds: Grab still image (AVStillSource)

and this is what is says at the end:
[10:51:34] DVDEngine 上午 10:48:23 #8 Phase 36 File APIProgress.cpp, Line 276
[10:51:34] DVDEngine Burn process started at 4x (5,540 KB/s)
[10:51:34] DVDEngine
[10:51:34] DVDEngine 上午 10:48:51 #9 Text 0 File BurnAtOnceRecorder.cpp, Line 675
[10:51:34] DVDEngine Reserved fragment at 0. Length: 592
[10:51:34] DVDEngine
[10:51:34] DVDEngine 上午 10:48:51 #10 Text 0 File BurnAtOnceRecorder.cpp, Line 1869
[10:51:34] DVDEngine Reserved start fragment at 0
[10:51:34] DVDEngine
[10:51:34] DVDEngine 上午 10:48:52 #11 Text 0 File BurnAtOnceRecorder.cpp, Line 675
[10:51:34] DVDEngine Reserved fragment at 592. Length: 48
[10:51:34] DVDEngine
[10:51:34] DVDEngine 上午 10:48:52 #12 Text 0 File BurnAtOnceRecorder.cpp, Line 1401
[10:51:34] DVDEngine Writing VTS_01_1.VOB at sector 640
[10:51:34] DVDEngine
[10:51:34] DVDEngine 上午 10:51:33 #13 SCSI -1039 File Cdrdrv.cpp, Line 1435
[10:51:34] DVDEngine SCSI Exec, HA 0, TA 1, LUN 0, buffer 0x036BE400
[10:51:34] DVDEngine Status: 0x04 (0x01, SCSI_ERR)
[10:51:34] DVDEngine HA-Status 0x00 (0x00, OK)
[10:51:34] DVDEngine TA-Status 0x02 (0x01, SCSI_TASTATUS_CHKCOND)
[10:51:34] DVDEngine Sense Key: 0x04 (KEY_HARDWARE_ERROR)
[10:51:34] DVDEngine Sense Code: 0x09
[10:51:34] DVDEngine Sense Qual: 0x01
[10:51:34] DVDEngine CDB Data: 0x2A 0x00 0x00 0x00 0x68 0xA0 0x00 0x00 0x10 0x00 0x00 0x00
[10:51:34] DVDEngine Sense Data: 0x71 0x00 0x04 0x00 0x00 0x00 0x00 0x10
[10:51:34] DVDEngine 0x35 0x01 0x04 0x0E 0x09 0x01
[10:51:34] DVDEngine
[10:51:34] DVDEngine 上午 10:51:33 #14 Text 0 File BurnAtOnceRecorder.cpp, Line 2113
[10:51:34] DVDEngine Failed to write cache to disc at 26784
[10:51:34] DVDEngine
[10:51:34] DVDEngine 上午 10:51:33 #15 Phase 179 File APIProgress.cpp, Line 276
[10:51:34] DVDEngine Writing file to disc failed
[10:51:34] DVDEngine
[10:51:34] DVDEngine Existing drivers:
[10:51:34] DVDEngine Registry Keys:
[10:51:34] DVDEngine HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon\AllocateCDROMs : 0 (Security Option)
[10:51:34] DVDEngine _Xcept (): Signalling Exception: 129 NeroBAOWriteToFile() returned error condition _BAOFile::Write()
[10:51:35] DVDEngine ********END: _VOBS - Process VOB
[10:51:35] DVDEngine ******END: VTSTT_VOBS#1 - Process Create
[10:51:35] DVDEngine ****END: Create - VTSTT_VOBS#1
[10:51:35] DVDEngine **END: _DVDVideo - Create
[10:51:35] DVDEngine ########################################################################################
[10:51:35] DVDEngine ERROR
[10:51:35] DVDEngine cause: 2 (internal_error)
[10:51:35] DVDEngine source: _VOBS
[10:51:35] DVDEngine description: Unspecified error
[10:51:35] DVDEngine ########################################################################################
[10:51:35] DVDEngine **BEGIN: IDVDSessionBaseImpl - Clear
[10:51:35] DVDEngine **END: IDVDSessionBaseImpl - Clear
[10:51:35] DVDEngine END: IDVDVideoSessionImpl - CreateDisc
[10:51:43] GCCore The following operation did not finish in the past 15 seconds: Grab still image (AVStillSource)
[10:51:50] NeroAPI 以4x (5,540 KB/s)的速度燒錄失敗
[10:51:58] GCCore The following operation did not finish in the past 15 seconds: Grab still image (AVStillSource)
[10:51:59] DVDEngine BEGIN: IDVDSessionBaseImpl - EndDiscAccess
[10:51:59] DVDEngine …Flags=0
[10:51:59] DVDEngine **BEGIN: _MediaAccess::Release ()
[10:51:59] DVDEngine ****BEGIN: _MediaAccess::~_MediaAccess ()
[10:51:59] DVDEngine ****END: _MediaAccess::~_MediaAccess ()
[10:51:59] DVDEngine **END: _MediaAccess::Release ()
[10:51:59] DVDEngine END: IDVDSessionBaseImpl - EndDiscAccess
[10:51:59] DVDEngine BEGIN: IDVDSessionBaseImpl - RegisterCallback
[10:51:59] DVDEngine …Session callback unregistered…
[10:51:59] DVDEngine END: IDVDSessionBaseImpl - RegisterCallback
[10:52:13] GCCore The following operation did not finish in the past 15 seconds: Grab still image (AVStillSource)

Has anyone had this problem before?

wow, now it can’t even read CD’s…

If its still under warranty get it exchanged.

Make sure that you do not have ‘burn at once’. ‘qucik copy’ or ‘on the fly copy’ checked off anywhere.

I tried burning with both ‘burn at once’ on and off. Neither work. I want to get it exchanged, but they say that if the drive isn’t actually faulty, they will charge me for the replacement unit.