Can not get Lite-on LTR-52327S to burn

For the past week i have been unable to get my drive to make one single copy. I usually use Alcohol 120 and Nero, neither will burn and both give me the same error message basically. Here is the error i get when i try to burn an image file with Alcohol.

13:32:47 Processor info: AMD Athlon™ XP 2800+ (2079MHz)
13:32:47 Memory Available to Windows: 1,048,048 KB
13:32:47 Memory Buffer size: 128 MB
13:32:47 Image file loading: F:\Microsoft.Visual.Studio.NET.2003.Enterprise.Architect.PROPER-TBE\Microsoft.Visual.Studio.NET.2003.Enterprise.Architect.PROPER-TBE\CD1\vs2k3ea1.cue
13:32:47 Source Info: Session: 1, Track: 1, Length: 636.6 MB / 072:25:67
13:32:55 (H:) LITE-ON LTR-52327S(1:1): Recording Method/Speed
13:32:55 Recording - DAO / SAO - 52X (7800 KB/Sec)
13:32:55 (H:) LITE-ON LTR-52327S(1:1): BURN-Free activated
13:33:13 (H:) LITE-ON LTR-52327S(1:1) - [Write PREGAP area ERROR]: -150 - 0
S:KEY - 06/28/00 - “Not Ready To Ready Change, Medium May Have Changed”
13:33:13 (H:) LITE-ON LTR-52327S(1:1): Recording failed!
13:33:13 Error message: [06/28/00] - Not Ready To Ready Change, Medium May Have Changed
13:33:13 (H:) LITE-ON LTR-52327S(1:1): Recording failed!
13:33:13 Image file loading aborted!
13:33:16 Something is wrong with the recording procedure!
Please check the log file and report any errors to Technical Support.

I used to be able to reboot my PC and then it would let me burn a cd after i had gotten that error, but rebooting solves nothing now. I tried to simply uninstall the device from device manager and reboot, same error. Eventually i tried to burn the cd on my Optorite DVDRW, i got the same damn error messages. When i was in school i had the same errors, i eventually broke down and just formated my hard drive which fixed the errors, but i dont really like formating my hard drive. When i have tried to install new firmware it gets to about 20% then it tells me it can not finish installing firmware and boggs down my pC like crazy. My PC freezes for 5 seconds every 2-3 seconds until i reboot. This happens whenever i try to update firmware, which i download directly from liteon corp website. Any help would be greatly appreciated as i a trying to burn some cd’s for my uncle. Thanks