Can Burn DVD's but not CD's.. Help!

Hi, I new to the forums so I hope I am posting correctly. Here’s my problem:

I have a LG GSA-4166B burner that has always worked perfectly. All of the sudden I cannot burn CD’s in XP SP2 but I can burn DVD’s all day long. The drive can read cd’s just fine, just not burn them. When I try to burn a CD the software (Nero 7) asks me to insert a blank CD like it does not recognize the blank media. Here’s what I have tried so far:

  • confirmed I have the latest firmware
    -tried different software (MediaPlayer, RealPlayer etc) same results (insert blank cd)
    -tried different manfacterer of blank CD’s
    -confirmed I have no “virtual” apps running (Alcohol etc)

So here’s the odd part: I dual boot with XP and Linux SUSE 10 Enterprise and guess what? Linux can burn CD’s with no problem! So, I know the drive is fine that only leaves a conflict/driver problem but I cannot find it.

any ideas?

Fixed it. Ended up being the Nvidia IDE drivers. I uninstalled them and began using the standard Windows drivers and all is well…