Can burn DVDR's succesfully - but all discs are flawed..?

vbimport

#1

I’ve been burning a few .ISO files to DVDR today - thank god I decided to test them.

I’ve used NeroLinux to rip the burned DVDR to a new .ISO - it always fails about 80% through with a read error.

I experience the same issue using K3b however - so it’s probably not a Nero specific problem.

Any suggestions as to what on earth might by wrong ?

The burner work perfectly under Windoze btw :confused:


#2

If I understand you corrently, you are re-ripping your self-burned DVD’s back to ISO to test, right? The burning went OK I take it, but when ripping to ISO it gives an I/O (Input/Output) error or something … where it cannot read from DVD?

You say the burner works correctly in Windows, but can you rip the same DVD to ISO on Windows?

Here are just some ideas:
Maybe the DVD is corrupt?
Maybe there is 1 file on the DVD bigger than 2GB? (ISO 9660 states that no single file in the ISO can be bigger than 2G) ~ the ISO itself yes, but not a file in it.
Maybe you have no large-file-support in Linux ( > 2G)?


#3

I’m narrowing down the problem… All the files I’ve been having issues with are on a NTFS volume mounted in linux. I just tried burning an ISO file that was downloaded to an EXT3 vlomue - that worked without issues -and the verification is fine.

I’m not ripping DVD’s - I’m downloading an ISO image and burning it - I then rip the DVDR to check that the entire disc is readable. I could just use NeroLinux or k3b’s build in verification as they fail aswell.

You mention that I might be lacking large file support - I’m running a fresh install of Suse 9.3 pro - how do you suggest I check it ?


#4

Ahhh, yes, this is most likely your problem. NTFS is known for many many different issues on Linux. Don’t use it if you can avoid it. Actually NTFS-write “is still only partially” possible even with the latest kernels ~ to give you an idea about what I’m talking about. A quote from the help file in the latest 2.6.11 kernel: “The only supported operation is overwriting existing files, without changing the file length. No file or directory creation, deletion or renaming is possible”.

Of course this applies to writing, not reading… however is writing is so unstable and limited, imagine how “accurate” reading is :wink:

It’s possible to download directly to your Linux partition? If so, use this method.

Your disto supports it :wink: … SuSE always add in features like this, so don’t worry about it.

Anyway, I think you have found the source of your problems… and one you start using the Linux partitions you should not have this issue any more.

Good luck


#5

It really puzzles me however - I copy a ISO file from the NTFS volume to the EXT3 volume - verify it with k3b and burn it with NeroLinux - the DVDR then burns successfully but fails verification.

If I extract the ISO from a bunch of RAR files on the NTFS volume to the EXT3 volume and then burn it - then it works…


#6

A corrupt ISO will normally always burn correctly to DVD/CD, as all the burning does it copy/burn 1:1 the ISO to the device. If the ISO is corrupt it means that the final burned image on the device will be corrupt… it’s that simple.

The bunch of rar files are probably 15MB files … the ISO is 4.4GB. Somewhere the translation layer from NTFS -> ext3 (ie: kernel) probably gets a few 0’s and 1’s mixed up or something.

I can’t explain exactly why you are having problems, but only that if you use Linux you should use Linux partitions ~ especially if you use things like > 2G files. For normal small files it’s OK, but here we are talking about a filesize that is an “illegal” filesize on most existing popular filesystems. Only in the last few years has large-file support been added in, and obviously does have issues. Fortunately you have it in rar files, so enjoy extracting and burning that way :wink:


#7

Goddammit - I still get errors :frowning: Managed to make ONE working disc so far…

About the ISO’s being corrupt - k3b makes a md5 check of it before burning so i can say with some certainty that the ISO’s are alright…

What REALLY blows my mind is that the error allways seem to appear at the same place on the discs :frowning:

I’m thinking the next step might be to move the DVD-RW to another ATA controller - just to test it…


#8

k3b makes an md5check to what …a checksum file you got with the isos, or does it make an md5 of the iso ~ burn it ~ then compare the 2 ? Sorry but I’m not very familiar with k3b.

At what point if this going wrong? You mentioned 80% or so of an iso of 4.4G? The exact same files burn fine with Windows?

Not sure either what it could be now unfortunately. Sorry, but I’m all out of ideas :wink:


#9

It appears other are having ‘simular’ problems…

http://www.ndsengineers.com/showthread.php?t=138736


#10

Could it possibly have something to to with the ISO files ?

isoinfo -d -i <filename>.iso

CD-ROM is in ISO 9660 format
System id: Win32
Volume id: <volumename>
Volume set id:
Publisher id:
Data preparer id:
Application id: MKISOFS ISO 9660/HFS FILESYSTEM BUILDER & CDRECORD CD-R/DVD CREATOR © 1993 E.YOUNGDALE © 1997 J.PEARSON/J.SCHILLING
Copyright File id:
Abstract File id:
Bibliographic File id:
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 2286567
NO Joliet present
NO Rock Ridge present


#11

PROBLEM SOLVED !

For the hell of it I added a new harddrive to the system (had a spare) and formated it with Reiserfs (3.6)

I can burn ISO files from that volume without error :smiley:


#12

That is wierd. I don’t think it could be the reiserfs 3.6 (although reiserfs 3.6 is exactly what I always use), but maybe possibly something to do with how your computer (hardware) is connected with the IDE cables (master/slave order etc). I have never really deepened my knowledge of it as it’s always simply just worked here but it might be worthwhile looking into if you are still trying to trace the problem. How is your DVD-RW connected in relation to your Windows partition and Linux partitions? Are W & L on the same harddrive?
I think google would help you more here than I could possibly dream of though, however I am curious as to your setup :wink:


#13

My PATA and SATA devices are connected ‘by the book’ - one device on each channel.

I’ve got no idea what might have been causing it besides the ext3 filesystem - which makes no sense - I know. I wont spend more time on testing - already cost me enough discs :Z