Can anyone figure out this Rosetta Stone Farsi problem?

vbimport

#1

Ok, I have attempted to backup my Rosetta Stone Farsi discs 640 times. I cannot get them to back up. I have back ups of Arabic level one and two discs that DO work.

I have the Farsi set (levels one and two, lessons 1-19). I cannot get the RS program to read the Farsi.

I have the disc (or mounted ISO image) set up like this:

Root directory: All the FAR and PCT folders, and the three TRS files (CDID, credits, and CATMPC). The disc is named FAR_LEV1+2.iso (or the disc).

I mount the disc in D-Tools and start up Rosetta Stone (I have tried just about every version of the application, but currently I am using v2.1.3.0.a). If I don't include the CATMPC file it simply doesn't find the language. If I include it, it says "ERROR PARSING CATMPC.TRS: Cannot recognize 'Farsi' ". I have also tried to set up the CATMPC file to say Farsi Set but it gives the same error (cannot recognize "Farsi Set" instead though).

Below I have included images of what my ISO directory looks like, and links to all of my TRS files. I think the problem lies within the TRS setup. I know I am missing something simple or something.

If anyone can help or provide suggestions I am all ears.

Lastly, does anyone have a working backup of Rosetta Stone Farsi, or is it the elusive language that simply won't back up???

Here are the links to all the information I talked about:

TRS files:
http://www.ej20.us/Matthew/CATMPC.TRS
http://www.ej20.us/Matthew/CDID.TRS
http://www.ej20.us/Matthew/Credits.TRS

Screen shots (not that I am not trying to show EVERY folder in these screen shots, just the way it is set up and the basic naming conventions. Basically there are three things in the ISO: the FAR folders, the PCT folders, and the TRS files):

http://www.ej20.us/Matthew/ss1.jpg
http://www.ej20.us/Matthew/ss2.jpg
http://www.ej20.us/Matthew/ss3.jpg

PS - If I include the Autorun files on the ISO or disc, when I put in the disc or mount it, it says Rosetta Stone is not installed on this computer (it clearly is).


#2

Most likely it is copy protected by Safedisc or Securom or some other form of copy protection and that is why you are not able to back it up properly. You should try CloneCD, Blindwrite, or Alcohol 120% to backup your discs. I don’t think any drive can do 1:1 copies anymore or how many sheeps burners are rated now. Everything for backups now seem to be all emulated in one form or another. If I were you I’d just use Alcohol 120% and make an image in mds mdf format and try to load it from that. It’s been ages since I’ve tried to back up anything protected, guess I just gave up backing up discs I own :stuck_out_tongue: . But for the most part I have gotten protected discs to properly work with Alcohol 120% and Blindwrite and the crappy part is, I always had to have the software installed and some form of emulation enabled.

Otherwise if enough people complain and stop buying Rosetta Stone’s software you can get the protection remove, kinda like the Star Force fiasco. But I doubt that will happen.


#3

I don’t think this is the problem. I think it is something to do with the way the files are worded or set up. I have used every CD program known to man, including the ones you listed. Nothing changes.

I think it boils down to the way the CATMPC file is worded. Thanks for the help though.


#4

It very much sounds as though you’re not trying to make a disc image or copy of an original disc but rather you are modifying the files within the iso image or burnt copy.

First, please advise if your original disc works.

If so, then simply make an image of that disc using alcohol with plain old safedisc datatype settings, install the program from an image mounted on your daemon tools virtual drive and then mount the image of your language disc after using arom hiding utility such as sd4 hide.


#5

My problem is, I copied all the files to my external hard drive when I was in Afghanistan and then lost all of my movies and computer program CDs when I redeployed (the Army lost the entire CONEX filled with most of our personal gear).

Fortunately I still had my laptop and my external hard drive on my carry on baggage. The problem is, RS program will not read the languages from random folders and I hadn’t copied the three TRS files (like an idiot, I didn’t know they were needed, I figured I just needed the language files).

So basically, I have had to re-create the TRS files to the best of my ability and from reading my Arabic CDs (I did not have the Arabic discs with me in Afghanistan, so I have those intact with no problems), only substituting the word Arabic for Farsi.


#6

bump :frowning:


#7

You can’t expect to be able to re-create a safedisc 4 protected cd as a file copy and have it work. The necessary copy protection info simply will not be present whther you make the copy in image format or as a physical disc.

[PS Please do [B]not[/B] bump a thread just because you haven’t had an answer within 3 hours.]


#8

I still think it has to do with the wording of the particular file in question. Assuming it is what you say it is, how would I go about getting it to work?

I appreciate the help, but I don’t think someone without the program and language is going to be able to help.