Burn't dvd don't run

i have a lg dvd writer ,running win7.i have burn’t an iso file on dvd DL with nero10 .nero burn it successfully and verified also.but after checking the disc it won’t read the disk.it say wither drive is empty or tray is open.
i have also checked it in other pc running windowxp with lg writer.but still it can’t read.
why a successfully burn’t and verified won’t run?
this is my third attempt to burn that iso on DL.first i got burn error with nero,second i tried to burn it with imgburn but it give some error at starting that i don’t remember.
btw i have dma on ,i also do regular defragmentation and scandisk.my drive is a new one [rma].i use national DVD-DL

99% of these problems are disk related. If you are not using Verbatim DL your chance of success is isn’t very good.

At least 1% is user error.

Its also questionable if the content / ISO is error free depending on how it were created…

[QUOTE=Whappo;2579995]99% of these problems are disk related. If you are not using Verbatim DL your chance of success is isn’t very good.[/QUOTE]

another burning failed from the same batch.
i have used this brand before but it hadn’t give me error.may be the batch defective?
here is the disc info
Disc Type DVD+R DL
Book Type DVD+R DL
Manufacturer Mitsubishi Chemical Corporation
Media ID MKM001
Protection System None
Region 1,2,3,4,5,6,7,8
Capacity 7.96 GB
Layer 0 Capacity 3.98 GB
Free Size 7.96 GB
Free Blocks 4173824
Number of Layers 2
Track Path OTP
Maximum Rate Not Specified
Linear Density 0.293 um/bit
Track Density 0.74 um/track
Maximum Read Speed 5.0x
Maximum Write Speed 4.0x
Current Write Speed 4.0x CLV
Write Speed Performance Descriptor 1 4.0x CLV
Write Speed Performance Descriptor 2 2.4x CLV

Try burning with ImgBurn and post the log. You can find the burn log in ImgBurn by clicking Help–>ImgBurn Logs

i used the same disk earlier with imgburn but it gave me error before the burning starts
Here is the log
; //\
; ImgBurn Version 2.5.1.0 - Log
; Tuesday, 08 March 2011, 20:47:05
; \
//
;
;
I 20:45:29 ImgBurn Version 2.5.1.0 started!
I 20:45:29 Microsoft Windows 7 Ultimate Edition (6.1, Build 7600)
I 20:45:29 Total Physical Memory: 1,834,100 KB - Available: 1,229,640 KB
W 20:45:30 Duplex Secure’s SPTD driver can have a detrimental effect on drive performance.
I 20:45:30 Initialising SPTI…
I 20:45:30 Searching for SCSI / ATAPI devices…
I 20:45:30 -> Drive 1 - Info: HL-DT-ST DVDRAM GH22NS50 TN02 (M:) (ATA)
I 20:45:30 -> Drive 2 - Info: ILIZA 6789YBK 1.03 (Q:) (SCSI)
I 20:45:30 Found 1 DVD±RW/RAM and 1 BD-ROM/HD DVD-ROM!
I 20:46:02 Operation Started!
I 20:46:02 Source File: D:\Image.iso
I 20:46:02 Source File Sectors: 3,767,936 (MODE1/2048)
I 20:46:02 Source File Size: 7,716,732,928 bytes
I 20:46:03 Source File Volume Identifier: SC2-L100-D1
I 20:46:03 Source File Volume Set Identifier: 4C4F88FB4C4F88F1
I 20:46:03 Source File Implementation Identifier: EZB UltraISO
I 20:46:03 Source File File System(s): UDF (1.02)
I 20:46:03 Destination Device: [0:1:0] HL-DT-ST DVDRAM GH22NS50 TN02 (M:) (ATA)
I 20:46:03 Destination Media Type: DVD+R DL (Disc ID: MKM-001-00) (Speeds: 2.4x, 4x)
I 20:46:03 Destination Media Sectors: 4,173,824
I 20:46:03 Write Mode: DVD
I 20:46:03 Write Type: DAO
I 20:46:03 Write Speed: MAX
I 20:46:03 Link Size: Auto
I 20:46:03 Lock Volume: Yes
I 20:46:03 Test Mode: No
I 20:46:03 OPC: No
I 20:46:03 BURN-Proof: Enabled
I 20:46:03 Write Speed Successfully Set! - Effective: 5,540 KB/s (4x)
I 20:46:03 Book Type Setting: DVD-ROM
I 20:46:03 Optimal L0 Data Zone Capacity: 1,883,968
I 20:46:03 Optimal L0 Data Zone Method: ECC Block Boundary
E 20:46:54 Set L0 Data Zone Capacity Failed! - Reason: Write Error
E 20:46:59 Operation Failed! - Duration: 00:00:51
I 20:46:59 Average Write Rate: N/A - Maximum Write Rate: N/A
I 20:47:04 Close Request Acknowledged
I 20:47:04 Closing Down…
I 20:47:05 Shutting down SPTI…
I 20:47:05 ImgBurn closed!

i don’t why this is happenning,does my drive is failing again.
it won’t read if i use explorer to read the burned disc.but using isobuster after a couple of minutes it identifies the disc and explorer also now read the contents.i copied the whole content without any error using explorer.
but after i closed isobuster and again tried to read using the explorer, it did’t work.i also tried tried to read other DL dvd ,it taked a lot of time to read them .