Burns ok but cant read what it's just burned

Hi there, I’ve finally got my BTC 1016 to burn onto DVD but the problem I have now is that it wont read what it’s just burned! I’m using Nero 6 and burning in UDF_mode1. I’ve tried writing it at both x8 and x4 with no joy! I’m using firmware A190… and Datawrite Titanium x8 DVD-R discs.

Burn again but this time with Verify.

If it verifies OK the issue is with your OS/software.

I’ve just tried to verify after burning and it still won’t work. I saved the log file from nero, if you can make something of this it would be great, this is just the last bit of the log if you need anymore of it just let me know! By the way I’m running Windows XP pro as the OS…

Recorder needs eject between burn and verify. Auto reload.
	(Medium in drive: Unknown. Medium required by compilation: DVD.)

23:42:39 #75 VERIFYERR 10 File UDFCompilationImpl.cpp, Line 1306
Cannot mount the written CD
"DVDRW IDE 16X " (H:1, T:0)

23:42:39 #76 VERIFYERR 13 File UDFCompilationImpl.cpp, Line 1360
Status summary
Total files=0, identical=0, different=0, inaccessible=0, skipped=0.

23:42:39 #77 Phase 81 File dlgbrnst.cpp, Line 1800
Data verification failed

Serious driver problem.

Re-install the UDF reader/driver and delete the upper & lower filters, then restart.

Search the m$ support sites for more info.