Burning photo to CD problems

I am trying to copy photos to my CD, as I have done many times before
without problem. Now, when it is time to write the temporary file to
the CD, my CD won’t do it. I push the button to write and nothing
happens. As a matter of fact if I hit the button below it to erase
the CD, nothing happens. Any help out there?

I am currently using a Dell with Windows XP. Optiarc ND35-70A DVD-CD R

In “my computer” right click the drive in question, click properties, click recording, click “enable CD recording on this drive”.
Welcome to the forum.
Post back if that does or does not work.

Its already clicked. Same problem.

1> Press on the Start Button at the bottom left of your Desktop !

2> Goto Run and when it opens copy and paste or just type in

" %SystemRoot%\system32\services.msc /s "

Without the quotes. Then press OK.

3> Scroll down to “IMAPI CD-Burning Com Service” and double click on it.

4> When it opens Select Start then select OK and close the Service Window

Thanks.

Just tried that. Same problem.

Is it a CD-RW disc? try another disc yet??..

It is a CD-RW disc. I have tried other discs.

What were you doing at the moment the problem first appeared? Did you try a system restore, yet? Did you recently install any new software or hook up any new hardware to the computer? Does the optical drive recognize CD’s? Can you play a music CD? What program are you using to copy photos to CD? These buttons which do not work, are they faded out (gray) or do they look normal? Check Device Manager for any red X’s or exclamation marks next to this drive?

I was just burning the photos to the CD. I did try a system restore. No new hardware. I did recently install a Icon making program. I can play music and games with the CD drive. The buttons that don’t work do not seem faded. The Device Manager shows no red x’s or problems.