Burning Mode 2 and Mixed Mode CD's

I have a Ricoh RW7060s drive and it seems it cannot read mode 2 CDs. I have tried various programs to burn (Nero, CDRWin, etc…) and all the programs say that the images have burned properly yet when I got to attempt to read them in any CD-Rom readable device. I have installed Windows 2000 Pro more times than I care to admit and I have tried doing it with and without the latest ASPI drivers from Adaptec. One mode 2 cd’s such as a SVCD the CD’s show up as an Audio CD on the Windows Explorer or in My computer. On mixed mode CD’s ones that have Audio and Data I simply get a CD isn’t readable. I have another system which has a completely different setup which includes a different brand of CD-burner and DVD Drive running ME and the same thing happens on it. I know the images are good because other people don’t seem to have a problem with burning them. The CD shows up fine on their machines. What am I doing wrong?:confused:

have u tried using discjuggler?

padus.com

its not picky on drives and is a splendid program
:smiley: