Burning GTA Vice City

Hello all, this is my first post on this forum. I keep Googling how to successfully backup my GTA:VC play disk, and it keeps giving me posts on this forum. I figured I’d register and explain that none of those posts have helped me.

I have read enough from this forum to know that Vice City is protected by Securom 4.8. I have followed various instructions on this site specific to this game, as well as general 4.8 instructions…the image records fine, with only one error at the end (I’m familiar with copying Safedisc and am therefore accustomed to seeing lots of errors), but then when I ‘load’ the image into my virtual DVD, the mouse icon changes to the spinning CD icon and stops. In task manager, GTA-VC.EXE terminates itself at this point.

I tried again, re-copying the image and then adding the step of using Twinpeaks (but used the almost identical program TwinCreator, included with Alcoholer, so I could use an MDS file instead of a BWA file because I can’t locate a BWA file and the BWA maker program is impossible to find). This time, GTA-VC.EXE hangs with the CD mouse icon. It has to be manually terminated and the game itself does not start.

Seeing as I play this game a lot, I would like to know that I have a working backup should I damage the disk. I’ve copied and copied and copied and used every method except this RPMS thing I keep reading about. I do NOT use what I don’t understand…it’s a general rule that I have.

The software that I have is Alcohol 120% 1.9.5 build 3105. I also have CloneCD (can’t be bothered to find version number at the moment) and VSO BlindWrite 6. On their own, none of these three programs have been able to help me. BlindWrite seems utterly useless to me at this point, and CloneCD is producing useless images. Alcohol seems to be the way to go, if not because of the copy-protection-design built into it, but for the support on this forum.

I have a feeling that this would work if I could find the BWA builder. Unfortunately, it’s host websites seem to have disappeared off the face of the earth. If anyone is willing to email a copy, let me know.

Thanks, and sorry for the long post…figured I’d squeeze in as much as possible now.

-Kevin

PS Contrary to what my sig says, my burner is a Dynex…no clue on the model number, but it’s a value-oriented product.

When you select [B]Image Making Wizard[/B] make sure your [B]Datatype[/B] is set to [B]Securom *New (4.x/5.x)[/B] for your read and write. Whn asked for RMPS speed you can leave it maxed. Your burner is not a 2sheep burner so it will not write the bitpattern back correctly so you will need [B]Alcohol 120% Emulation enabled[/B]. You can find this option off to your left hand side and check the box the says [B]RMPS (Recordable Media Physical Siganature) Emualtion[/B].

Try these settings and post back and let us know how it goes.

Hmm…well, my objective was to burn an image that I could load into the virtual drive, but with that datatype it had to use MDS which can’t be used that way. So, in a nutshell, I have yet another coaster.

I enabled RMPS emulation, then restarted (just to ensure there were no pending changes). I tried to burn the disk, and it told me that RMPS couldn’t be started because something failed.

The disk has all the same files on it (I compared) but the game won’t start with it in. I’ll keep the disk in case there’s some way to use it, but it’s just an R and not an RW.

MDS is part of Alcohol’s native format and certainly can be mounted to a virtual drive.

That is the way I install my games with Alcohol is to set up 4 or 5 virtual Alcohol drives and mount the mds image of each disk on each drive. It is so nice to watch it install a game so fast and perfectly. It goes from the 1st disc right on to the last without any user intervention… :bigsmile:

I’m aware it’s the native format…however, Alcohol ever-so-kindly refuses to load MDS files into virtual devices. It says something along the lines of “unsupported image”. One sec, I’ll go take a look…

“Invalid image file.”

Including attachment (screen capture), though as an Alcohol tech I’m sure you know the dialog I mean.


The image is bad I’m thinking or corrupted, it has the right extension but if it’s corrupted Alcohol is not going to reconize it as being any good, just have to get a image from a better source…

Question the image setting above the mds what file is that (unknown), is that the 2nd part of the image, it looks like a problem with a corrupted archive being unrared and getting only a few blocks that were good while others were missing giving you an incomplete image…

I had a feeling someone would ask about that…

That was from one of my previous attempts to burn the game. I was experimenting with all the different settings to see if one lucky combination would do it, but it didn’t. That was a bad image, not related to the new one.

The descriptor file for this “good-er” image was not shown in that list but is in the folder with the image. It is 534 bytes.

An .mds file for a securom 4.8 protected cd would have to be significantly larger than 534 bytes in order to contain the necessary dpm information. I suggest that you make a fresh image from your original cd using securom new 4.x/5.x datatype settings and see how that goes.

This Works with me. Copy install disc on CD-R. Then Rip all the files off the Play disc using ISOBuster. Then Create Mini-Image of CD. Burn Mini-Image and Data on CD-R. Then when ever I need the mini-image I rip it off the CD.

Thanks Id33k, but as it happens it worked the other way.

It worked, and it worked well…interestingly, this time RMPS didn’t fail, so that means that RMPS was the issue all along. I ripped the image (“dumped” in Alcohol terms) at 24x.

The MDS is 27kb…much better compared to 500-some bytes. The image works fine in the virtual drive, and I think I’ll just leave it there until I need the drive again.

Thanks everyone, this was annoying the heck out of me at first.

-Kevin

id33k what do you mean?

kkishkon,after all that is your GTA VIce City working with a virtual cd,is your cd label Vice_City_PLAY or Vice_City_play,what what are the file’s that have in your image.??

one question again
what disc is your disc inserted when you play Vice City,disc 1 or disc 2?

reply

Er, shouldn’t you be able to check the original discs for this information?

one question
how can i make mini image that the size only is KB??
coz my install disk is 660MB and i want to create image securerom to a small size…like Id33k what he did do to make small size image of an installer??

You pretty much need to follow the tutorial. Basically what you want to do to create a Mini-Iso. Cancel about when it gets to 1%.

See Here:
http://club.cdfreaks.com/showthread.php?t=131341