Burning ends at half disc (Nero EndTrack and more probs)

vbimport

#1

Hi all :slight_smile:

This is my first message in this nice place hehe :wink: Anyways; i've searched this forum, but didn't really find anything that nailed my problem...

All of the sudden, I got burning problems with my old CDR (a Sony 8x). It sounded really messed up, so I borrowed an almost new Plextor 12/10/32A from a m8. First disc went just fine @ 12x. Second and sporadic (most of the times) discs after that also went coasters.... :frowning:

So first of all, my specs: [b]
Windows 2000 Pro SP1
Intel PIII @ 1GHz
512mb PC 133
Gigabyte VIA mobo (VIA 4-in-1 v.4.38V installed)
Plextor 12/10/32A burner (latest. v.1.09 firmware)
Kodak Ultima 80 CDR Media

Nero Burning Rom v.5.5.8
NTI CD-Maker 2000 Professional
Adaptec ASPI layer v.4.70 (got a 2940AU card in the system too)

The Plextor is set in DMA mode as slave on the secondary IDE channel (Master on that one is an IBM Deskstar disk in UDMA mode).
I have a similar setup on the primary IDE channel, but with DVD reader.[/b]

The funny thing is that it works sometimes. And it doesn't seem to have anything to do with which speed I choose to burn in. And it fails in different percentages of completion each time it chooses to fail...

In Nero I get this "Cannot perform EndTrack" problem. NTI desn't specify it that way, only pukes the CD out and say's thay I should try cleaning the media or somethin...

I've tried this already:

  • Uninstalled CloneCD
  • Updated the VIA Chipset drivers to v.4.38V
  • Updated the ASPI drivers to v.4.70
  • Made sure I got 800mb+ on my Nero cache drive
  • [li]Tried another burning app (NTI)

[/li]Here are example logfiles from Nero:


Windows 2000 5.0
WinAspi: File 'Wnaspi32.dll': Ver=4.70, size=45568 bytes, created 2001-12-10 17:32:34
ahead WinASPI: File 'C:\Program\ahead\Nero\Wnaspi32.dll': Ver=2.0.1.45, size=172099 bytes, created 2002-05-02 00:39:17
Nero Version: 5.5.8.0
Recorder:             <PLEXTOR CD-R PX-W1210A>  Version: 1.09 - HA 1 TA 1 - 5.5.8.0
 Adapter driver:      <atapi>                   HA 1
 Drive buffer  :      2048kB
 Bus Type      :      default (0) -> ATAPI
CD-ROM:               <PIONEER  DVD-ROM DVD-105>Version: 1.22 - HA 0 TA 1 - 5.5.8.0
 Adapter driver:      <atapi>                   HA 0
 Bus Type      :      default (0) -> ATAPI

=== Scsi-Device-Map ===
DiskPeripheral       : IBM-DTLA-307060                  atapi Port 0 ID 0  DMA: On 
CdRomPeripheral      : PIONEER DVD-ROM DVD-105          atapi Port 0 ID 1  DMA: On 
DiskPeripheral       : IBM-DTLA-307060                  atapi Port 1 ID 0  DMA: On 
CdRomPeripheral      : PLEXTOR CD-R   PX-W1210A         atapi Port 1 ID 1  DMA: On 
DiskPeripheral       : iomega  jaz 1GB         J^77   aic78xx Port 2 ID 4  DMA:  ? 
=======================

AutoRun : 1
Excluded drive IDs: 
CmdQueuing     : 1
CmdNotification: 2
WriteBufferSize: 61865984 (0) Byte
ShowDrvBufStat : 0
EraseSpeed     : 0
BUFE           : 0
Physical memory     : 511MB (523760kB)
Free physical memory: 301MB (308768kB)
Memory in use       : 41 %
Uncached PFiles: 0x0
Use Static Write Speed Table: 0
Use Inquiry    : 1
Global Bus Type: default (0)
Wizard: Off

CD-ROM (ISO)
4.5.2002

19:54:02	#1 Text 0 File Isodoc.cpp, Line 5095
	Iso document burn settings
	------------------------------------------
	Determine maximum speed : FALSE
	Simulate                : FALSE
	Write                   : TRUE
	Finalize CD             : TRUE
	Multisession            : FALSE
	Burning mode            : TAO
	Mode                    : 1
	ISO Level               : 1 (Max. of 11 = 8 + 3 char)
	Character set           : ISO 9600
	Joliet                  : TRUE
	Allow pathdepth more than 8 directories : TRUE
	Allow more than 255 characters in path  : TRUE
	Write ISO9660 ;1 file extensions        : TRUE
	
19:54:02	#2 Phase 72 File dlgbrnst.cpp, Line 1449
	BURN-Proof activated
	
19:54:02	#3 Text 0 File Reader.cpp, Line 118
	Reader running
	
19:54:02	#4 Text 0 File Writer.cpp, Line 129
	Writer PLEXTOR  CD-R   PX-W1210A running
	
19:54:02	#5 Text 0 File Burncd.cpp, Line 2636
	Turn on Track-At-Once, using CD-R/RW media
	
19:54:02	#6 ISO9660GEN -11 File geniso.cpp, Line 4428
	First writeable address = 0 (0x00000000)
	
19:54:02	#7 Text 0 File ThreadedTransferInterface.cpp, Line 684
	Setup items (original item values)
	 0: TRM_DATA_MODE1 (CTransferItem)
	    2 indices, index0 (150) not provided
	    original CD pos #0 + 358443 (358443) = #358443/79:39.18
	    relocatable, CD pos for caching/writing not required/required, no patch infos 
	--------------------------------------------------------------
	
19:54:21	#8 Text 0 File DlgWaitCD.cpp, Line 199
	Last possible write address on media:   359848 (79:59.73)
	Last address to be written:             358442 (79:41.17)
	
19:54:23	#9 Text 0 File DlgWaitCD.cpp, Line 1387
	Recorder:  PLEXTOR CD-R PX-W1210A;
	   CDR code: 00 97 27 46; OSJ entry from: Kodak Japan Limited
	   ATIP Data:
	     Special    Info [hex] 1: C0 00 A0, 2: 61 1B 2E (LI 97:27.46), 3: 4F 3B 4A (LO 79:59.74)
	     Additional Info [hex] 1: 00 00 00 (invalid), 2: 00 00 00 (invalid), 3: 00 00 00 (invalid)
	
19:54:25	#10 Text 0 File ThreadedTransferInterface.cpp, Line 834
	Prepare recorder PLEXTOR  CD-R   PX-W1210A for write in TAO
	DAO infos:
	==========
	MCN: 
	TOCTYPE: 0x0   Close CD
	Tracks 1 to 1:
	   TRM_DATA_MODE1, 2048/0x0, ISRC "", FilePos 0 307200 734398464
	
19:54:25	#11 Text 0 File ThreadedTransferInterface.cpp, Line 862
	Removed 2 run-out blocks from end of track 1.
	
19:54:25	#12 Text 0 File ThreadedTransferInterface.cpp, Line 684
	Setup items (after recorder preparation)
	 0: TRM_DATA_MODE1 (CTransferItem)
	    2 indices, index0 (150) not provided
	    original CD pos #0 + 358443 (358443) = #358443/79:39.18
	    relocatable, CD pos for caching/writing not required/required, no patch infos 
	    -> TRM_DATA_MODE1, 2048, config 0, wanted index0 0 blocks, length 358441 blocks [PLEXTOR  CD-R   PX-W1210A]
	--------------------------------------------------------------
	
19:54:25	#13 Phase 24 File dlgbrnst.cpp, Line 1449
	Caching of files started
	
19:54:27	#14 Phase 25 File dlgbrnst.cpp, Line 1449
	Caching of files completed
	
19:54:28	#15 Phase 36 File dlgbrnst.cpp, Line 1449
	Burn process started at 12x (1Â 800 KB/s)
	
19:54:28	#16 Text 0 File ThreadedTransferInterface.cpp, Line 1960
	Verifying CD position of item 0 (relocatable, CD pos, no patch infos, orig at #0): write at #0
	
19:54:28	#17 Text 0 File Mmc.cpp, Line 15361
	Set BUFE: BURN-Proof -> ON 
	
19:59:15	#18 SCSI -1135 File Cdrdrv.cpp, Line 1413
	SCSI Exec, HA 1, TA 1, LUN 0, buffer 0x08B70000
	Status:     0x04 (0x01, SCSI_ERR)
	HA-Status   0x00 (0x00, OK)
	TA-Status   0x02 (0x01, SCSI_TASTATUS_CHKCOND)
	Sense Key:  0x03 (KEY_MEDIUM_ERROR)
	Sense Code: 0x0C
	Sense Qual: 0x07
	CDB Data:   0x2A 0x00 0x00 0x03 0xB9 0xDB 0x00 0x00 0x1F 0x00 0x00 0x00 
	Sense Data: 0xF0 0x00 0x03 0x00 0x03 0xBA 0x71 0x0A 
	            0x00 0x00 0x00 0x00 0x0C 0x07 
	
19:59:15	#19 MMC -1135 File Writer.cpp, Line 330
	Write error
	
19:59:15	#20 Text 0 File ThreadedTransfer.cpp, Line 222
	all writers idle, stopping conversion
	
19:59:15	#21 Text 0 File ThreadedTransfer.cpp, Line 216
	conversion idle, stopping reader
	
19:59:26	#22 CDR -201 File WriterStatus.cpp, Line 186
	Invalid writestate
	
19:59:26	#23 TRANSFER -18 File WriterStatus.cpp, Line 186
	Could not perform EndTrack
	
19:59:50	#24 Phase 38 File dlgbrnst.cpp, Line 1449
	Burn process failed at 12x (1Â 800 KB/s)
	
19:59:50	#25 Text 0 File Scsicmd.cpp, Line 386
	SCSI not using temporary buffers
	20 out of 20 temporary buffers allocated
	

Existing drivers:
File 'Drivers\ASPI32.SYS': Ver=4.70, size=17101 bytes, created 2001-12-10 17:29:42
====== *** Nero-Burning Rom, History File *** ======

...and NTI:


========== BEGIN OF LOG ==========

NTI CD-Maker 2000 Professional Version 5.1.17  (SKU-22510358888)
Start Time: Sunday, May 05, 2002, 11:50:34AM

DIEN DEBUG: sysInfo.wProcessorArchitecture: 0
DIEN DEBUG: sysInfo.dwProcessorType: 586
Processor Architecture: INTEL
Processor Type: INTEL PENTIUM
Processor Level: 6
Microsoft Windows 2000 Professional version 5.0 Service Pack 1 (Build 2195)
Memory in use: 39%
Total physical memory: 523 MB
Total free physical memory: 317 MB
Total paging file: 882 MB
Total free paging file: 661 MB
Total virtual memory: 2097 MB
Total free virtual memory: 2044 MB

CD Layout: Data CD
Disc Format: CD-ROM
File System: Joliet
Bootable CD: No
Total Data Blocks: 350976

CD-Recorder: PLEXTOR CD-R PX-W1210A (G:)
Firmware Version: 1.09
Disc Media: CD-R
Free Disc Blocks: 359847
Test: No
Write Speed: 8x
Write Method: Disc-At-Once
Close Disc: Yes
Leave Session Open: No

Error Code: 1014
CDB: 2A 00 00 02 D1 3A 00 00 20 00 00 00
SenseKey:03 ASC:0C ASCQ:07

Finish Time: Sunday, May 05, 2002, 11:56:16AM

========== END OF LOG ==========

Help :confused: :wink:


#2

Have you tried using an other kind of cd-r’s?


#3

Yupp, i’ve also tried Fujifilm media…

I’ve now manually uninstalled all Adaptec ASPI layer components, and i’m trying to burn using Nero and it’s own ASPI layer. 1CD, so far, so good :wink:

I also noticed that Nero started much faster when there was no external ASPI layer. Another thing I noticed was that Nero’s record buffer jumped as low as 70% (median ~94%) :eek:.

My D:\ which I burned from was 95% fragmented :o hehe… although I don’t really think this is related to the problem’s i’m having though, since i’ve burned off of defragmented partitions earlier.


#4

Ok, PROBLEM SOLVED

It turns out there could be a conflict with the ASPI layers. I had previously v.4.60 installed, and upgraded to v.4.70.

I don’t know if some components are still v.4.60 in the v.4.70 release from Adaptec, but you will discover all this by running the ASPICHK.EXE utility that Adaptec provides.

Since Nero desn’t require and ASPI layer to be installed on the OS (since it got it’s own WNASPI32.DLL in it’s Program dir), an extra, OS native ASPI will most likely only mess things up. I think this can also be traced in the Nero log above… which I drew conclusion from…

To delete the Adaptec ASPI layer, start by deleting or renaming the %WINDIR%\System32\Drivers\aspi32.sys file. Then reboot and delete the rest of the files (same as the one’s that the v.4.70 installer has with “._” suffixes in the \adaptec\aspi folder the installer creates).

Problem solved :wink:


#5

Oh no… it worked for a week, and now i’m here AGAIN :frowning: :frowning: :frowning:

Anyone with fresh ideas?

Seems like it burns almost 100% or 100% this time… but I still get that “Could not perform EndTrack” problem… :mad:


#6

Ok, i’ll continue my monologue here… :rolleyes:

I’ve set the IDE burner in PIO mode now, and I could burn in 12x without problems (well, my whole system went reeeeally slow because of the PIO mode).


#7

I dont think that deleting the adaptec apsi layer was a good idea in the first place. Both nero’s aspi and windows native aspi suck bigtime.

It’s not a good idea to upgrade aspi 4.6 to 4.7 either, at least if you use windows XP (many ppl have stated they had several problems with it - afteral it anly changes 2 out of 4 dll files i think). So i would suggest sticking to aspi 4.6

There’s no logical reason setting both your hdd and cdrw to pio mode. This will only get transfer rates lower and create bigger problems.

Did both your old drive and the new plexie come up with the same exact problem?