Burner doesn`t write on DL anymore

Hi,

First I was happy with my NEC 3540A with the firmware 1.03, but after I found out that the burner doesn`t write on the DVD DL from MITSUBISHI DVD-R DL 8x, I looked for a firmware update and found 1.04.

Unfortunately the firmupdate didnt solved te problem and I still cant write on the MITSUBISHI DVD. Not only that; now I can`t even write on the TDK DVD-R DL 8x which worked fine before the firmware update. But the Bruner still works fine on Single layer DVDs.

While I looked for an solution, I found modified firmware updates and tried Liggy’s and Dee’s LD3540 1.W9.

Even after changing the firmware to 1.W9 I still cant burn the DL DVDs.
But now I cantt flash back the firmware to 1.03 nor 1.04 because the it says that it cant find the device 3540A.

Can somebody help me?

I am useing XP Sp2 with NERO ver.8

When ever I try to burn, NERO tells me to put in a DVD with a Layer Jump Support. But if I run DISC INFO it recognizes the DVD as a empty DVD R DL.

Welcome to the forum.
You can load your downloaded original firmware into Binflash (it accepts .EXE files too) and flash the drive.

Thank You for your answer.

I`ll give it a try.