Burner acts weird / CD Speed errors

vbimport

#1

this is a little long… sorry
I have a Philips 40x12x48 burner and noticed it seemed to be reading slowly lately so tried to run a test in CD Speed to see if it was just my imagination or not. Tried to run 6 full tests with 4 different CDs and none of them completed. I either got a focus servo error, or CD Speed would freeze when it got to the seek time test. The burner still writes fine however.

There is also this weird thing that happens sometimes where my burner will all the sudden stop working (cant read any CDs) and the drive tray acts as if its stuck when you try to eject a disc. When you hit the eject button the tray comes out about half an inch then goes back in about 2 or 3 times and stays closed. The only way I have found to solve it is to uninstall the burner completely (IDE cables and all) and reinstall it. Then it works fine for another couple weeks or so til it does it again.

Any ideas about what could be goin on with it?

XP Pro SP1a
Celeron Tualatin 1400
Intel 440BX mobo
512 ram