Burned DVDs don't really play in my standalone DVD player

My first BTC 1004 burner (firmware 0043) burned dvd movies fine and they all played on my Pioneer DV-414 dvd player. Since I exchanged that drive for another BTC 1004 due to a problem, this new one burns dvds fine but freezes while playing in my dvd player. I have tried burning a movie using 0043 firmware and 0047 but the movie occassionally freezes or green blocks/distorted picture appears. I tried those same movies in my friend’s Samsung dvd player and it played fine. He didn’t get the same problems I did. So where does the problem lie? :confused: I’m thinking this second one I have has problems and might exchange it again for another one.

BTW, I am using 4x Ritek/RiData Media (RITEKG04)

You can try another burning software like CopyToDVD. Different burning SW will get different compatibility to DVD player.

Don’t forget to check the following while using CopyToDVD:
Options->CopyToDVD Settings->File System->UDF 1.02.

Good luck.