Bug report: this news article is incorrectly dated


#1

That go for three posted comments, too. On the forum, the article is dated 5 days ago. However, I remember reading said article months ago. On the front page, that same article is dated March 06, 2017. I could have sworn the article was older than that, however. Maybe that’s just me. :-\

Here is the article on the forum:

And here it is on the front page:


#2

You’re right - It looks like something’s gone wrong with the news threads created over the past week.

I went through the past week in the news forum and these threads were created over the past week for old news stories dated below:

  • Microsoft develops customized Windows 10 version for Chinese government - 21st March 2017
  • Portugal Passes Legislation to Restrict DRM - 10th April 2017
  • US-CERT warns for end of support of Windows Vista next month - 17th March 2017
  • Windows 10 Creators Update reduces updates with up to 35% thanks to UUP - 6th March 2017
  • Microsoft patches zero-days in Windows and Internet Explorer - 15th March 2017
  • Micron 5100 ECO 1920GB SATA Enterprise SSD Review - 28th March 2017
  • Malware abuses antivirus software to attack computers - 22nd March 2017
  • Microsoft shows OneDrive advertisements in Windows 10 File Explorer - 10th March 2017
  • Toshiba’s shareholders agree to split of NAND division - 30th March 2017
  • Broadcom offers $18 billion for Toshiba’s NAND memory manufacturing division - 31st March 2017
  • Microsoft sued for data loss and damage to PC due to Windows 10 upgrade - 27th March 2017
  • Windows 10 users targeted in new social engineering attack - 9th March 2017
  • Security reseachers: Youtube’s encryption reveals viewing behavior - 14th March 2017
  • New technology could increase HDD storage density by 1,000 times - 9th March 2017
  • Microsoft tests new warning screen when blocking Flash content in Edge - 27th February 2017
  • Microsoft officially announces Windows 10 Creators Update and Mixed Reality headsets - 29th March 2017
  • Free tool allows upgrade to Windows 10 Creators Update before official release - 28th March 2017
  • BackBlaze: Best way to securely wipe data on SSDs involves throwing away the encryption key - 17th March 2017
  • Google reports decrease in malware on its Android Play Store - 22nd March 2017
  • Google fixes 107 vulnerabilities in Android - 7th March 2017
  • Ask.com toolbar used to distribute malware - 21st March 2017
  • Facebook forbids usage of its data by surveillance software - 13th March 2017
  • Google investigates issue with automatically logged out accounts - 24th February 2017
  • FedEx Office gives users $5 discount to enable Adobe Flash plugin in browser - 24th March 2017
  • New Windows 10 feature blocks applications that are not installed from the Windows Store - 27th February 2017
  • AV-Test: antivirus vendors should better protect their own software - 2nd March 2017
  • Microsoft warns for tax-themed malware and phising - 20th March 2017
  • Microsoft to announce new Surface Book in April – device already in mass production - 16th March 2017
  • Distribution of Windows 10 Creators Update could take months - 23rd March 2017

Threads older than a week appear to correspond with the news story date.


#3

I can confirm the issue. It’s really, really strange. I had a quick look but have no idea what could be causing this. Unfortunately I’m about to leave for a 10 day holiday, so I won’t have time to properly fix this.

I really hate that, because I’d love to squash this bug before I left. If there is some left to look at this, I will, else it will probably go on for 10 more days ;(

The only change I’ve made the last week is to switch the frontpage to HTTPS, but I can’t think of anything why that would be related.

I’m really for the inconvenience :frowning:


#4

@DoMiN8ToR: FWIW, it’s not really inconvenient to me. It’s just odd, that’s all. I mostly reported it because I see it as a way to contribute to this awesome site. So there’s no rush as far as I’m concerned.