Buffer underruns



When I burn at 24x with my LTR-24102B (firmware 5S5A) I get lot of buffer underruns, it happens approximately every 10 secs (red light turns into orange). At 20x writing buffer underruns don't occur. (I were using mmore 24x cd-r discs)

Writer is connected to secondary ide port as master (there's a cd-rom as slave). I were writing with CloneCD but I haven't yet tested if it happens with other programs.

My computer is 750Mhz and it has 128mb memory, it should be enough and DMA is enabled so I have no idea what causes problems. :confused:


Have you ever tried it with other media like verbatim ? These mmore’s are often no name crap. I have one of these (700MB 24x). If they are really no name crap they could be designed for who knows what speed and that could cause you trouble.


Thanks for help, I’ll buy better discs when I have used these mmores. This was first time I used 24x discs because I had 8x discs at storage.


Are you copying on the fly from the CD-ROM? if you are it will cause buffer underruns cos IDE channels cant read and write at the same time and if you have both writer and reader on the same channel it will have to stop and start to send and recive data.


Does it happen after you have be running awhile?
I have seen a few instances of high case temps doing stuff like this. Usually things go fine until the case heats up. If that is it add a bay fan in the bay above your burner.


I didn’t copy on the fly, I were writing a image which was at hard disc.

I haven’t tested if it happens right after starting the computer but I have never had any heat problems.


Try uninstalling the “secondary channel” under device manager -> IDE Controllers, let the PC reboot and let Windows detect your new hardware, then try burning another disc @ 24x. Hope this helps.


try a write transfer rate test with nero CD-Speed. Do the curve look ok then?

It may still be DMA related issues…


I tell you, some mmore’s are just not right. They are no name crap. These cd’s
give me a very funny curve in cd speed.
My soft is ok with dma enabled and everything else. I don’t know if that can cause buffer underruns. Still it might be dma, but it might be not. Check your mmore’s with cdridentifier to see if they are real.


At transfer rate test everything went well, light stayed red all the time (except when drive changed speed). So maybe crap media is causing problems.

CD-R Identifier gave this info:

ATIP: 97m 28s 26f
Disc Manufacturer: Multi Media Masters & Machinery SA
Reflective layer: Dye (Short strategy; e.g. Phthalocyanine)
Media type: CD-Recordable
Recording Speeds: min. unknown - max. unknown
nominal Capacity: 654.49MB (74m 30s 00f / LBA: 335100)


Your cdidentifier info is different from mine, but that doesn’t change the whole thing. What about your ide cable ? If it’s very old and crappy you should change it.
Also, you should try to burn on a verbatim, mitsui , tdk or fuji certified for 24x. Buy one of these jut to test. Burn at 24x of course. If everything’s alright you can be sure that mmore’s ain’t good thing.


I bought that ide cable less than 2 weeks ago and it is DMA 66, costed 4,9 euros. Buffer underruns happened also when I did a simulated writing with CloneCD right after I started my computer so it’s not heat. I’ll buy one of those discs you suggested and test it.


I tried simulated writing with CloneCD and TDK 700MB 24x and it still happened. :confused: (I didn’t test it earlier because I were at summer cottage)

CD-R Identifier gave this info:

ATIP: 97m 24s 01f
Disc Manufacturer: Taiyo Yuden Company Ltd.
Reflective layer: Dye (Long strategy; e.g. Cyanine, Azo etc.)
Media type: CD-Recordable
Recording Speeds: min. unknown - max. unknown
nominal Capacity: 702.83MB (79m 59s 73f / LBA: 359848)


When a CD-R/RW used to burn a full CD in 2 - 3min. and now takes about 10 - 15min. to finish the job, try closing down some applications that are running in the background especially anti-virus software, these programs running in the background tie up the computer resources which leads to buffer under runs(even with DMA enabled). If you select the option “prevent buffer under runs” then every time the buffer goes empty because the CD-R/RW is burning away to quickly the CD-R/RW will stop writing until the buffer is filled up again. Resulting in longer copy times. Also see if the buffer is not filled up with to much junk(Temp folder). This is probably why you only get buffer underruns when burning at speeds higher then 20x.


I have already tried closing ALL other programs. Didn’t help.

And 750Mhz with 128Mb memory should be enough even if some small applications are running.


Well, not totally the truth. A lot more comes into play than just the superficial 750 Mhz and 128 MB RAM.
Things like:

  • What type of CPU.
  • Amount and levels of Cache.
  • Speed/bandwidth of FSB.
  • Type of RAM [SD, DDR SD, RD, Single or dual channel bus]
  • Clock speed of RAM.
  • Type of MPCB.
  • Type of DMA supported.
  • etc. etc. etc…

I have witnessed P4 2.0 Ghz 400Mhz FSB systems with 512MB PC-800 RAM (40Ns) get buffer under runs when burning at 32x.
Some apps just tie up the resources that are needed atm.

Though indeed, if you have tried a selective startup(loading only the minimal of processes) this should have been fixed.
Non the less, I still think this issue is related to the software of your PC not the hardware.

What program(s) do you use to bake your CDs?



I am getting Buffer Underrun error message. How can I resolve this?

This information applies to the following product(s):

Easy CD Creator Deluxe Suite 3.x
Easy CD Creator Deluxe Suite 4.x

This information applies to the following Operating System(s):

Windows 95
Windows 98
Windows ME
Windows NT 4
Windows 2000

Buffer underruns are generally caused by a number things:

The performance of your system
Size and number of the files you’re recording
Location of the temporary directory and source files
Older device drivers (8 / 16 bit drivers)
Busmastering enabled for the IDE controllers
Applications / TSRs running in the background
Quality of recordable media
General Troubleshooting Steps:

  1. Close all running applications before launching Easy CD Creator by pressing [CTRL] + [ALT] + [DEL] and End Task on all except ‘Explorer’ and ‘Systray.’

  2. Run both Scandisk and Defrag on the hard disk(s) (To run click on ‘Start’, ‘Programs’, ‘Accessories’, and ‘System Tools’.)

  3. Clean Temp directory, in \WINDOWS\TEMP - move or delete all files and folders

  4. Make sure no real mode drivers are loading from CONFIG.SYS and AUTOEXEC.BAT (Rename the files to *.BAK or place a REM in front of each driver load statement)

  5. For Win 95 & Win 98 systems: go to the settings tab in Device Manager for each IDE device on your system and remove the check mark in the DMA box. For NT systems extract the program DMACHECK.EXE from the service pack disk (service pack 3,4 or 5), and run it. You will be able to disable DMA on screen.

  6. Update your video driver to current version - check with your video controller manufacturer for details

  7. Make sure the firmware on the recorder is current - most manufacturers publish the latest firmware on their web site

  8. Disable screen savers and ALL power management

  9. Do not multi-task while recording

  10. Do not record from a compressed drive

  11. Log off all network connections

  12. For Win 95 & Win 98 systems, set the following for the CD-ROM properties in Device Manager

In Control Panel, select ‘System’ icon
Click on the (+) on the CD-ROM
Highlight your recorder listed then click on ‘Properties’ button
Disable Sync Data Transfer / Enable Disconnect / Enable Auto Insert Notification on the ‘Settings’ tab
13. Make sure the C: drive has plenty of free space, recommend about 1 1/2 times the amount you want to record to CD

  1. Try a different brand of recordable media, recommend blank disks with the green or blue dye coating

  2. Create a temp directory on the root of the hard drive with most space available. Change the temp directory that Easy CD Creator uses as the buffer during the record process

  3. For Win 95 & Win 98 systems - check for the following in \WINDOWS\SYSTEM\IOSUBSYS and rename if found:

atapchng.vxd (used by CD changers)
necatapi.vxd (only if you do not have a NEC brand IDE CDROM)
torisan3.vxd (used only by Torisan brand 3 CD changers)
There may be others loaded by various software packages that will conflict, generally from other CD writing or similar products.
17. For Win 95 & Win 98 systems set the Optimize access pattern to ‘No Read ahead’, if it’s already at ‘No Read ahead’, try setting it for ‘Quad Speed’ or higher:

In Control Panel, select ‘System’ icon
Click on ‘File System’ button in ‘Performance’ tab
Change the ‘Optimize access pattern for’ under ‘CD-ROM’ tab
Additional Troubleshooting for SCSI Device :

  1. Make sure your SCSI Termination is set properly:

Internal devices only: The device farthest from the controller and the controller must be terminated. Nothing else can be terminated.
External devices only: The device farthest from the controller and the controller must be terminated. Nothing else can be terminated.
Internal and External devices: The two devices farthest from the controller must be terminated. Nothing else can be terminated.
2. Set the SCSI Controller to the following :
To access Adaptec’s SCSI controller setting, press [CTRL] + [A] during the boot sequence. To access non-Adaptec SCSI controller, contact your SCSI controller vendor.

Synchronous Negotiation = disabled
Wide Negotiation = disabled
Ultra or Fast SCSI = disabled
Maximum or DMA Transfer Rate = 5 MB / sec
Disconnection = enabled


Buffer Underrun
If a bufferunderrun occurs, then the CD Writer has not received the data quickly enough. One or several of the following 4 points is the cause in this case:

The source is too slow, e.g. if data is being transferred from a network, a floppy or from exchangeable data carriers.
The connection between source and the system is
too slow, i.e. if the source drive is connected to the parallel port and this is only being run in SPP mode or

is blocked at times by the connection being used by another device so that a constant flow of data is not possible.

The PC is too busy to process the incoming data, e.g. by using an active virus scanner in the background.
The connection between the system and the CD Writer is too slow or blocked at times (see 2.).

Initially it is advisable to download the newest Nero version from the ahead-WebSite as in the process of development the susceptibility of Nero with regards to buffer underruns is decreasing.
If you own a device by Iomega: Unfortunately its driver IOMEGA.VXD (in the Windows\System\IOSUBSYS directory) interferes with the data transfer. If you are only using a ZIP drive, then this driver can be removed or deactivated. See Deactivating drivers.
In Windows 98 and Windows 98SE drivers are loaded which as a generla rule are never needed but can cause problems. this drivers can all be found in the Windows\System\IOSUBSYS directory. See also: Deactivating drivers.
Is only needed if you are using an IDE CD changer.

Is only needed if you are using a very old NEC CD-ROM

Is only needed if you are using a Torisan 3x CD changer.

If a time of more that 100 minutes is given in the log file and if you are using a Sony 928 CD Writer (or compatible)
then switch off the automatic message when changing.

If the buffer Underrun occurs relatively near the beginning of the burning process, then for test purposes the switch off the automatic for the CD drives should be deactivated.
If you are using a mainboard with an Intel chip set, Windows 95 (until OSR2) and the busmaster driver is being used, then please update the busmaster driver to at least version 3.02, as this is the earliest version to correctly support CD-Rs and CD-RWs.
http://developer.intel.com/design/chipsets/drivers/busmastr/index.htm (Intel Chipsets: Busmaster IDE drivers for Windows 95)

If you use one of the following types of CD Writer :
Grundig CDR100IPW, HP 4020, Kodak CDR240, Mitsubishi CDVR2X4, Mitsumi CD-R CR-2401TS, Philips CDD2000, Plasmon CDR4220, Plasmon RF4100, Plasmon RF4102, Wearnes CDR-432

and you are using an Adaptec 1542CF, then you should use the Utility SCSISelect in Device Configuration for the ID of your CD burner to change the value from FAST SCSI to NO.

If you have installed Office 97 or newer, then this journal function should be deactivated. This journal function protocols every time files are opened and closed by an Office program. See: Deactivating the Journal function of Office.
A bufferunderrun can also occur if the driver NECATAPI.VXD is loaded.
The driver can be found in the Windows\System\IOSUBSYS directory. Please change the file extension from .VXD to .VX_ and restart Windows.

A buffer underrun can also occur if the bus has too higher pulse (instead of 66MHz, 75MHz etc.)
For SCSI CD burners in the BIOS of your SCSI controller, the option ‘maximum synchronous transfer’ should be set to 10 as for numerous SCSI controllers the space of time between two ‘bus retries’ is too long.
If you are using an Adaptec UW / U2W SCSI hostadapter, then you should download the newest drivers for your SCSI hostadapter: ftp://ftp.adaptec.com/pub/BBS/win95/7800w9x.exe
If the buffer underrun only occurs during the burning process but never during the simulation and if an NCR controller is being used and the Internet Explorer 5.0 beta is installed.
Please deinstall the internet Explorer 5.0 beta.

Please check if the Easy CD driver CDR4VSD.VXD is still there. Please remove it. On this, see drivers of other CD burner programs. Unfortunately this driver seems to cause more problems with newer Nero versions than it did with older versions.
If you are using an IDE burner and have got a harddisk connected to the same port, then please connect the burner separately to another port for test purposes (as the master), as some chip sets or their drivers cause problems if the burner and the harddisk are connected to the same port.
Example: TX Pro Chip set

If the buffer underrun stopped in the case of a direct copy straight after starting the burning process or the simulation stops, then it can be assumed that the CD-ROM drive stopped turning while writing the Lead-In.
On this, see Wake up the CD-ROM drive.

Please in Start->Settings->Control Panel->Device Manager for all devices Sync data transfer deactivate and disconnect .
If a buffer underrun occurs because you are reading in data from a JAZ drive, then you should deactivate the Spindown of the drive. Plesae read the following article on this:

Nero reads the data from CD Writer or CD-ROM drive at most with 4x instead of e.g. 20x/32x in the case of the Plextor CD-ROM drive.
If you are using Windows 95, then you should download the following update and install it:


If the Internet Explorer 4.0 (or higher) is installed, then please deactivate Active Desktop. If this doesn’t help, then please deinstall the Internet Explorer and have another go at burning.
If you are working in Windows NT, then in

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

at the DWORD entry


there should be a 0 as otherwise caching gets a higher priority than executing the programs.

A buffer underrun may also occur because in Windows the cache grows rapidly while burning. This is still not prevented by the up-to-date Nero version. Here you are recommended to download the program Cacheman in which the settings of the Windows Cache can be optimized for burning CDs.

If you operate the CD Writer at the parallel port
please change the protocol setting in the BIOS from SPP to EPP or ECP. Please note however that not every CD Writer supports both protocols but only one of the two.
Please close all printer monitor programs. Some printers even have to be disconnected so that no problems occur.

If EZ-SCSI is installed, the deinstall this software for test purposes as this software can also cause a lot of traffic through the SCSI/IDE bus.
Please also read through the Recommended hardware settings and check the Recommended software settings .
Please close all programs active in the background: Antivirus programs; programs which link into the file system, e.g.: ZipMagic; Scheduler; monitor programs for printers, network, fax, e-Mail;
If you computer is connected to a network, then you should disconnect all access to your printer for the duration of the burning process.
If you are using a Ricoh MP6200, then please update to firmware 2.40.
Please set the following entry in the registration to 1 or 0 and Nero restart:
HKEY_CURRENT_USER\Software\ahead\Nero - Burning Rom\Recorder\SCSICmdQueuing

If you are using an infra-red device, then please read the following article:
http://support.microsoft.com/support/kb/articles/q184/2/04.asp (How to Troubleshoot Issues with Infrared Devices)

If your are working in Windows 95, then please read the following article:
http://support.microsoft.com/support/kb/articles/q141/3/68.asp (Poor Performance from CD-ROM-Based Program)

If you newly create a Media Vision Fusion 16 soundcard and a CD-ROM drive is connected to this device, please read the following article:
http://support.microsoft.com/support/kb/articles/q136/5/55.asp (Delay Occurs Accessing Phillips CD-ROM Drive)

If you are using a 1x CD-ROM drive and are working in Windows 95, then please read the following article:
http://support.microsoft.com/support/kb/articles/q134/7/09.asp (Slow Performance with Single-Speed CD-ROM Drive)

If you have updated from Windows 95 to Windows 98, then you should read the following article:
http://support.microsoft.com/support/kb/articles/q189/0/92.asp (Problems with Hard Disk and CD-ROM Drive After Upgrading)


http://support.microsoft.com/support/kb/articles/q189/5/18.asp (Problems with Hard Disk Controller After Upgrading to Windows 98)

If you are using Windows 95, then you should download the following file, as the original IOS.VXD file can cause problems (extremely slow reading in)

Information on this:

http://support.microsoft.com/support/kb/articles/q149/5/64.asp (Poor Performance Reading Video CD in IDE CD-ROM Drive)


I used CloneCD. I haven’t burned with nero at 24x because I rarely use my drive for other than “backuping” cds so I don’t know if buffer underruns occur in nero. Hower transfer rate test at nero cd-speed went well. If it doesn’t happen in nero its probably because CloneCD uses 2352 bytes sectors and nero uses 2048 (if I remember correctly).

For some reason nero doesn’t let to do a simulated writing at 24x. When smart-burn box is selected simulate is greyed out. When I set speed to 24x after disabling smart-burn and checking simulation it automatically enables smart-burn and greyes out simulation. :confused:


What else do you have on your secondary ide port ?