Buffer underrun with plextor W2410A

vbimport

#1

I have some big problem with my Plextor W2410A. I get buffer underrun up to 50 times when i trie to burn a data cd. It seems that audio cd works better. I burned an audio cd with about 500 mb in about 2 min. without any buffer underrun. I returned my first burner and got a new one but with the same problem.

When I first got the burner it works well but after some time this problem came up. I'm not shure if the problem came when i started to use Win XP. The problem is the same wether I burn from the harddisk or ont he fly. My CD rom is an Plextor PX 40-TS.

My motherboard is Epox 7KXA. Could it be something withe the IDE drivers? I always update to the latest Via4in one.

Anybody have a good tips?


#2

Check to see if the ide channel your burner is connected to is in dma mode.

Originally posted by mogga
[B]I have some big problem with my Plextor W2410A. I get buffer underrun up to 50 times when i trie to burn a data cd. It seems that audio cd works better. I burned an audio cd with about 500 mb in about 2 min. without any buffer underrun. I returned my first burner and got a new one but with the same problem.

When I first got the burner it works well but after some time this problem came up. I’m not shure if the problem came when i started to use Win XP. The problem is the same wether I burn from the harddisk or ont he fly. My CD rom is an Plextor PX 40-TS.

My motherboard is Epox 7KXA. Could it be something withe the IDE drivers? I always update to the latest Via4in one.

Anybody have a good tips? [/B]


#3

It seems that you have right. It was in dma mode before but no it has gone to pio mode. I tried to set it to dma mode and restart the machine, but it’s still in pio mode. How to get it back to dma mode.


#4

Ensure that your BIOS are set to allow dma on your ide ports. The usual setting is AUTO. If your BIOS are correctly set, go to Control Panel/Administrative Tools/Computer Management and click on Device Manager. (You need Administrative privileges for this.) Double click each ide port and choose Advanced Settings. Choose DMA if available from the drop down box. Re-boot and check again to see if you’re ports are in udma mode. If not, ensuring that you’ve still got DMA if available selected, delete your ide ports from device manager and re-boot.

Originally posted by mogga
It seems that you have right. It was in dma mode before but no it has gone to pio mode. I tried to set it to dma mode and restart the machine, but it’s still in pio mode. How to get it back to dma mode.


#5

Thanks for the tips, but I saw another post that suggest that I should download the Via miniport driver. This seems to solve my problem. Will you say that your solution is a better choice?


#6

If applying the VIA4in1 drivers solved your problem, I’d say that was a good choice. If it didn’t, try deleting the ide channel and re-booting.

Originally posted by mogga
Thanks for the tips, but I saw another post that suggest that I should download the Via miniport driver. This seems to solve my problem. Will you say that your solution is a better choice?


#7

It was not the Via4in1, but Via busmaster PCI IDE utility, and it solved my problem, but I still have problem with reading some data cd both with my PX 40TS and my PX W2410A. It start reading at full speed but after 20 - 30% it spins down and it can take about 15 min to read the CD. This is also when I make image, both with Nero and Clone CD.


#8

I’m not sure which driver you installed. A quick look at the VIA site showed only the 4in1 and the separate components. I didn’t see a separate busmaster driver and I didn’t think one existed apart from the usual drivers.

Originally posted by mogga
It was not the Via4in1, but Via busmaster PCI IDE utility, and it solved my problem, but I still have problem with reading some data cd both with my PX 40TS and my PX W2410A. It start reading at full speed but after 20 - 30% it spins down and it can take about 15 min to read the CD. This is also when I make image, both with Nero and Clone CD.


#9

The name of the file is viapfd_104.zip.


#10

What ever u do don’t upgrade the Via Drivers in XP!!!

Get The Latency patch version 1.9d. form via or look on the Via Forums.

Trust me on this 1…been there done that and the Via upgrades knacked me OS…had to reinstall…and I did this 3 times:o

Bartman:cool:


#11

I have the VIA drivers installed on my XP Pro machine with no problems. There are a lot of ways to screw up all versions of WIndows and it’s not always clear what (or what combination) did it.

Originally posted by Bartman@MASH
[B]What ever u do don’t upgrade the Via Drivers in XP!!!

Get The Latency patch version 1.9d. form via or look on the Via Forums.

Trust me on this 1…been there done that and the Via upgrades knacked me OS…had to reinstall…and I did this 3 times:o

Bartman:cool: [/B]