Buffer Underrun with Burn-Proof ON!

BURN-PROOF FUNCTION!!! (PLEXTOOLS <-> NERO)
The first disc I tried to burn was a CD-DA compilation out of mp3 files from my HD. I used a Maxell CD-R 48XL disc. The recording was made with nero (5.5.10.45) at 4x. The Burn-Proof function’s check box in nero options was already checked, so of course i left it enabled. The recording had been INTERRUPTED and stopped, and cd destroyed, because of a BUFFER UNDERRUN ERROR!!!
I wrote to Plextor (Belgium and Korea) to inquire. In meanwhile i tried something else: I changed the nero’s option from Diskspace strategy to Tempfile strategy and tried again. Now, my (same) compilation was SUCCESSFULLY recorded and finished and plays fine in my home player (a very old one that is very sensitive and picky and doesn’t play CD-R/RWs if they are not perfect). It seems the problem was that 4x was “too high” speed for “on the fly” recording of mp3s (probably no time to make the decoding and writing at the same time). I can’t think of anything else. With Tempfile strategy (where nero makes the decoding from mp3 first and saves the info on image on hard disk and then burns from the image), there is enough time to burn it right and no buffer underrun occurs! (Notice that i have a slow system: enough 256MB RAM, but only an old Pentium MMX 166MHz).
Answer from Korea came, and informed me (from the logfile and systeminfo file I had sent) that “I HAD THE BURN-PROOF OPTION OFF” !!! But i am more than sure i had it on! I checked again with nero and found it was on, of course (default and not changed by me). Then I checked with PlexTools and found that it was OFF!
This is quite a mystery, eh?
WHAT DO YOU UNDERSTAND ??? That nero DOES NOT REALLY apply the BurnProof function if it is not enabled from the PlexTools itself!!! This is quite strange and odd !!! Isn’t it ?
Now i have turned the Burn-proof option on (in the PlexTools) and it’s always on.
But, how does nero recognize the function? Does it enable it by itself or waits for PlexTools to enable it? It should BE ENOUGH if it is enabled in nero’s interface! Shouldn’t these two affect onto other? Shouldn’t be linked? It seems they are not related - and it seems like nero’s enable does not work if the function is not enabled by PlexTools (as if PlexTools was THE MASTER of the function)!!!
How does this relation work (between Nero and PlexTools)?

HAS ANYONE EVER NOTICED A SIMILAR BEHAVIOUR with Burn-Proof between PlexTools and Nero ???

ALL OTHER CD-Rs since then, are burn perfectly! Even very cheap and no-name blanks. Even a 90+ minutes CD-R I tried!

Nero should enable BURN-Proof by default for the Plextor drive, but you can disable it in Nero. The same applies to the PlexTools software where you can also disable it. When BURN-Proof is disable in PlexTools it will also be disable in other applications such as Nero. When BURN-Proof is disabled in Nero is has no affect on PlexTools and it will only apply to Nero. So, I don’t think it’s a very big mystery. BURN-Proof was disabled in Nero for some reason. It could be you did it yourself by accident…? And a P166 is indeed not fast enough for ‘on-the-fly’ decoding of MP3 files but you already figured this out :wink:

i aggree basically to all you say… but please notice:

  1. i have made lots of 1:1 copies, ON THE FLY with both YAMAHA and PLEXTOR… and with both nero and Feurio! it went correcti (providing i won’t load the cpu with anything else, ok?)

Anyway, i know best strategy after all, is the tempfile strategy, and i’ve changed to it - for good from now on.

  1. I understand the relation of Burn-Proof enable/disable between the two programs. But I DID NOT DISABLE IT ON NERO!!! OF COURSE NOT! I HAD NOT THIS function for years, and i waited long to have it! How should i have disabled it? Of course it showed it was disabled, somehow! but HOW ???
    Normally enabling/disabling from both nero and plextools should affect the other accordingly! shouldn’t it? But they don’t! That IS a mystery! Why when disabling in nero should inform plextools (the drive itself) and when enabling should not! Isn’t it odd?

ah, something else! Speaking for ON-THE-FLY, for mp3s, till today i used always 1x ! (and 2x for wav files) so the cpu took it’s time to make its job! That’s why i didn’t need tempfile strategy till today. Now the min speed i had was 4x ! and that’s why i was cheated! but now, tempfile strategy on 4x from now on!

It should BE ENOUGH if it is enabled in nero’s interface!

Yes, but Nero is an unreliable buggy program. :stuck_out_tongue:
Check the log to see if it was enabled.

Speaking for ON-THE-FLY, for mp3s, till today i used always 1x ! (and 2x for wav files) so the cpu took it’s time to make its job! That’s why i didn’t need tempfile strategy till today. Now the min speed i had was 4x ! and that’s why i was cheated! but now, tempfile strategy on 4x from now on!

If you’re a registered Feurio user, then you can use the latest Feurio beta version, which supports your PlextorPX708.
In an old K6 computer I have, Feurio was twice faster than Nero5.5 when decoding MP3 to hard disk, which is what Nero does when Tempfile strategy is used, I guess.

Writing files to hard disk in Nero is poorly implemented. :rolleyes:
With Feurio, you have more possibilities of burning MP3 on the fly at 4x speed. And if the MP3s are corrupt, Feurio will warn you unlike Nero.

Compare and tell us :wink:

Have same problem , when burning CD from cue/bin with Nero 6.0.019 if CPU is too loaded the burns fails at start. Disk not even touched !
I could burn it again once I exited Dr.DivX (video encoding) .
I do not think it’s problem with Plextor but more with new Nero … :frowning:

Using Win98SE, and when resources get low, even when the record buffer in nero stays at 98%, I get the 'buffer underrun avoided 1 time - always 1 time!!).

I assume its when Nero is writing the beginning or end of the session - but the buffer near 100% means little in Nero’s world it seams.

Originally posted by icey
[B]Using Win98SE, and when resources get low, even when the record buffer in nero stays at 98%, I get the 'buffer underrun avoided 1 time - always 1 time!!).

I assume its when Nero is writing the beginning or end of the session - but the buffer near 100% means little in Nero’s world it seams. [/B]
Using which recorder? If you’re using a recorder that uses the Z-CLV recording method you may get one or more buffer underrun(s) because the drive switches recording speeds.

I always use DOA and constant speed with a Plextor 241040a. Considering I burn at x12 (sometimes x4) the speed change would not apply.

Good try though :slight_smile:

Originally posted by icey
Good try though :slight_smile:
Haha :bigsmile:

Well then I would guess the buffer underrun occurs when Nero/your drive is writing the lead-in area of the disc. When your drive is burning DAO mode it still switches recording speeds so that doesn’t make a difference.

Originally posted by minix
[B]Yes, but Nero is an unreliable buggy program. :stuck_out_tongue:
Check the log to see if it was enabled.

If you’re a registered Feurio user, then you can use the latest Feurio beta version, which supports your PlextorPX708.
In an old K6 computer I have, Feurio was twice faster than Nero5.5 when decoding MP3 to hard disk, which is what Nero does when Tempfile strategy is used, I guess.

Writing files to hard disk in Nero is poorly implemented. :rolleyes:
With Feurio, you have more possibilities of burning MP3 on the fly at 4x speed. And if the MP3s are corrupt, Feurio will warn you unlike Nero.

Compare and tell us :wink: [/B]

I am afraid i can’t compare and tell, because a. i can’t buy Feurio (i have nero and plextools, why should i buy a third program, even if it is so good?) - b. my results would not be reliable, since i have such a slow cpu (166MHz MMX Pentium) !!!
so, i will stick to the tempfile strategy and slow burning speeds!

Originally posted by Lord KiRon
Have same problem , when burning CD from cue/bin with Nero 6.0.019 if CPU is too loaded the burns fails at start. Disk not even touched !
I could burn it again once I exited Dr.DivX (video encoding) .
I do not think it’s problem with Plextor but more with new Nero … :frowning:

I don’t think it has to do with versions. It’s a normal buffer underrun behaviour in general (older versions do the same too)

Originally posted by icey
[B]Using Win98SE, and when resources get low, even when the record buffer in nero stays at 98%, I get the 'buffer underrun avoided 1 time - always 1 time!!).

I assume its when Nero is writing the beginning or end of the session - but the buffer near 100% means little in Nero’s world it seams. [/B]

I have not noticed a special sensitivity in start or finish of the session espacially! What i have noticed and aggree with you is that:
98% full buffer doesn’t mean a lot! What i mean is that if the percent falls under 90%, it keeps falling contineously and reaches 10%, 5% and then - buffer underrun occurs!
It never goes back to 98% again! So i think the number is somehow symbolic and not exact!
This i have noticed for years in both home and office and both with Nero (5.0, 5.5 and newer) and EasyCD Creator (3.5, 4, 5) and both with SONY older non-burn-proof recorder and Yamaha 8424 (non-burn-proof) recorder!
Only 95-99% area is safe! Lower than 90% concludes always in underrun! I have never seen it to grow up again after falling in e.g. 30% or 20%… (it stops for a moment, it “tries” to rise back high, but then it falls again till zero buffer - cd destroyed!!!)

After all these, i have concluded, that most safe way to have no buffer underruns destroyed cd’s is:

  1. Use of modern burn-proof recorder with the function ON.
  2. record in slow speeds or at least not in extra-high ones (not to the extreme).
  3. Tempfile use (strategy) especially when writing from mp3s to cd-da.
  4. Perhaps having the “extra” buffer (virtual buffer on disk) option manually set.

i suppose you know this option in Nero? (you can add extra buffer to your 2MB or 4MB buffer, as an extra swap file in your disk, that it is read as if it was the buffer in your recorder - and so you “extend” your small buffer).
In my old Yamaha i had 8MB buffer, in my new Plextor i have only 2MB ! I always believed buffer is essential. In the other hand you will tell “If a recorder is Burn-proof, it doesn’t need such a big 8MB buffer”! It sounds correct, but new SONY DVD-R is burn-proof and has also a 8MB buffer! Why not ?
I think 2MB is very few, anyway!

And the question is:
I have burned one or two cd’s and a buffer underrun occured, but with the burn-proof on, the cd was finished succesfully.
I don’t here any difference.
Do you know if a cd burned with no buffer underrun occurances is QUITE THE SAME as with the same compilation burn with some underrun occurances with burn-proof on of course???
ARE THEY QUITE THE SAME?
Is the point that the laser stops and starts again (after buffer filled again) NOT HEARABLE ??? AT ALL ???
Waiting for an answer for sure!!!
Should i consider " by burn-proof on " correct CDs the same perfect with those that were burned with no underrun occurance?

Well in theory a disc that was burned with burn-proof kicking in a few times should still be perfect and of the same quality as a normal burned disc. Some people will disagree and say that they’re not the same since the burn process was paused for some time causing a tiny gap in the burned data. However, in case of an audio CD you won’t be able to tell the difference and in case of data the CD will be perfectly readable.

well, this sounds reassuring! At least if you don’t hear the laser’s click (pop) it’s quite the same.
But still, you say THERE IS ALRIGHT a gap (stop and resume of the laser’s operation) and this is so tiny that it is inhearable!

Another similar phenomenon is the non Disc-at-once sessions, where the laser stops in between tracks (of an Audio-CD burning) and though the compilation was written succesfully w/o buffer underruns… the stop/resume in the start of the tracks kept being hearable (very clearly!).

You say, this is not the same thing? That was hearable then, but the buffer/underrun stop/resume is not ??? (much smaller gap) ?

Normally should be the same effect. Shouldn’t it?

When burn proof type activities kick in, the gap is less than 1 block of data. You never hear it with audio and it does not affect data. If you’re doing audio copy, you normally get a 2 second gap by default between audio tracks. Roxio (and I assume other apps) lets you reduce this to 0 seconds, but this still leaves a gap of 1/75 of a second (1 frame) between tracks. The only app that will give a true 0 second gap is an audio mastering software application.

Originally posted by bob11879
[B]Roxio (and I assume other apps) lets you reduce this to 0 seconds, but this still leaves a gap of 1/75 of a second (1 frame) between tracks.

No.
If you set the pauses to zero, you will get absolutely no gap if the size of the WAV is a multiple of a CD-DA sector (588 samples = 1/75 of a second), which is almost always.

If it’s not a multiple, then you might get up to 587 samples of silence filling the last sector.

The only app that will give a true 0 second gap is an audio mastering software application.

Feurio (it’s a regular burning program), Wavelab, Samplitude, Sequoia…

TAO leaves a defective sector.
http://www.feurio.com/English/faq/faq_vocable_trackatonce.shtml
BurnProof not, and shouldn’t affect quality.

hi guys! I’m back after 1,5 month! I had problems with my pc and moreover i was not receiving notifications for new posts in my mail (don’t know why, not only here but also on other forums/sites). Probably it was something with cookies, althoug i had not deleted my cookies. All my registrations to threads and forums had been cancelled. Now i’m entering all my old subscriptions and re-subscribe to each one of them, again!

Anyway, thank you for your explanations. I was worrying that a cd burned with burn broof incidents WAS NOT as perfect as the original or as one burn with no underruns. Now, i feel ok, as any differences are not effective and are inhearable! So i record freely and no worries (but still i have very few underruns and only in extreme situations and high speeds).

Thanks guys!