Buffer size settings

vbimport

#1

Is there any way to increase the size of the buffers in clone beyond the max setting, I am currently restricted to about 32 meg even though I have 768meg ram. The reason I want a larger buffer is because when writing to multiple recorders (check this thread) the larger you set the buffers the longer they obviously take to empty. When writing to 3 writers at the default buffer settings( about 8meg)the buffers empty almost immediately when the progress bar shows about 10% on the last writer started, when the buffer setting is set to max I get to about 50% before the buffers empty.That is a big gain for a small buffer increase of only 24meg.In discjuggler you can set the buffer upto 1 minute of write time which at 24X is about 200 megs I think?. If there is no work around perhaps Olli could change it in the next revision:)


#2

Originally posted by plimo
Is there any way to increase the size of the buffers in clone beyond the max setting, I am currently restricted to about 32 meg even though I have 768meg ram.
Have you looked in the registry? perhaps you could experiment by changing the value manually; however, Olli’s code might only account for a max of whatever, anyway…


#3

changed registery settings but it made no differance. But setting it to max (38meg) has improved writing, I am almost certain if I could increase it more it would cure this annoying problem???
P.S stopped using DJ because it keeps locking up my liteon 24103s it has happened in clone a couple of times as well???


#4

Originally posted by plimo
Is there any way to increase the size of the buffers in clone beyond the max setting, I am currently restricted to about 32 meg even though I have 768meg ram. The reason I want a larger buffer is because when writing to multiple recorders (check this thread ) the larger you set the buffers the longer they obviously take to empty. When writing to 3 writers at the default buffer settings( about 8meg)the buffers empty almost immediately when the progress bar shows about 10% on the last writer started, when the buffer setting is set to max I get to about 50% before the buffers empty.That is a big gain for a small buffer increase of only 24meg.In discjuggler you can set the buffer upto 1 minute of write time which at 24X is about 200 megs I think?. If there is no work around perhaps Olli could change it in the next revision:)

There is no workaround. However, allowing bigger buffer sizes shouldn’t be much work. :slight_smile:


#5

thanks very much appreciated…