Buffalo v8.40 - available target not found -?

vbimport

#1

In installed my DVR-109 into my PC Windows XP sp2 as a MASTER drive. Upon bootup, I had the little message “New hardware: Pioneer DVR-109” which then went away.

I ran the Buffalo v8.40 updater, it extracted and showed me the .exe file, which I ran. A little window (Japanese) came up, and I clicked Okay.

A terminal window opened showing “Firmware update utility ver 2.19”

Then “Available Target is not Found.”

Help!

Thanks.


#2

Use this one:
http://flashman.rpc1.org/Firmware/PIONEER/DVR-109/Buffalo/Buffalo109.840.zip


#3

Thanks, but. Still Target Not Found. !!

The drive does work. It reads CDs and DVDs okay.


#4

Have you tried this FW with DVRUpdate, giving both the route of the kernel AND FW files?
(In other words: Have you read the posts over the 8.40 thread?)
Pls, don’t open a new thread for every issue you experience, there’s great chance that others have experienced the seme already. Especially if you don’t read the how-to first. :rolleyes:


#5

Sorry, I have looked (and participated) but I cannot find what you suggest. I have tried both versions now, and I have only ever used FlashKit for Mac before…

If you could provide the direct links to me, at least this “Target Not Available” thread will be available to other poor sods like me…

UPDATE *** I think I have found the files & instructions. I will post them here if everything works…


#6

http://flashman.rpc1.org/Firmware/PIONEER/DVR-109/

DVRUpdate 0.9 is right in this directory. The Buffalo 8.40 FW (containing the kernel part too) is a zip file in the “Buffalo” directory. It contains both the kernel file (smaller file with extension of 840) and the firmware file (bigger file with extension of 840). Remove any media from the writer. Open DVRUpdate, select your burner, show the kernel and firmware files at the right place and flash it. Restart your PC. That’s all.


#7

Here’s what I had to do –

1) get the master file and extract the runtime .exe and data files:

http://flashman.rpc1.org/Firmware/PIONEER/DVR-109/Buffalo/Buffalo109.840.zip

2) get the DVRupdate .exe application

http://flashman.rpc1.org/Firmware/PIONEER/DVR-109/DVRupdate_v0.9.zip

3) Once you’ve extracted everything, put the “DVRupdate 0.9.exe” application into the “FW840” folder you got from step (1).

4) Run the “DVRupdate 0.9.exe” and Select the Small File “R9154009.840” as the Kernel, and the Large File “R9154109.840” as the Firmware.

5) The tray of the DVR-109 should open, and the DVRupdate should show some messages. Then you’re done.

If I made a mistake anywhere, PLEASE let me know.

William Donelson


#8

Yup! You did right :iagree: If your drive isn’t flashed with the Buffalo firmware yet then I dunno what you did wrong :stuck_out_tongue:


#9

Thanks to everyone for their exceptional patience and help!

I just burned a 2 Gb file onto a DVD+R in about 2.5 minutes = +/- 16 Mb/sec.

Excellent. I will try a DVD later.

Regards,
William Donelson


#10

I read in another thread that this is supposed to do the auto Booktype setting of +R media to DVD-Rom on the fly? Is this true? If I burn DVD-Video to +R media it will be automatic with no input from me and then should play on my set top player?


#11

Yes it will set both DVD+R and DVD+R DL to DVD-ROM booktype upon burning.

You may still encounter problem on a set top player, but if you do the only other option would be to test with -R media.

Thanks for taking the time to explain what you did, this may help having issue flashing their own unit, the hardest one is the first one :stuck_out_tongue:


#12

Yes, I made a dual layer Verbatim 8x DVD+R of a TV show DVD, and it plays beautifully in my 3 year-old Samsung combo DVD + VHS player.

I ripped it quickly from my Pioneer 106D with FW 1.08, and burned it on DataSafe DVD+R DL 2.4x with my Pioneer 109 with Buffalo 8.40. Perfect combination!

Note: The DL discs were sold to me by BigPockets.co.uk as “Datasafe Ritek” (£11.75 for 5), but I do not see any hint of Ritek on the discs or at the datasafe-media.com website…


#13

I’m good now.

I flashed according to the instructions above, and now my Panny 47S can read DVD+R burned video.

Why the hell this isnt enabled by default from the factory is beyond me.

Putting the disc back in and showing info via Nero states the book type is DVD-Video.

So now I know this 50 pack of DVD+Rs aren’t a waste.

Also found out that the Nero Ultra Edition I bought directly from them online includes the encoder for DVD-Video (MPEG-2) and it will transcode just about anything I throw at it now too.

I am having too much fun.

/Not drunk.

/honest.


#14

Such a Booktype doesn’t exist.


#15

DVD-Rom then, ugh, you know what I mean.


#16

Good that it works now.


#17

Remember that Pioneer is the developer of the -R format… :wink:
Remember that this Buffalo FW comes from Pioneer as well, and I don’t think it was just an accident. :wink:


#18

I recently purchased a Panasonic DVR-109BK drive for use in my PowerMac G5. After installing with no problems, it I decided to remove it and upgrade its firmware to version 1.40 using my Windows 98 machine. I downloaded the 1.40 firmware upgrade utility from Panasonic and when I ran it, I received the same error:

“Available target is not found”

BACKGROUND

I did a bit of reverse engineering on the upgrade utility and found that it uses the Adaptec SCSI layer (better known as ASPI) to discover and upgrade the drive. If the ASPI sub-system isn’t installed correctly (which happens very easily under Windows 98) the upgrade utility will not be able to find the Panasonic drive.

In a correctly functioning ASPI setup the Panasonic drive should appear as an ATAPI (IDE) Miniport SCSI adapter. In an incorrectly functioning system, the ATAPI Miniport SCSI adapters are disabled. In my case I had to specifically enable them to get the utility to work.

DETAILS

The Adaptec ASPI driver queries the following registry value at boot time to determine whether or not to enable Miniport devices.


HKEY_LOCAL_MACHINE
  System
    CurrentControlSet
       Services
          VxD
            APIX
              ExcludeMiniports

The normal contents of this value is a list of Miniport interfaces that should be EXCLUDED from the ASPI system. However, if the value is not present, or moreover, if the entire APIX parent key is missing, the driver defaults to disabling all ATAPI devices from being accessed through ASPI.

FIX

Again, this fix applies to Windows 98 ONLY. It is not valid for NT based Windows systems (XP/NT/Windows 2000).

  1. Download and install the latest ASPI layer (currently version 4.70) from Adaptec.

  2. Using regedit, ensure that the string value


HKEY_LOCAL_MACHINE
  System
    CurrentControlSet
       Services
          VxD
            APIX
              ExcludedMiniports

exists (create it if necessary).

  1. Ensure that the value is empty (""). Delete its contents, but not the value itself.

  2. Close regedit and reboot.

  3. Re-run the firmware update utility and it should find the drive.


#19

Ehm, surely a PIONEER drive.