BTC/Top G 8x dual format DVDRW no longer recognizing CDs

vbimport

#1

I have two BTC/Top G-built 8x dual format DVDRW drives.

The first one is an Emprex drive (1008-something) and the second is an IO Magic Dual Digital Storage 8x dual format DVDRW with 7-in-1 card reader. The IO Magic is a 1008IB.

Both drives initially was able to burn CDRs up to 40x. Now, both no longer burn or read CDs, regardless of whether they are audio, mp3, data, or software CDs. They still can read and write DVDs though.

Has anyone figured out why they are acting up? I’m assuming it’s something to do with my computer as I bought another IO Magic and that too did not read/write CDs.

As for the Emprex, it started burning DVDs real slow (the light would alternate red and green). Someone said it was in PIO, despite DMA being enabled. I took this out of my Compaq and put it in my mom’s P3 933mhz Gateway computer. She has an 12x DVD-ROM drive, and the Emprex replaced the original 8x CDRW drive that came with her computer.

The Emprex worked fine, reading/writing to CDs and DVDs. It no longer took 2-3 hours to burn a DVD, and the CDRW speeds were fast. Now (within a month of the IO Magic), the Emprex did the same thing as the IO Magic. It became useless as a CD drive.


#2

Does anyone know how to change the mode back to DMA so that it stays in DMA?

For some reason the Emprex is in PIO despite being on the DMA setting.

I dont’ know if it’s a BTC thing or a WinXP thing. I feel like going Office Space on some BTC drives…


#3

Chatted with IOMagic tech support (though I think it may be automated and not a real person I chatted with) and they had me download DVDInfoPro (don’t know why), then a new firmware (my IOMagic still doesn’t recognize CDs) then some Via 4 in 1 driver update or ASPI update or whatever it was. The drive still doesnt’ recognize CDs.

I’m about to chuck this out the window…


#4

Maybe read the part obout “2. PIO/MWDMA2/UDMA SETTINGS (BIOS & WINDOWS)” here

http://club.cdfreaks.com/showthread.php?t=79667

Or uninstall the IDE channel like done here.

http://club.cdfreaks.com/showthread.php?t=105248&highlight=dma

Many people complain that 4.71 of ASPI is buggy. Use ForceASPI to put on 4.60.

Read about here. http://club.cdfreaks.com/showthread.php?t=120014&highlight=aspi+4.6

Download here. http://www.clonecd.net/aspi.htm

I don’t have XP, so I’m guessing.

I had problems with Intel Application Accelerator, I would remove this if you have it installed.

A good general trouble shooting guide.
http://club.cdfreaks.com/showthread.php?s=&threadid=92320


#5

One other idea. Might be fixed in XP-SP2.

http://support.microsoft.com/default.aspx?scid=kb;en-us;817472