BTC IDE1008 major problem

vbimport

#1

Hi there!
Can I start by saying that I’m not a technical expert. I’ve got a major problem with this unit. I am getting a constant error which says that “the driver detected a controller error” on the drive.

The drive will not read any files or open anything CDs or DVDs. It is also hanging the system.

I am running Windows Xp Pro.

Any ideas?


#2

Would you call your physician on the phone and say nothing more than “I hurt, doc. Can you fix me?”

If we’re to diagnose the problem without making wild gueses, more info is necessary.

  • Have you tried booting from a DOS floppy? What happens?
  • How is the drive configured? Is a master or slave? Is it the only drive on an IDE channel or is it sharing with another device - what is that other device?
  • Using a 40-wire or 80-wire cable? Plugged into the end connector or the middle connector?
  • What are you doing when the error occurs?
  • Is this a new drive or one which has been working?
  • Any changes (ANY, even if not related) to system since it worked?
  • Is the drive connected to one of the two standard IDE controllers on your motherboard or to an additional controller either on the MoBo or an add-in card?
  • Have you run Nero’s Infotool & checked it’s ASPI test? It’ll also tell give you the master/slave and controller information.
  • What kind of processor? What motherboard chipset?
  • Are you using IDE drivers supplied by the motherboard mfr or by Microsoft as part of the OpSys? Have they been updated recently?
  • What ASPI are you running? What version? What does ASPICHK say?
  • Do you have any Packet-writing software installed (like Roxio’s Drag-to-Disc or Nero’s InCD?)?

#3

:bow:

Regards, Martin A


#4

InCD

Sorry but I’m not an expert…so I can’t necessarily do all the things I need to to check this but hopefully this will give you more information


#5

Well, I hope removal of InCD fixes it. It has a good chance. Much Roxio software is buggy and their packet software has been problematic since they released it years ago. Their new version (InCD) doesn’t seem to be a great improvement. You’ll be far better off without it.

Let us know how it works after removal of InCD. BTW, if I remember correctly, it doesn’t totally remove itself with the uninstall function. There used to be a procedure on the roxio.com web site for total removal. For one thing, the uninstall procedure left modules still being loaded at boot time.
d.


#6

Phew!
This has been a major tail chasing exercise, but I thought I should write back to you guys becaue you’ve been helpful.

I did indeed remove InCd as it was causing other problems. But I found that when I ran Windows in safemode by DVD was fully recognised, present, and correct. So I set about finding the differences between the settings in normal boot up and safemode for the drive.

It turns out that the IDE1008 wouldn’t work properly when set to Ultra DMA 4, it does however get recognised and work fine when set to PIO (although I know that’s slow and not right it’s a start!).

I had a look around on the web and it seems that many other people have this problem with DVDs under XP not just BTC drives either.

Has anyone got any further ideas? There are some suggestions about editing registries to force DMA to be accepted but based on past experience I’d like to try something less radical first.

Thanks for your help

Siobhan


#7

When I wrote the series of questionss early in this thread I was serious. It’s really difficult for anybody to be much help when we don’t know anything about your system. Nobody can promise that we’ll have the answer if you do provide the info, but it’d take monumental luck to isolate the problem without it.
d.


#8

hmm… for me, unless the drive is in ultra dma mode 4, all the burned dvd will have problems…