BTC DVD-ROM DOS Firmware help

vbimport

#1

recently updated firmware of my BTC BDV316E DVDROM using BTC’s liveupdate program, this didnt work out.
Contacted BTC helpdesk and advised to relash in DOS.
Unfortunatly I’m not an expert with DOS and having problems with BTC’s instructions and generally not getting very far. I understand the need to boot into DOS and then run their NTFSDOS disk which I have tried but cant get access to the firmware om my copied to harddisk.

Have copied BTC instructions below for info, I need help and detailed instructions in either 1. how to get to my C: drive to access the firmware or 2. is there a better way of doing this. Any advise appreciated. thanks :confused:

BTC instructions -
1.Please extract the enclosed DOS version firmware to a hard disk folder(such as c: emp).
2.Make a MS-DOS boot floppy disk.


How to make a MS-DOS floppy disk?
a.Insert a floppy disk into floppy drive.
b.Double click My Computer Icon on desktop.
c.Right click floppy A choose Format.
d.Choose Make a MS-DOS bootable disk.


3.Turn PC off.
4.Unplug drive (power and IDE cable)
5.Boots on pure DOS environment (use MS-DOS boot floppy disk)
6.Plug drive (power and IDE cable)
7.Change to firmware folder(such as c: emp)(If C is a NTFS file system please execute NTFSDOS enclosed)
8.Type f l4 (Drive connect as Secondary slave) or fl (Drive connect as Secondary master)
9.After flash complete please reboot, Windows will recognize drive then flash latest firmware by Liveupdate tool.


Warning!

1.DOS flash utility program can’t be used under DOS mode of Windows!

2.plug drive on IDE Secondary master or slave,not on IDE Primary master/slave

3.If your drive is an USB device, please return to dealer for the procedure.


#2

hi,

sometimes the drive letters are changed when you boot to DOS with a NTFS partition.
sometimes the c:\ is changed to D:\

also i used the boot disk from the site.
it has the NTFS driver included and a ide utility.
http://pioneerdvd.rpc1.org/Firmware_FAQ.html


#3

thanks for info, main problems I’m having is actually getting to
and running the firmware on the harddrive after using the NTFSDOS disk (you are right it is shown as D:\ Drive). Link very helpful though. Regards.


#4

have you tried using MTKFlash?
http://forum.rpc1.org/dl_firmware.php?category=1&manufactor=7
you can try the original binfirmware 0049 using MTKflash then upgrade to the latest.
There is also a firmware flashing help forum.


#5

tried the MTKflash, think I must have gone wrong somewhere.
Put the MTKflash 1.80 and BTC firmware 0049 on a floppy and ran Upgrade.Bat. as stated (after booting to DOS) but it couldnt find the firmware? Any advises on this appreciated.


#6

The command for dos-flashing depends on the location of the drive in your system and the filetype of the fw file

command for .bin fw files: MTKFLASH 1 W /B /M name-of-the-firmware.bin
command for .hex fw files: MTKFLASH 1 W /M name-of-the-firmware.hex

replace the bold written number by the number which fits for the location of your drive

[ul]
[li] 1 = primary master
[/li][li] 2 = primary slave
[/li][li] 3 = secondary master
[/li][li] 4 = secondary slave
[/li][/ul]


#7

thanks for reply, I have two bin.files downloaded from the firmware page Bide00.bin and Bide01.bin. Do you know which one best to use. thanks


#8

You need to use both files; you will need to run two different flashes, using these commands instead:

mtkflash X w /a0 /b Bide00.bin
mtkflash X w /a1 /b Bide01.bin

Replace the “X” with the drive location (see H3rB3i’s post)

(The /m switch is used only when all the banks of the firmware are rolled up into one file. If the banks of the firmware are split into separate files as is the case with all BTC DVD-ROM firmwares, then you will need to manually flash each individual bank separately using /a0, /a1, etc.)


#9

many thanks for all help given on this one. regards