BTC DRW1004IM dead after firmware update

… and now i’ve thrown this piece of crap away. (seriously, believe me … garbage). Well, the original btc flash stuff never worked (some others replied the problem to me), so i used mtkflash and tried the version 043, the flashing procedure went cool, no error messages … but when i restarted my computer, the drive was dead, really dead. No light, no noise, nothing … so i tried to flash the 040 and the 042 version … the drive is still dead.

Anyway, i now went to store to buy a benq …

cu

Mortician

Did you use mtkflash version 1.80? Previous versions do not work with this drive. I successfully flashed this drive with mtkflash before, after flashing with the windows flasher has failed.

For all you flashers out there, please take note.

Whenever a flash goes bad (which doesn’t happen a lot, maybe once in a million updates), you can usually revive it by doing the following:

(works ONLY in a DOS environment with a DOS flash update !)

  1. Get a DOS version of the flash update (for BTC drives, please contact support@btceurope.nl to get it);
  2. Connect a working drive to the system while the system starts (the BIOS will report that there is a drive present);
  3. Then after startup, remove the power and datacable from the working drive WHILE THE SYSTEM IS ON (!) and replace it with the “dead” drive;
  4. Do the (DOS) flash update as usual.

Marco
BTC Europe Support

Sorry Mr. BTC,

enough is enough…

i have bought the BTC -no words for it- four days ago.

reading the media compatibility list, before buying it.

investing 129 € in the BTC DRW 1004IM, F/W 040, Manufactured

10/03,

the package includes Nero 5.5.10.33,

(and no handbook for the hardware ---- why is it a problem??

you need no handbook for it)…

i have also spend 25 € in Ritek04 - Ritek DVD (-) 4x

as listed by BTC (what a surprise).

and now its getting started…

  • installation of the recorder (plug and play +1+1+1)

  • deinstallation of Nero 5.5.10.20

(now there is no other burning software left on the pc)

  • installation of Nero 5.5.10.33 (from the BTC orig. pack)

  • burn my first 4.2 GB on DVD + RW (the orig. from the pack)

  • thank you Mr. BTC …(what a feeling)

  • looking twice and controlling the work…(and as promised

he/she is doing it on 2.4x with no noise…realy no noise…+++++)

  • lets burn the first DVD -r (Data-DVD, mixed Files, ca. 3.3 GB)

  • but what went wrong?..on the Ritek DVD (-) 4x -

“Writing ERROR”

  • Why is it in the BTC-List???..check my system…

  • Win ME (Buhhhh)… i love it … DMA - ok, ASPI Driver - ok,

DirectX8.1, no other burn-software, DVD from the BTC-list…

  • ok, the list was updated…my first thought…cauld be the F/W…

  • first try some CDs…VCD… SVCD…no problem…(min.16x)

  • lets call and nerve some friends, look for other DVDs

  • have a look at the internet…80 % bad news…

(its normal, people always talk about their problems)

  • so read this Mr. BTC…

Notice - i am on vacation…

over the week it was a lot of work to find a suitable DVD -r,

i think it must be suitable - not compatible…

i have tried some (3 are enough) PRINCO 4x from a friend (BTC-Listed) - ERROR

burn 1x, 2x, 4x - ERROR

the friend told me, on his Toshiba ?? 2x are working

fine…the same that doesnt work on the BTC.

have also tried:

MCC “DVD-R For General” (Verbatim 1-4x) - ERROR

MCC “Verbatim Data Life Plus 4x” … just a try - ERROR

EMTEC “DVD-R For General 4x” - ERROR

EMTEC “DVD-R For General 2x” (old ones) - ERROR

testing one, two: Ritek 03 (Octron/Lidl), TDK (cant remember), Sony (?? 2-4x)

Speer 1-2x … all by loan and in origanal package,

plus a Maxell 1-4x

  • look at the BTC-List again

  • this time changing to +r

i need the recorder just for DATA-SAVING (1 day/Week)

  • MCC “DVD+R Verbatim” 1-4x - ERROR

“fuc…its in the list”


Just a clue…

is there a difference between “DVD+R Verbetin” (as listed) and “DVD+R Verbatim”

(US, Europe, Japan, China, Taiwan…???) dont know…


remember: the original pack includes a CD +RW from Ricoh (named RIDATA),

but i could not find them in germany…sorry.

– oops…thanks olli … Ricoh is Sony…

olli brings me a “SONY DVD +RW 4.7GB” cost 3.89 €/per 1

  • ERROR

(normally you can do everything with it, - that must be a dream)

“with a good recorder you can do everything, you need the right medium”

Yeeessss…

After three days of testing, reading FAQs and watching different forums

  • none of the tested DVDs -r/+r work…

(its normal…comming from DORTMUND/Germany, a small town with 660000 residents,

nothing works, the shops are selling the wrong media)

  • so i decide to update the firmware from 040 to 045…

  • and i still remember the words of Marco BTC…


Marco BTC Marco BTC Marco BTC Marco BTC Marco BTC Marco BTC Marco BTC Marco BTC

Whenever a flash goes bad

(which doesn’t happen a lot, maybe once in a million updates),

you can usually revive it by doing the following:

Marco BTC Marco BTC Marco BTC Marco BTC Marco BTC Marco BTC Marco BTC Marco BTC


Thanks Marco,

i lick my own balls,

after, you have promised it, the FW-Update has flashed/crashed my BTC…

No CD, CDRW, DVD, DVDRW…

No more FAQ, readme, compatibility list, no testing, no more searching,

just going back to the shop, be friendly and asking for the manager,

speaking loud and clear…and dont believe in guys like you.

i am the second of a million…

must be a lucky guy

sorry marco…

the flash was a real flash…

help us all - close the hole thread and stay in your own world…

you are million miles away from the user

greetz from

Hellimann/Dortmund

the problem is the user - or microsoft

sorry btc mike,

another thread, the same lie…

after the last 4 days, i wont believe in anyone…

you have posted something like this…

Brand name: Verbatim
Media type: DVD-R
MID code: TYG01
Firmware used: V0045
Burn software used: Nero 5.5.10.33
Write contents: DVD movie (The Matrix)
Number of media tried: 3 pcs.
Burn result: 3X OK
Verification result: 3X OK
Verification program: CD Speed 2.10

where did you get the hardware from (the working driver)?

JAP/US/TW/F/D/GB/RUS…etc.

whats your OS?

why did the (your) firmware 0045 make no problems.

sorry

i have to change

need a write-all on every-medium

not a read-all on nothing

cu hellimann

Hellimann,

Please send me an e-mail at support@btceurope.nl and send the drive over to me.

Marco
BTC Europe Support

Furthermore, I never lie, and I don’t think I’m million miles away from the enduser.

Marco
BTC Europe Support