BTC 1008 Emprex Branded

vbimport

#1

Hi, i am new here! i recently bought an emprex branded BTC1008. i have used it for a couple of weeks with dvd+rw media with no problems whatsoever. recently i decided i wanted to burn a couple of stuff to dvd-r so i went out and bought 25 infiniti whitetop dvd-r 4x at 12£.

the 1008 writes to these fine with no errors or anything. but when i try to read the disc afterwards it is extremely slow reading. (dma 5 is enabled i confirm this) also it is very slow reading in my mums pc which has a standrad dvd drive also has dma mode 3 enabled on this one. it fails to read. i have re burnt the dvd 5 times now and still with the same results.

then i decided to upgrade the firmware from 0057 (i think) what it was to the lastest firmware from BTC’s website, but with no avail. still does the same thing.

media incompatibility you reckon? whats a good media to use with this recorder.

cheers
Al.


#2

i have the same drive as you with similar problems. i bought dvd-rs and, like you, they write perfectly but my standalone dvd player didnt like them much. also when i put a blank one in the drive, the computer responds slowly to them?! weird huh. haven`t got to the bottom of it yet, however, i purchased some “bulkpaq dvd+r” and have been 100% successful on all drives… just something to think about… cheers.


#3

bought some datawrite red topped v3 dvd-r discs today! these will onyl write at 2x in my btc1008 (emprex branded) its burning now, so i will show u the results, this disc is supposed to be 4x and even burn at 8x sometimes, how come its not allowing me to burn at 4x or 8x, maybee not fully compatible!

i dont care anyway if it read back fast and sweet after a 2x burn then i can put up with it untill a supported firmware is released!

cheers
Al.

p.s watch this space will post again with 2x burn results!


#4

completed burn at 2x using nero 6, reads perfect! here are the nero cd/dvd speed results in the attachment.



#5

Here’s all I know about my Emprex 1008 8x DVD Writer:

COST/BENEFIT
If you are like me, the fact that it burns at 4x all the time, and will burn 8x DVDs without coasters whenever you have a bunch of DVDs to burn, and burns CDs at 40x always, you’ll think it’s a great drive. Had it for a year.

MEDIA:
The cheapass (but good enough for more expensive drives) GC “8x” media available at Fry’s Electronics only writes at 4x on this drive, because the firmware doesn’t recognize the code on the media. The latest firmware is version 0159, and it’s the one with this problem. However, Emprex is a rebranded BTC drive, and you may be able to use firmware for that drive. Risky. Anyway, it has burned every other regular brand name 8x media at 8x for me, so I don’t buy the GC 8x media when I want to burn at 8x.

DRIVE SPEED:
This drive supports UDMA 66, but Windows XP SP2 resets it to PIO mode 4 if the drive reports 2 or more hardware errors (which happened to me). When Windows sets it to PIO mode, it’s pretty much a permanent change unaffected by reboot. Causes drive to write very slow. You have to change the registry to get it back.

To restore UDMA 66 after xp/sp2 has changed it to PIO 4, you can reset it by going into the registry (Start/Run/Regedit), find
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\4D36E96A-E325-11CE-BFC1-08002BE10318. There will be many sub keys ( 0000, 0001… etc.) Find the subkey with “DriverDesc” set to the IDE channel your Emprex drive is on (either “Primary IDE Channel” or “Secondary IDE Channel” and delete both keys (it won’t hurt the other drive, it will just be redetected): MasterIdDataCheckSum and SlaveIdDataCheckSum, and then Reboot. This will force redetection.

MASTER/SLAVE:
Yeah, I know - I’m stupid. I had two CD/DVD drives on one cable and I had them both set to slave - it kinda worked, intermittently… so there’s at least one person stupid enough to forget to check the master/slave status ot his drives.

CABLES:
The newer EIDE cables with 80 conductors on the 40 pin cables is necessary to get UDMA 66, and therefore 8x burn speed. Crappy 40 conductor cables will not work. Also, if your cables are bent funny, sometimes that will cause occassional hardware errors. I replaced my crimped, twisted, folded up 80 conductor cable with a brand new “air flow” type cable and it stopped changing from UDMA to PIO mode all the time. Buy cable select cables with the grey, black and blue ends, set each drive to “CS” and you can save on brain power.

That’s all I know. :smiley:


#6

Here’s a little more I know :slight_smile:

Its not really the best drive out there, I also own a Pioneer DVR-108 and a NEC 35300AG, so I have done comparisons. Its just not the best burner out there.

It is however, a very good reader and CD burner. Case in point, I can get better scans with DVDInfo Pro on the exact same disc, on this drive than with the Pioneer, which just started being supported in DVDInfo Pro.

It also supports PIE/PIF error checking so you can use it with DVDInfo to do this kind of testing. ( I man be wrong, it might only support PIE, but it seems to be useful for this testing.)

There is no “risk” of using BTC firmware and Live Update, or at least that’s what I’ve been doing. It IS a BTC drive rebadged with the Emprex case.

So, I use it in like my 3rd machine as a ripper, tester, and CD Burner, but rarely to burn DVD-R’s or DVD+R’s.

I may not have given it a totally fair shake, having the other two drives that I can depend on. There may actually be some media that has a good write strategy, that will work fine. I have not had the best of luck with the media I have tried, Ritek G04 and 05, Prodisc F01, and the lowly AN31’s. Probably the burns with TYG02’s I’ve done are acceptable, but I don’t risk it anymore.

Hope that helps