BTC 1004IM unable to read DVD (and write CD) anymore

I bought the BTC 1004IM drive Saturday, and I am now very frustrated and I would have turned it back this morning if not reading all the good work Marco is doing on this forum. This is my story (i have seen many of similar stories on this and other Italian forum and hope somebody can help).

  1. installed the drive. My XP pro with AMD 1800+ recognized it immediately. The Drive was able to play DVD movie and write CD with UDF format (just a first test)
  2. I then used the bundle software Powerproducer to burn a DVD -R (Princo 4XB140023892) directly from a DV stream from my camera. An error writing occured immediately an my first Princo was gone.
  3. I then tried my second Princo disk. I tried to create a data DVD with 4.2 GB of photos. (using the Nero SW inthe bundle) Also this one failed immediately.
  4. I then used, the DVD +RW sample disk in the bundle (from RiData). Again the DVD data burning failed.
  5. I tried to cancell the DVD+RW disc and the drive was not recgnizing it anymore.
  6. At this point the drive stopped working. It was not able to read DVD or write CD anymore. It doesn’t recongize the media any media and the system ask to isert e disk. it is only able to read CD.
  7. I tried several reboot, unistall the drive and let XP recognize it again. I tried uninstalling Nero and Powerproducer and reinstalling them again. Nothing to do.
  8. Without reading any fourm I unmounted the drive from my computer and inserted again my old Plextor CR Writer. The result is that NOW ALSO THE OLD CD WRITER DOESN’T RECOGNIZE CD-R and cannot burn CD any more.

I thought it was a SW error but after reading several thread I couldn’t find the solution and instead foiunf several disatisfied users.

I need an affordable DVD writer, I spent all my Sunday trying to figure out problems and more than 4 hours on forums. I cannot waste hours of my life with that so I will probably turn it back but I really need at least my old CD writer back to work.

Any thought ???

hi,

When i bought my DRW 1004i, after few burnig test my drive was not able to read or write anymore DVDs, then i’ve flash a new firmware and everything goes right again. Do you try to upgrde the firmware?

Bye