BSOD-Sim City 4

vbimport

#1

Have a custom-built computer with Epox motherboard, AMD 4000+ processor, ATI X1300, and 2GB RAM.

I recently installed Sim City 4 Deluxe Edition. Whenever I try to run the game it will work fine, but when I do something that requires more memory(like bumping up the game play speed), it crashes and gives me all sorts of ‘stop error screens.’ Sometimes it also crashes on shut down.

These are some of the screens that I got:
IRQL_NOT_LESS_OR_EQUAL
0x00000019 (0xFF53FF01, 0x00000002, 0x00000000, 0x80532D07)

Bad_Pool_Header
0x00000019 (0x00000020, 0x88A18C60, 0x88a18D28, 0x0A190009)

Page_Fault_In_Nonpaged_Area
0x00000050 (0xFFFFFFFC, 0x00000000, 0x805AB6F3, 0x00000000)

IRQL_NOT_LESS_OR_EQUAL
0x0000000A (0xFFFFFFFC, 0x000000FF, 0x00000000, 0x80540D1F)

‘Didn’t write down the header for this one’
0x0000008E (0xC0000005, 0x805B06CD, 0xA71CDAE8, 0x00000000)

They suggest stopping BIOS shadowing and cache. I think I disabled cache, but my BIOS didn’t have an option for (video?) shadowing.

Much help is much appreciated. :bow:


#2

Went through EA’s customer support. They told me to reinstall the game, manually reinstall the game, screw with a whole bunch of system settings(after which I had to do a system restore), and then download their fixer software(which forced me to again do a system restore).

I am feeling at my wit’s end. Help. Please. Soon. Anything.


#3

Have you tried to update ATI drivers? On the log you posted is shown that you have version 6 of drivers,

Driver Version: 6.14.0010.6677 (English)

but on ATI website latest available driver is version 7.3.


#4

Update the game with the latest patch.
Update your ATi card with the latest drivers.
Update your sound card with the latest drivers.
Update windows with the latest patches.

Are you overclocking anything in your system?
What O/S are you running?

It’s strange that the game runs then crashes


#5

I updated/reinstalled the drivers for my: sound card, video card, monitor, and windows.
In the readme file, I ran across a mention that Sim City 4 didn’t like full screen anti-aliasing. So, I disabled that.
Then, the EA people told me that they thought something was preventing me from running DirectX. They said it might be a process called ‘dxlock’, but I knew that the program running it was legitimate. I uninstalled the program anyway.
When I next booted up Sim City, it worked great, with all of the bugs apparently fixed, but when I quit, it gave me a BSOD. I’m sorry, but I forgot to get the codes from it. I know it said "Bad Pool Header."
Now, when I try and launch SC, it goes black, like it is about to play the first intro, but instead, it shuts down back to the desktop, and doesn’t give me any error messages.

Any ideas? I trust you guys more than the 7 different technical support people who have handled my problem.

P.S.>I am running Windows XP Home Edition, and had Ntune accidentally over clocking my cpu a little. I turned that off though.


#6

IRQL_NOT_LESS_OR_EQUAL error is usually associated with bad video card drivers or a bad memory module. Since you already used updated drivers perhaps you could try running memtestx86 for a day or so to check if your memory modules are correct.