Brand new Pioneer DVR-109 stuck in Multi-word DMA mode 2

vbimport

#1

Hello,

Well, I followed all the advices i found here and on other CD/DVD forums but my brand new Pioneer DVR-109 is stuck in Multi-word DMA mode 2 (only in Windows though, because the BIOS recognize the drive as ATA-66!)

So, to resume:

  • I flashed the firmware to 1.40
  • I have a 80 pin cable (I even swapped for another and same thing). Even tried a standard cable: BIOS says “ATA-33” but windows stuck again at Multi-Word!
  • I deleted several times the DVD and the IDE channel in device manager
  • I tried some registry tricks documented on this forum
  • Jumper on the drive is set correctly (master). I even tried in Cable select but no change
  • I installed the latest 4-in-1 drivers for my chipset (Via KT133A).
  • The drive is alone on the cable (no slave device)
  • I have the latest BIOS for my mainboard
  • I know that’ not a good thing but I tried the drive on my integrated Promise controller to look for a difference of speed. The results in Nero CDCHECK (reading a DVD-R) were about the same on Promise or on standard IDE. Each time, the burst speed was around 13 mb/s… Ouch!

The guy where I bought it says to me on the phone: “You have an old chipset so it is surely a compatibility problem. Anyway, with that chipset, you won’t be able to go more than 8x”. Why then my HDD (on IDE1) is set to UDMA5 in the BIOS and in Windows and transferring at 45mb/s ?

I don’t know what to think or what to do now. The thing that bug me the most is the fact that the BIOS set the drive correctly but Windows refuses to do the same.

Ah, I also tried the VIA Miniport drivers (to replace the Microsoft generic ones) and I have the choice to update the drive in UDMA66 with this driver but applying the changes and rebooting does nothing again!

So, any solutions other than returning the drive and picking one from a different brand…

LATEST NEWS:

Ok. I also tried to change the MasterTimingDevideMode to UDMA66 (8010) in the registry. It shows UDMA4 when I go in the device manager but when I reboot, it is back to Multi-word dma 2 again. There’s nothing about it in the event log too.

AND AGAIN (after multiple reboots):

Arghh!

I did a clean install of Windows and upon the final reboot, I checked the device manager and… multi-word dma mode 2. Just WinXP with generic drivers and nothing else so there are two possibilities:

  • Compatibility problems with my chipset or my mainboard
  • Defective DVD unit: I called at the store where I bought it and they told me to bring them the drive and they will test it on one of their comp to see if the behavior remain the same. If it is ok on their machine, I guess I’ll have to keep the drive and live with it… I understand that there will be a possibility to exchange the Pioneer only if it is defective…

My machine:

MSI K7T Turbo LE (Via KT133a chipset)
Athlon XP 1600+


#2

I had the same problem with the MSI K7T Turbo. This chipset had a couple of bugs. All atapi drives (cd/dvd drives) will not exceed multi-word DMA 2 on the Secondary IDE. HD’s don’t have this problem. You can work around this problem by putting your atapi’s on your Primary IDE and your HD’s on the secondary. All devices will now be in real DMA mode. Worked great with my mainboard.

Hope this will solve the problem.


#3

had the same problem with the MSI K7T Turbo. This chipset had a couple of bugs. All atapi drives (cd/dvd drives) will not exceed multi-word DMA 2 on the Secondary IDE.

Thanks. Before I read this post, I tried another thing (just to be sure that the IDE is not kaputt): I put my second hard disk (normally on Promise controller) on the second IDE channel and it is set as UDMA5 in the BIOS and in Windows.

Now, I’ll try your suggestion but it will be kind of problematic I think: I have a dual-boot with Boot Magic enabled and I’m afraid the OS drive won’t boot at all if I plug it on the second channel. We’ll see and I’ll report back…


#4

UPDATE: I got it!!! Thanks again. Pioneer now on Primary IDE as master with a CD-ROM drive slave. Reading UDMA4 in Windows now…

HDD1 alone on Secondary IDE and running at UDMA5 like it is supposed to be.

One little annoying thing though: I had a throughput (max burst rate if you prefer) of around 80-81 mb/s when testing my Maxtor HD on Primary IDE. Now, on Secondary IDE, I get 74-75 mb/s. This is with HDTach and HDTune. I verified that it wasn’t the cables by swapping them and I even retested the HDD on Primary IDE.

Definitely a loss of bandwidth on Secondary IDE… Strange old motherboard…


#5

Hi Patrice :slight_smile:

Hopefully, MSI got their act together with the KT266, that’s the one I plugged my own 109 to, no problem :cool:

Actually many mainboards with the VIA KT133 chipset were plagued by all sorts of strange problems (worst being the ABIT ones).
I’ve had an Asus A7V133 which gave me awful headaches.
But that’s an old story now… (funny, I was a mod at Viahardware.com at that time)

Cheers :slight_smile:

'Wiz
Je suis qui moi?


#6

Well, I finally put the Pioneer as slave on IDE 1. My hard disk is master on the same IDE.

I understand that there’s a risk of slowdown when burning data coming from the HD but I prefer that compared to a loss of bandwidth…