Booting Win2k from a ZIP

vbimport

#1

Hello folks!
For some unknown reason I cannot boot from my SCSI cdroms (PX32TS / PXW1210S) using my Advansys controller. :frowning:
Being that I'll need to reinstall win2k professional, and I'm not going to fight with 4 floppies, I was wondering IF and HOW can I boot from my internal ATAPI ZIP?
My mobo supports this feature, but I really cannot figure out how to create a bootable / install zip - it should contain the scsi drivers, so I can eventually insert my win2k cdrom and start the setup from there - or am I just dreaming :slight_smile:
I hope it can be done!

Thanks in advance!


#2

bump


#3

I have no idea how you could make a boot-zipdisk. But maybe I can help you out.

Advansys scsi-adapters are not supported in Win2000. But this is what you can try:
depending on your bios:
“boot from scsi”
or
“boot from cdrom”
(try both; my scsi-cdrom only boots if “boot from scsi” is selected, but on another system I had to select “boot from cdrom” for a scsi-cdrom.)

If you get in Win2k setup, you have to press F6 to add drivers for your Advansys-adapter. (asuming you have Win2k drivers on some disk)

It worked with my Advansys scsi-firewire card.

good luck!


#4

What do you mean by “not supported”?
In the device manager is listed correctly and works like a charm :slight_smile:
I’ve no hard disks, just a CD and a CDR drive attached.
Problem is, there are many a setting in the scsi bios that maybe interfere with the boot-from-cd process, like (i think) the “removable drive support”, and so on… unfortunately I don’t know much about them, and all I can do is trying all the possible combinations!
When I try to boot from cd, enabling the “cd bootability” option in the scsi bios, and “boot from cdrom” in the motherboard bios, I end up to a message saying (more or less):

Choose device for booting:
0 - Default entry

I press 0 and the PC simply go ahead booting from HD…
I think I should see the CD drives list instead of “default entry”, right?
I tried both with “boot from CDROM” and “boot from SCSI” option in the mobo bios, but it seems that I need the first one. The second option searches for hard disks.


#5

“not supported” in the way that Win2k does not have the proper drivers by itself (at least my Advansys card isn’t recognized without a driver disk)

When the scsi-bios asks (during boot) to choose a bootdevice, you can try to enter the scsi-ID for your CDROM. (you can find that ID by listing the scsi-devices in your scsi-bios).

0 - Default entry is ment for Harddisks (they usually have ID 0 or ID 1). And your scsi-adapter checks this ID’s first. So you might as well give your CDROM ID 0, since you don’t have scsi-harddisks. (you have to remove the jumpers from your CDROM to set the ID to zero)


#6

Sorry for the delay (I’m building a PC to use as a DVD player and I’m fighting against video connectors and macrovision :Z )!

Well, my controller didn’t need any drivers, win2k has its own and they work just fine :slight_smile:

Now I wrote down the whole thing it displays when I try to boot from cd:

A bootable CD was detected:

0 - Default Entry

When booting a CD-ROM image, your drive letters may change.
Select image number, or press escape for normal boot:

At this point I can only press 0 or ESC.
I asked a friend of mine who owns an Adaptec 2940UW and when he boots from cd he has to choose “boot from floppy” in the motherboard bios, because the 2940 sets the cd-rom drive letter to A:.
Mmmm… I wonder if this also applies to the Advansys, “your drive letters may change”…


#7

Hello,
Assuming your scsi card supports booting from a cd;

The bios settings on your motherboard should be set to “Boot from SCSI” Make sure that “Include in BIOS Scan” is enabled in your SCSI controller for the ID that is your CD Rom. Do NOT set the boot device ID to your cd rom.

I just realized you dont have a Harddrive installed on this controller more than likely you do not have your scsi bios enabled.
Make sure your scsi bios is enabled as well as int 13… You need these to boot from a device on the scsi card

If you still can’t boot from cd rom and you have a fat partirion, just make a win 98 bootdisk that loads your SCSI and cd rom drivers… make sure smartdrive and Xcopy.exe and Xcopy.mod is on there too, (you can find these in the “Windows\Command” folder.

Boot up with the bootdisk you just made and use the Xcopy command with -e switch to copy the i386 folder and all its sub-directories to your harddrive.

Load smartdrive

Run the setup, (winnt.exe), from the i386 folder now on your harddrive.


#8

Whoa, your reply sheds some new light on the matter :slight_smile:

Make sure that “Include in BIOS Scan” is enabled in your SCSI controller for the ID that is your CD Rom

My controller has a section where I can choose, for each target ID, whether if it will be controlled by the SCSI bios or not. I think this is what you mean, right? I have all the ID’s checked (although I have only two units: CD on ID3 and CDR on ID4).

Make sure your scsi bios is enabled as well as int 13… You need these to boot from a device on the scsi card

Uhm… how can I check if the scsi bios is enabled? And… for what I can remember the INT 13 had something to do with the floppy drive; would you please explain a bit more? :confused:

There are some options in the SCSI bios configuration that are somewhat unknown to me… or better, I don’t know if they can interfere with the ability to boot from cd; for example the “Removable drive support” toggle… it says something like “determines if SCSI bios should control removable devices”.
CDROMs are considered removable devices like ZIP’s or JAZ’s and such?

Thank you very much!


#9

Hello,

[quote]
My controller has a section where I can choose, for each target ID, whether if it will be controlled by the SCSI bios or not. I think this is what you mean, right?

Yes. Make sure that both cd roms are set for this.

  1. SCSI BIOS enabled
    2 .Include in Bios scan for each cd rom you want to boot from
    3.The setting to allow to boot from CD Rom

Also do not treat the cd roms (or even a scsi zip) as removable devices (in the scsi card bios) as this setting is meant for hot swappable devices.

What model advansys card do you have?
What is the scsi ID of each cdrom?

I am assuming that the last device on this chain (cable) is terminated.

Could you go through the settings of your card and let me know what options you have and which ones are enabled.

The BIOS INT13 option is NOT necesarry for CDROMS my mistake.

The INT13 option forces the use of the disk I/O routines that process disk read/write commands which are issued by the operating system. It only handles hard disks, removable hard disks and magneto optical devices. Other types of devices are excluded from BIOS INT13 option regardless of this option’s setting. Devices that are not handled by BIOS INT13 should be handled by either a device driver, (e.g. CDROM, WORM) or directly from the application software (such as Tape). Devices that are included in BIOS INT13 are required to be “ready” during the
BIOS power up scanning process. For removable devices, the cartridge has to be inserted in order for the drive to be ready. Please note that this option only handles devices with 512 bytes per sector and can’t handle removability of the device. For such devices, use the proper software device driver.


#10

why would you want to do that anyways?


#11

Silver X

[quote]
why would you want to do that anyways?

Do what?