Booting to DOS in XP w/ NTFS

vbimport

#1

Hello everyone. Perhaps someone can give me some educatin’. I need to flash my BTC 4012IM CD-RW and I have the firmware updates and mtkflash.exe. The problem I have is that I have WinXP Pro on my system with an NTFS file structure which is inaccessible through a real DOS boot. Does anyone know how I can accomplish this? Thanks in advance


#2

If you only need to read from the NTFS partition, then there are some boot disks available with read-only DOS NTFS drivers. There’s one here: http://pioneerdvd.rpc1.org/index.html#BOOTISO

You could also make a small FAT partition using something like Partition Magic or you could also work right off of a floppy disk.

Is your drive a BTC BCO4016IM? I would really recommend making a firmware backup before flashing, and if you could send it to me I’d appreciate it!


#3

make a bootdisk;
http://www.bootdisk.com/

use drdos7.x…and copy the files you need to flash to the disk


#4

Thank you both for your help, but I need a little more help. This is my first attempt at flashing anything, and I figured out a solution to my problem, but another has reared it’s ugly head. I copied the files (BIDEX.HEX and MTKFLASH.EXE) I recieved from BTC onto a FAT formatted floppy, but I think I’m doing something wrong. when I run MTKFLASH, it just sits there at the cursor and does nothing.

Directory of my floppy, and I run FL.BAT per BTC’s instructions.
Volume in drive B has no label
Volume Serial Number is 403C-6B50
Directory of B:\

BIDE0 HEX 141,373 08-26-02 4:12p
BIDE1 HEX 128,174 08-26-02 4:12p
BIDE2 HEX 22,422 08-26-02 4:12p
BIDE3 HEX 48,991 08-26-02 4:12p
BIDE4 HEX 149,345 08-26-02 4:12p
BIDE5 HEX 147,095 08-26-02 4:12p
BIDE6 HEX 170,050 08-26-02 4:12p
BIDE7 HEX 71,800 08-26-02 4:12p
FL BAT 308 01-13-03 12:02p
MTKFLASH PIF 2,855 05-05-03 4:33p
MTKFLASH EXE 48,828 08-21-02 3:34p
OUTPUT TXT 0 05-11-03 11:17p
12 file(s) 931,241 bytes
0 dir(s) 522,240 bytes free

Contents of FL.bat
rem ‘f means MTKFLASH 3 W /M4 bide.hex …(4banks)’
rem ‘f 4 means MTKFLASH 4 W /M4 bide.hex …(4banks)’
@echo off
if 1%1 == 1 goto default
if 1%1 == 14 goto slave
goto end

:default
@echo on
mtkflash 3 w /m4 bide.hex
goto end

:slave
@echo on
mtkflash 4 w /m4 bide.hex
goto end

:end

And to answer your question, My drive is a BTC4012IM, if you need that backup (and I can figure out how to make it work) I will be more than happy to send it to you. Thanks.


#5

Yes, please send me the backup of your firmware before the flash, and also the files from BTC. If you feel really generous I’d love to have a backup of your firmware after updating too :slight_smile:

In order for FL.bat to work, the drive must be on the secondary channel. Where is your drive connected?


#6

I will freely admit that this is where my knowledge falters. I have an IBM HDD that is on it’s own IDE ribbon (connecting it to the motherboard–whatever that cable is called)
Then I have a Creative 52X CD only drive that is “first” on the second ribbon, and then the BTC 4012IM. I therefore assume that the BTC would be the secondary slave? Seriously, I get needlessly confused by this. I can tell you what windows reports via the Device Manager, though I don’t know if it’s the info you wanted.

HDD Location 0 (0)
Creative Location 0 (0)
BTC Location 1 (1)


#7

You can use Nero InfoTool to see how your IDE devices are connected.