Bluray quality scanning specifications to aid in creating free/libre software

vbimport

#1

I am a Debian (GNU/Linux) user interested in free/libre software bluray quality scanning. Normally I use qpxtool to quality scan DVDs, but it deals solely with DVDs - I have offered to donate in order to get bluray scanning functionality, but the request has gotten nowhere so far.

Talking to the programmer behind cdrskin (the only program I’ve found to properly burn multisession BD-Rs so far), he has shown interest in bluray quality scanning, but only if he can get at the specifications associated with the standard and in some cases presumably drive-proprietary commands to do the job.

Since myce is the ‘centre of excellence’ on the net for burning, this is probably the most appropriate place for the question - does anyone here know about the specs/where to get them/how much they cost etc? Cost-wise I can then better target future donations.

Unfortunately I know nothing about burning and only a little C, so this is not a question for me.

Thanks for any help!


#2

I don’t think the specifications for scanning are available at all, however it could be possible to trace existing applications and check which commands they use.

What I do have are the commands for scanning on NEC/Optiarc drives (PDF from August 2007), but I don’t remember where I got them from and they also just include CD/DVD scanning. However Bluray scanning may use the same commands, but this will only work on Optiarc slimline drives using the NEC/Renesas SCOMBO chipsets, if scanning Bluray is supported at all.


#3

Thanks - yes he did conjecture that the commands would be similar, and qpxtool does offer some code to look at, but I doubt he’d be up for the time sink of reverse engineering stuff without specs. Regardless, I’ve pinged him about this thread.


#4

Hi,

i am said author of program cdrskin.

My tries to use SCSI command F3 on an Optiarc drive did not
get over the initial command with sub operation code 1.

The drive identifies itself as ‘Optiarc’ ‘BD RW BD-5300S’ ‘1.04’.
Medium was a closed DVD-R ‘RITEKF1’ with 2,276,543 blocks of data.
I also tried blank RITEKF1 with no better result.
Operating system is an elderly GNU/Linux.
The experiments had to be done as superuser, because else ioctl(SG_IO)
returns -1 and errno is 1 ‘Operation not permitted’.

I understand from the PDF that i should enable error reporting by
sub operation code 1. When sending and logging it, i get:

NEC/OPTIARC REPORT ERROR RATE
f3 01 00 00 00 00 00 00 00 00 00 00
+++ sense data = 70 00 05 00 00 00 00 0A 00 00 00 00 24 00 00 00 00 00
+++ key=5 asc=24h ascq=00h ( 4 ms)

I also tried to send the desired error rate period already with the
first command (although i understand i belongs to sub code 2):

NEC/OPTIARC REPORT ERROR RATE
f3 01 00 00 00 00 00 00 08 00 00 00
+++ sense data = 70 00 05 00 00 00 00 0A 00 00 00 00 24 00 00 00 00 00
+++ key=5 asc=24h ascq=00h ( 4 ms)

Am i doing it wrong here ? Is my BD-5300S suitable at all ?

My understanding is that i should perform this procedure:

  • Send sub code 1

  • Send sub code 2 with Starting LBA (e.g. 0) and error rate (e.g. 8)

  • Loop of sub code 3 commands until result LBA indicates end of track
    or until i get sense 5/21/00. These commands would give me a pair of
    error counts each. I assume result LBA advances by error rate.
    (Shall i send a non-zero Starting LBA here ?)

  • Send sub code 15

Would that be correct ?

Have a nice day :slight_smile:

Thomas


#5

The BD-5300S is a LiteOn rebadge and uses LiteOn (or Mediatek?) commands for scanning disks. But I do not have any information about these commands. With Optiarc you can probably just use slimline drives and I have no information if scanning blu-ray is supported at all. If you have an Optiarc DVD burner, you should be able to test the method you described. While I haven’t implemented error scanning myself yet, what you wrote looked OK to me. However it’s an error rate interval - not just an error rate.

I already had that “Operation not permitted” error myself. It always happens if you’re sending vendor commands (C0 to FF) to the drive. As far as I remember, this behaviour was introduced with kernel 2.6.8 and requires the executing program to run as root (or have the s-bit set and owner root)


#6

Hi,

in any case: thank you for the info.

(I wonder how many families there are of vendor specific scan commands
and why none of them made it into MMC specs.)

Have a nice day :slight_smile:

Thomas

PS:
Good news seems to be that the drive can indeed scan BD.


#7

If you download the QPX sourcecode, you can find ways to scan if you look at the plugins directories and its sub-directories.


#8

Hi,

so i will study qpxtool-0.7.1_002/plugins/liteon in the hope that
it applies to my drive. Actually i should begin by making experiments
with qpxtool, whether it works with the BD-5300.
(Functions scan_liteon::check_test() in plugins/liteon/qscan_plugin.cpp
and determine_disc_type() in lib/qpxtransport/qpx_mmc.cpp
look as if they could influence the decision what media type is
acceptable.)

In the code of qscan_cmd.cpp i see mainly command DFh.
But there is also one F3h (with second byte 0Eh).

Have a nice day :slight_smile:

Thomas


#9

Hi,

just for the records: The drive Optiarc BD-5300S is indeed handled
by qpxtool plugin “liteon”.
By a coarse hack, i could make qpxtool accept BD-R and BD-RE media.

Without the last sample, which shows very large numbers, the maxima
and the averages bear numbers which are similar to LDC and BIS
numbers in screenshots of Opti Drive Control in the web.

My report to qpxtool forum:
http://qpxtool.siteboard.org/f10t171-support-for-scanning-bluray-media-on-liteon-ihbs112-2-drive.html#p544

Have a nice day :slight_smile:

Thomas


#10

[QUOTE=Omega Weapon;2677336]Yes, v0.7.2 has the relevant functionality.[/QUOTE]

Greetings Omega Weapon.

  1. Is there a w32 build for v0.7.2?
  2. Does it work for Samsung BD drives?

Many thanks and best regards.


#11

Morning, you can see on his site that there isn’t a w32 build available. Looks like the minimum was done to officially release the 0.7.2 source it seems.

No, ShultZ implemented Liteon functionality because he had a drive and there were people like me to test it - he needed others to appear to be willing to test other drives (next question is whether he has a Samsung drive etc).

The forums back up finally!! Best to ask him in my original Liteon thread: http://qpxtool.siteboard.org/f10t171-support-for-scanning-bluray-media-on-liteon-ihbs112-2-drive.html?start=45

Or make a new thread starting the Samsung request.


#12

Thanks for the reply.

What do I need to test the software on the a Samsung drive?


#13

Sorry, I can’t help with Windows stuff (GNU/Linux user here). Your best bet is to request a win32 build on the qpxtool forum and go from there.


#14

Can it be run from ubcd?